Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Photobucket issue !?

  • This forum uses Markdown, for better or worse.
    Personally I wish it didn't, but I'm sure the authors had their reasons.
    You can force a carriage return just by typing a double space after the full stop before the carriage return when you want the next text to be on a new line.
    If you don't do that, carriage returns are indeed ignored.

    Good luck with Photobucket.
    I suspect that you'll just get the stock reply that they don't support Opera and you should use another browser!
    It is of course working fine in the "new" Opera.
    😞

  • I think PB is a little different from most "we don't support your browser" sites because we are talking about embedded pictures that can affect any site on the web. If I post a picture and the "geniuses" at PB can break it for some browsers used by other people that I want to see my picture, both now or at any point in the future (!), why in the world should I use PB?

    One of these days I'm going to look back into fixing this, but if I contacted PB I would let them know that if their site is not universally compatible for embedded pics, I will not only not use it myself but recommend that no one else use it either every chance I get.

    Technically all they need to do is serve the picture directly for certain browsers. I found that the changing the "accept" tag in the request header can cause them to serve up the picture directly rather than redirect, but then I (temporarily) lost interest in pursuing it.

  • Please do take it up again!
    If there is any chance of a fix I'm sure quite a few people would be very grateful indeed.
    I just wish I had the knowledge to do it myself!
    🙂

  • Hello Folks,

    Well, in common with most other "we'll dictate what browser you use" sites, it is clear
    that PB have no interest in providing a customer focussed service. Indeed, there is no
    "organ grinder" that you can correspond with, and worse, the monkeys are extremely rude,
    with them having little or no concept of the dificulties of disability! The company
    motivation is simple: Profit before people, regardless of the law.

    Having received a lecture on using outdated browsers and claims that changes needed to
    be made for HTML 5 conformance and "functionality", it's interesting to note that their
    home page has 22 validation errors and no less than 3 warnings! Among them that they are
    using "obsolete code". Just how weak is their argument and can you believe the arrogance?

    You can rest assured that this problem is entirely at the door of PB. The whole point of
    having a web standards compliant browser is that as long as the HTML code it encounters
    is also standards compliant, there should not be any problems! Standards compliance is
    key here, because it is "industry standards" which drive the argument. The idea that today
    any company can dictate which browser anyone uses takes us back to the bad old days of the
    1990s when there was war twixt IE and Netscape.

    This needs to be resisted at all costs. There has been tremendous advancement of both the
    technology and attitudes, clearly with notable exceptions. As for functionality, building
    sites to be WCAG 2.0 compliant makes good commercial sense because it not only enhances
    functionality, but usability too, for everyone, regardless of their (dis)ability. I've
    been told, in no uncertain terms, that they have no legal requirement to comply!

    What this really needs is someone in the USA with some clout! Sadly, I'm in the UK where
    we already know about foreign companies who believe themselves to be above the law 😞

    As for customer reaction, I fully agree that PB are not doing their best by their customers!
    Regardless of whether or not they pay for the "service", there is a clear expectation that
    their images will appear without obstruction. I would imagine this to especially apply
    to pictures of goods sold on auction sites! That the expectation is not being met is clear
    but quite how we can make people aware, I don't know. Not many people are interested in
    "how" sites work.

    Regards,
    Steve


    A Warning Note About Markdown
    If you are tempted by the little red text link, copy whatever
    you have written before clicking it. Otherwise, without any
    warning, you will lose all your current text! Appalling!!

  • I don't think there is any mandate in the law the forces a company to support old versions of web browsers in perpetuity. Especially browsers with so little market share. I think that would never fly in court. It could easily be argued to be an unreasonable burden on a business, especially considering it works fine in newer versions of that browser.

    In the latest versions there is a huge great search box with a massive Google logo, as if that is the most important aspect of being on the web. It isn't and my machine does not belong to or get sponsored by this tax evading company!

    Your computer may not be sponsored by that company but your web browser is. Last I checked every major browser but IE gets a substantial amount of income from Google. In newer versions of Opera it is generically labeled though, if that helps.

  • OK - I'm not sure if this will cause any problems for other sites, but try this in 12.17:

    • Open the opera:config advanced configuration page.
    • Go to the "Network" section.
    • Under "HTTP Accept" enter the following string:

    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/vnd.ms-xpsdocument, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash, /

    • Hit the save button at the bottom of the Network section.
    • See if Photobucket images are working.
  • Thanks Drew, that seems to fix the problem, but it breaks asp pages
    like my email and pistonheads...

    Regards,
    Steve

  • Yes, that fixes it on the forum I was mainly having the problem with!
    :yes:
    Too early to say whether it has cased any other problems, but thanks so much drewfx, you're a real star!
    Yet another example of just how great Opera 12 is, that all these sorts of workarounds can be applied when there are problems.
    🙂

  • Apparently this forum autoformatted and I didn't notice last night, but it shouldn't be "/" at the end but rather asterisk slash asterisk.

    See if that helps with any broken sites. Otherwise adding appropriate tags might work, but web development is not my bread and butter.

  • Thanks Drew. Your fix seems to be working for me too.

  • "/"
    asp. sites work now

    tnx drewfx

  • Thanks drewfx, I have changed it, although I hadn't noticed any problems with it the way it was before.
    Hopefully it will fix the problems that lowiepete was apparently having.
    🙂

  • OK, I'm glad it seems to be working for everyone (knock on wood)! Please post if this is still causing problems.

    I'm going to rewrite the instructions here, with hopefully the correction showing properly by delimiting the asterisks, to make it easier if we want to refer to it in the future.

    Workaround fix for Photobucket embedded images not displaying in 12.17

    I'm not sure if this will cause any problems for other sites, but try this in 12.17:

    • Open the opera:config advanced configuration page.

    • Go to the "Network" section.

    • Under "HTTP Accept" enter the following string:

    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/vnd.ms-xpsdocument, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash, */*

    • Hit the save button at the bottom of the Network section.

    • See if Photobucket images are working.

  • Thank you very much drewfx!
    I'm very annoyed by those who always answer "move to the new opera". New Opera has actually nothing of that I'm loving in 12.17.
    I don't know if in the future the "new opera" will reach the "old opera", and I hope yes, but actually the "new opera" is simply "no longer opera".

    Back to your solution, it works in the way you posted as it works (at least to solve my problems) by adding only

    image/gif, image/jpeg

    Again a big THANK YOU!

  • Ehm, I wrote a silly thing... asp websites no longer working without the whole drewfx's string.

    Happy Easter to you all.

  • Yep, drewfx nailed it. BIG thanks!
    In your face Photobucket! In your face Google thieves!
    Opera 12.17 proves again it has invaluable, flexible embedded configuration tools to adapt to any situation.

  • Hi, after searching for a solution I landed here. Initially I fell at the first hurdle when following drewfx's steps. Clicking on the Tools menu, then selecting advance I see options for : Cookies, Password Manager, Blocked Content and so on but no Config option. What am I missing here?

    Keen to try and resolve this one way or another I opened OperaDef6.ini in MS notepad (having made a backup copy first of course) file which contains the following entry:

    [Adv User Prefs]
    HTTP Accept=application/x-shockwave-flash,text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,/;q=0.1

    I cut everything after the equals symbol and pasted the suggested replacement string:
    image/gif, image/jpeg, image/pjpeg, application/x-ms-application, application/vnd.ms-xpsdocument, application/xaml+xml, application/x-ms-xbap, application/x-shockwave-flash, /

    I saved the text file as .ini, closed and restarted Opera and opened a web page some embedded Photobucket images but the image still fail to load. Can anyone give me some further guidance to help me solve this please?

    Thank you.

  • You need to use the configuration editor page rather than editing the ini file directly.
    Put the original version back (with Opera closed) and then run it again and type "opera:config" (without the quotes) in the address bar and go to it.
    This should open the configuration editor page.
    Expand the "network" section and then find the "HTTP Accept" entry.
    Press the "default" button on the entry, which will probably clear it, and then copy and paste the necessary string into it, and press the save button at the bottom of the section.
    That should do it!
    If there is anything already in the HTTP Accept section, which your ini file seems to imply that there is, I'm not sure why that would be as I'm pretty sure that by default it's empty.
    It is possible that you may lose other functionality if any existing entries are cleared.
    🙂

  • Thank you very much for taking the time to explain the steps in more detail. Until now, I wasn't aware of this hidden advanced configuration page, so I've learned something new.

    I followed your steps and all is working as expected which is great.

    The "HTTP Accept" field was empty despite the OperaDef6.ini file having this entry filled so clicking Default didn't change anything and it remains unchanged after entering and saving these changes.

    A big thank you to drewfx for posting a working solution to this issue.

    Thanks guys.:)

  • These settings appear to prevent HTTPS web pages from loading coreectly. I'm unable to connect to instagram or my bank when these setting are in place, if I restore the default settings(empty field) and save I can load the aforementioned pages.

    Please see this thread for some more details:
    https://forums.opera.com/topic/9216/opera-12-17-instagram-issue/1

    Could this string be amended to fix this issue please?

    Thank you.

Log in to reply