Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera fails if there is no Password Keyring

  • I sometimes run Ubuntu on a Live USB and on many of those occasions I used to experience Opera becoming frozen after just enabling VPN. Recently with the most recent Opera v77 I noticed that Opera sometimes was not even opening any visible window. I downgraded to Opera v70 and noticed on Ubuntu logs that that this error remove_mnemonics: assertion 'label != NULL' failed was the only one logged just after clicking on VPN. Researching I found that it seemed to be related with Opera demanding access to Ubuntu keyring. After reading I tried running Opera with command opera --password-store=basic and it worked. Now old versions of Opera do not freeze when clicking on VPN and the newer Opera versions (v77, etc.) does actually open.

    So after partially found the problem and a solution I think that I have actually find the real problem. There was no Password Keyring. After adding it, opera was running properly without the need of using --password-store=basic argument. I deleted the password added, open again Opera and now a password was prompted for "Default keyring". Password added and again Opera and VPN running successfully.

  • I think that instead of using --pasword-store=basic , running command gnome-keyring-daemon should help ("unrelated" source that helped me to find this solution: )