Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Well, you lot at opera have done it again.

    I had previously posted about the Flash Player popup message (let us turn off that flash announcement popup) which finally sorted itself out when Opera updated to 74.0.3911.75.
    But now, tabs are being snoozed regardless of whether the option is turned on or off in settings. So well done, you have replaced an annoying problem with a bloody annoying problem.

    Sort your act out.

    By the way there is another post mentioning this and they are running Opera 75.0.3939.0 developer update, so this problem must have been around for some time.

  • I found an extension suggested by burnout426, Disable automatic tab discarding:
    https://chrome.google.com/webstore/detail/disable-automatic-tab-dis/dnhngfnfolbmhgealdpolmhimnoliiok
    I have installed it and is working fine, tabs are not being snoozed any more. I will test it further and report back if it stops working or any problems arise.

  • @gizmogadget I agree. I keep selecting 'disable tab snoozing' and Opera still snoozes tabs. It's affecting my work so I've had (reluctantly) to switch to another browser.

  • @wickedaunt Try the extension, have had no problems with it, it just sits there doing its thing with no settings to worry about.

  • opera is never going to allow us to disable tab snoozing. the whole point of snoozing background tabs is to force us to watch ads on youtube (the most commonly used site in the background). the "save memory" excuse is just a farce to cover up the real motivation.

    i honestly expect the "disable tab snoozing" setting will simply disappear in a future update. it's probably only still there so that google can test to make sure that ad-revenue sites never snooze.