Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera stable 70 - news

  • Oh well, if you have HWA disabled, Google Maps 3D does not work (no Globe option).

    So now I must choose between normal functionality and correct color reproduction
    (as close as you can in WIN10 browser outside Adobe environments, that for my setup was forced sRGB).

  • @vegelund said in Opera stable 70 - news:

    I have been trying to get forced sRGB back to see correct colors on my monitor.

    This is the solution I’ve found on Opera 70.0.3728.71, Windows 10.

    Add --force-color-profile=srgb to target line after Opera\launcher.exe
    Turn off hardware acceleration.

    If HWA is on, colors briefly flash correctly upon browser startup, but then revert to duller presentation.
    So, for some reason HWA influences color management.


    I had the same problem of colours briefly correcting and then reverting to dull. This was when I used --force-color-profile=dcip3

    I then tried --force-color-profile=argb, and this has made the wide color gamut permanent.

    Of course, it does not make sense why this should make a difference, but it seems to be the case.

    I did not try srgb, and I am loathe to try anything else in case it breaks the current working situation, so sorry about that.

    I have HW acceleration turned on.

  • Thanks, I tested but to no avail.

    Since #force-color-profile is back in latest Chrome, I expect it to return in Opera soon.

    @l33t4opera said:

    you can try to run the Opera with "--force-color-profile" switch, for example --force-color-profile=srgb.

    Am I doing correct by editing the shortcut?

    C:\Users\vegel\AppData\Local\Programs\Opera\launcher.exe --force-color-profile=srgb

    Opera.exe does not have a target field to change:


  • @vegelund Are you per chance launching Opera by clicking the automatically created shortcut on the desktop or pinned to taskbar? That shortcut generally points to the specific Opera ver 70.0.3728.71 etc, instead of to the launcher.

    Try creating a shortcut to the launcher itself, on your desktop or taskbar, and launch Opera using that. In that case the argument appended to the launcher shortcut should apply.

  • @odinprokhozhiy Perhaps it wasn't clear enough. In point 3 I meant the "2.15x" folder, which you need to copy outside the "Extensions" directory, and rename it to something else. It should work, it's working here. Anyway, since you are reverted to Opera 69 and you are fine with it, it's ok. However, please keep in mind, that it's not recommended to use older main version mainly for the security reasons.

  • @vegelund It looks correct. It could be wrong, if the path to the launcher.exe includes some spaces. In that case, you should put it within "...".

    Anyway, have you tried already to enable another flag the "opera:flags#forced-colors" ? Some people say, that it helped them in such of cases.

  • @l33t4opera Thanks.

    Opera\launcher.exe --force-color-profile=srgb has a space between .exe and --force

    No space or ... is not accepted. #forced-colors does nothing on my system.

  • @vegelund The space beetwen the path and switch is mandatory - necessary to make is work. If there's no spaces in the path, the quotation marks should not be needed.
    The flag seems to be working here with or without quotes, also with different values e.g. "color-spin-gamma24".
    Maybe you can check if it works, when you put "srgb" in quotation marks.
    Anyway, AFAIK "srgb" may not work for every graphics card.

  • No worries, I’ll just wait for #force-color-profile to return.

    sRGB has always worked before under normal settings, HWA on.

    Chrome 84.0.4147.105 has it.

  • @vegelund I have read your previous comments now, so it's working for you when the HWA is disabled?
    Yes, the flag is present in the latest Chrome stable and beta (85.0.4183.48), but not in Opera stable/beta. Perhaps it's disabled for some reasons in the Opera, or it's just a matter of different versions of Chromium.
    Nevertheless, there should not be a difference if you enable the feature thought the flag or using the switch, if it works it should work in both cases.

  • With HWA on, switch is not working. Flag worked as intended before removed.

  • @vegelund Can you leave the HWA enabled, and launch the Opera with "--disable-gpu-compositing" switch, and then with "--disable-dwm-composition" (one at the time). Does any of that help? I mean if you run it together with "--force-color-profile" switch. Don't forget to add a space between the switches too.

    Edit: They say here the issue is fixed on Chrome .105 for all platforms, so it looks like it should work also in the Opera, when it will be updated to that Chromium version. Of course if it's the same issue as in your case.

  • @iamkarthik, @vegelund The flag #force-color-profile is back in the stable .95, so you can update and check if it works for you ;-)

  • New build (also security update) - Opera stable 70.0.3728.95 ;-)
    The change log and the announcement.
    It includes a small stability update and other minor fixes.
    Chromium is updated to version 84.0.4147.105.
    ☕   🖖   🍺

  • @l33t4opera said in Opera stable 70 - news:

    @iamkarthik, @vegelund The flag #force-color-profile is back in the stable .95, so you can update and check if it works for you ;-)

    Jolly good! Thanks for your support and update @l33t4opera

    #force-color-profile is back in opera://flags/ and all is well. 🙂

  • New, minor update - Opera stable 70.0.3728.106 ;-)
    The change log and the announcement.
    ☕   🖖   🍺
    @vegelund You're welcome ;-)

  • @leocg Allowing users to search in their open tabs shouldn't require the replacement of an efficiently designed core feature with a version that's slower, more difficult to use, and less efficient.

  • Small update - Opera stable 70.0.3728.119 ;-)
    The change log and the announcement.
    ☕   🖖   🍺

  • DNA-88215 Introduce easy-setup-hint-ref feature flag

    I can't find the flag.

  • @andrew84 Probably not a visible one.

Log in to reply