Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera stable 70 - news

  • Hi,

    The opera://flags/#force-color-profile seems to have disappeared. The browser is now unable to use the color gamut of my monitor fully. Colors look drab compared to how they were previously.

  • @odinprokhozhiy If you want to try a workaround for your extension (it should make it work from the toolbar), you can follow the below steps:
    1. Download "manifest.json" and "neat.css" (also "neat-dark.css" if you use the dark theme) from here,

    2. Run the Opera, go to opera:about, and make a note of the path to profile (or copy it), close the Opera,

    3. Open your file explorer, navigate to that path, open "Extensions", there you should see "nfmcmkgigcijhkhpogobfhkdokdecjmb" and under it "2.1.5_0". Copy it to somewhere else, but outside "Extensions" (that is important to make it work) - you can copy it to Opera's profile folder, then rename it to e.g. "bmsbyside",

    4. Open the renamed folder, delete "_metadata" subfolder, and copy the downloaded files to it (overwrite the original files),

    5. Run the Opera, go to Settings > Extensions (Ctrl+Shit+E), and disable your installed extension (to don't be confused, when you enable modified one).
    Enable "Developer Mode", click "Load unpacked", select the "renamed folder", and click "Open".

    Now, you should see it on the list as "Bookmarks by the Side - toolbar", and you should be able to use it from the toolbar.

  • Hi @iamkarthik, you can try to run the Opera with "--force-color-profile" switch, for example --force-color-profile=srgb.
    The other accepted values can be e.g. "generic-rgb" or "color-spin-gamma24".

  • @l33t4opera said in Opera stable 70 - news:

    Hi @iamkarthik, you can try to run the Opera with "--force-color-profile" switch, for example --force-color-profile=srgb.
    The other accepted values can be e.g. "generic-rgb" or "color-spin-gamma24".

    Hi, thanks. I've done just that. I used "argb" (which I assume is how to write adobe RBG) and the colors pop now. A bit too much actually, I didn't realise my browser colors could be so saturated (⊙_⊙;). I was on DCI-P3 previously.

  • @l33t4opera Thank you, but it did not work for me. I must have done something wrong. However now I've restored Opera v69 and now everything works fine, so don't worry.

  • @iamkarthik said in Opera stable 70 - news:

    The opera://flags/#force-color-profile seems to have disappeared. The browser is now unable to use the color gamut of my monitor fully. Colors look drab compared to how they were previously.

    +1, I also miss #force-color-profile flag.

    In Chrome 84.0.4147.105 it is there.

  • I have been trying to get forced sRGB back to see correct colors on my monitor.

    This is the solution I’ve found on Opera 70.0.3728.71, Windows 10.

    Add --force-color-profile=srgb to target line after Opera\launcher.exe
    Turn off hardware acceleration.

    If HWA is on, colors briefly flash correctly upon browser startup, but then revert to duller presentation.
    So, for some reason HWA influences color management.

    Source: https://techdows.com/2020/07/chrome-84-force-color-profile-srgb.html

  • Oh well, if you have HWA disabled, Google Maps 3D does not work (no Globe option).

    So now I must choose between normal functionality and correct color reproduction
    (as close as you can in WIN10 browser outside Adobe environments, that for my setup was forced sRGB).

  • @vegelund said in Opera stable 70 - news:

    I have been trying to get forced sRGB back to see correct colors on my monitor.

    This is the solution I’ve found on Opera 70.0.3728.71, Windows 10.

    Add --force-color-profile=srgb to target line after Opera\launcher.exe
    Turn off hardware acceleration.

    If HWA is on, colors briefly flash correctly upon browser startup, but then revert to duller presentation.
    So, for some reason HWA influences color management.

    Source: https://techdows.com/2020/07/chrome-84-force-color-profile-srgb.html

    I had the same problem of colours briefly correcting and then reverting to dull. This was when I used --force-color-profile=dcip3

    I then tried --force-color-profile=argb, and this has made the wide color gamut permanent.

    Of course, it does not make sense why this should make a difference, but it seems to be the case.

    I did not try srgb, and I am loathe to try anything else in case it breaks the current working situation, so sorry about that.

    I have HW acceleration turned on.

  • Thanks, I tested but to no avail.

    Since #force-color-profile is back in latest Chrome, I expect it to return in Opera soon.

    @l33t4opera said:

    you can try to run the Opera with "--force-color-profile" switch, for example --force-color-profile=srgb.

    Am I doing correct by editing the shortcut?

    C:\Users\vegel\AppData\Local\Programs\Opera\launcher.exe --force-color-profile=srgb

    Opera.exe does not have a target field to change:

    C:\Users\vegel\AppData\Local\Programs\Opera\70.0.3728.71\opera.exe

  • @vegelund Are you per chance launching Opera by clicking the automatically created shortcut on the desktop or pinned to taskbar? That shortcut generally points to the specific Opera ver 70.0.3728.71 etc, instead of to the launcher.

    Try creating a shortcut to the launcher itself, on your desktop or taskbar, and launch Opera using that. In that case the argument appended to the launcher shortcut should apply.

  • @odinprokhozhiy Perhaps it wasn't clear enough. In point 3 I meant the "2.15x" folder, which you need to copy outside the "Extensions" directory, and rename it to something else. It should work, it's working here. Anyway, since you are reverted to Opera 69 and you are fine with it, it's ok. However, please keep in mind, that it's not recommended to use older main version mainly for the security reasons.

  • @vegelund It looks correct. It could be wrong, if the path to the launcher.exe includes some spaces. In that case, you should put it within "...".

    Anyway, have you tried already to enable another flag the "opera:flags#forced-colors" ? Some people say, that it helped them in such of cases.

  • @l33t4opera Thanks.

    Opera\launcher.exe --force-color-profile=srgb has a space between .exe and --force

    No space or ... is not accepted. #forced-colors does nothing on my system.

  • @vegelund The space beetwen the path and switch is mandatory - necessary to make is work. If there's no spaces in the path, the quotation marks should not be needed.
    The flag seems to be working here with or without quotes, also with different values e.g. "color-spin-gamma24".
    Maybe you can check if it works, when you put "srgb" in quotation marks.
    Anyway, AFAIK "srgb" may not work for every graphics card.

  • No worries, I’ll just wait for #force-color-profile to return.

    sRGB has always worked before under normal settings, HWA on.

    Chrome 84.0.4147.105 has it.

  • @vegelund I have read your previous comments now, so it's working for you when the HWA is disabled?
    Yes, the flag is present in the latest Chrome stable and beta (85.0.4183.48), but not in Opera stable/beta. Perhaps it's disabled for some reasons in the Opera, or it's just a matter of different versions of Chromium.
    Nevertheless, there should not be a difference if you enable the feature thought the flag or using the switch, if it works it should work in both cases.

  • With HWA on, switch is not working. Flag worked as intended before removed.

  • @vegelund Can you leave the HWA enabled, and launch the Opera with "--disable-gpu-compositing" switch, and then with "--disable-dwm-composition" (one at the time). Does any of that help? I mean if you run it together with "--force-color-profile" switch. Don't forget to add a space between the switches too.

    Edit: They say here the issue is fixed on Chrome .105 for all platforms, so it looks like it should work also in the Opera, when it will be updated to that Chromium version. Of course if it's the same issue as in your case.

  • @iamkarthik, @vegelund The flag #force-color-profile is back in the stable .95, so you can update and check if it works for you ;-)

Log in to reply