Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I have serious issue. The flow stopped working for me since I updated browser. Also I couldn't update via Update tab. It said:

    Your version is 69.0.3686.77
    Checking for updates…

    Check for update

    The "Check for update" button was greyed out and I couldn't do anything. And the checking could be like that forever. It's still like that.
    After I downloaded Opera 69 manually, I can't set up flow. My PC just stopped working, even if I already had paired it. I can't pair it, even if I removed all the devices. No matter if I update via scan or manually write the code. It's like that since the update.

    Both version (Opera Touch and Opera for Windows) are the newest versions. I even manually re-downloaded Opera from the main site (because automatic update still doesn't work for me).

  • The latest version of Opera doesn't work on LTS Ubuntu 16.04 Xenial or any of the variants that are built upon it, e.g., Linux Mint 18.x. Why? Because the new Opera unnecessarily uses a version of libgtk later than that of Xenial which doesn't reach its end of support until next April. Opera 69 needs libgtk-3.19.12 and Xenial only has libgtk-3.18.9 which is difficult and dangerous to upgrade and not something to do rashly, certainly not to run one particular application no matter how good it is. There are thousands and thousands of Xenial users out there which use Opera that now cannot install the latest and later versions of the browser using APT or from DEB packages without taking them apart, altering and rebuilding them so that they can be installed and made to work with libgtk-3.18.9. Opera 69 does work with Xenial's version of libgtk for the most part apart from an issue with the drop-down menu accessible via the Opera button, namely the option highlight is dark and opaque.

    If the next version of Opera could be tweaked to use libgtk-3.18.9, at least until Xenial's support ceases, the browser could be updated and installed as before pretty much automatically, with the operating system, via APT. Thousands upon thousands of longstanding Opera users who have relied on that browser for years would be grateful I assure you.

    Thank you.

  • @darroch As far as know, that is a Chromium dependency.

  • Is there a way I can add Ecosia as my main search engine?

  • @manu There isn't.

  • @leocg: The latest version of Vivaldi, based on Chromium 83.0.4103.119, installs and works perfectly on Xenial. And Opera 69 also works on Xenial without much of a problem, the only thing wrong seems to be a missing highlight bar on the Opera menu not being visible when using the Opera's dark theme. Because Opera is so good I am willing to download DEB packages manually and rebuild them, so that they install in the usual way, to run on Xenial until something else changes or Xenial's support ends in April 2021. Still, it would have been nice if Opera 69+ could have been finessed to enable it to update with the operating system, rather than manually, because a lot of people won't be bothered to unpack, alter and repack the DEB package to keep Opera, which is a pity because it really is the best browser in the world in my opinion.

  • you just deleted all my speed-dial bookmarks to force some crap i dont want upon me 😠 not f'n happy

  • It doesn't work like that. If they want to add new speed dials none of the old ones are removed.

  • you might think that @sgunhouse, but you fail to realise that as an >insert authority fallacy here< on this subject, i know what i am looking at, its a blank speed-dial page

  • @shaneyshane Did you already checked the topic about it? The Speed Dials are probably in Other Speed Dials in the Bookmarks page.

  • Can I disable this snapshot feature with Print Screen shortcut? Because I use Windows 10 snap tool, it uses same button.

  • @forzimus Snapshot doesn't use PrintScreen shortcut.

  • Best browser of all time. Love it.

  • I can't see "tabs from other devices" button, shouldn't I?

  • @balcis If you have sync enabled and synced opened tabs, yes. However, as said before, that button is kinda erratic.

  • Any mod would provide me some solution to what do I do to make my Flow working again? I can't connect no matter what.

  • @smokofenek If you explain the problem, maybe someone will be able to help you.

  • @leocg Well, I explained it few comments above, 3 days ago.
    Just Flow stopped working after updating Opera. And I also had to update Opera manually, because it won't let me do it by the Update tab. More info in previous comment.

  • Alt + Space was a terrific shortcut, why did you take ir off?! 😞 Please, if could be a way to enable it, would be great. And the button of last tab closed, also. I don't get why some people could not love those options, I was so habituate to use them. Thanks!

  • @petrugenio Instant Search is gone