Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Sidebar constantly re-enables itself

  • Re: Sidebar shows every time i run Opera
    Every time I open Opera, the sidebar is there, despite me disabling every single time I see it.

  • Goto the URL opera://about and take note of the "profile" path. Then, close Opera.

    Use JSONedit to edit the "Preference" file in the profile folder. Under root/ui/browser, right-click on "sidebar" and choose "delete selected node". Then, save your changes.

    That should rule out anything messed up with the sidebar settings (especially if you've been upgrading Opera for a long time). The section will get recreated fresh, which should help.

    Then, start Opera, hide the sidebar, close Opera and start Opera again to see if it sticks now.

    Which way are you hiding the sidebar though? Are you doing it via the Easy-Setup button or by clicking the 3 dots at the bottom of the sidebar and disabling "show sidebar" or by right-clicking the sidebar and choosing "hide sidebar"? Just asking as the 2nd method works fine for me to keep it hidden.

    Once you get things working though, you might want to show the sidebar again, click the 3 dots at the bottom, disable everything on it, and then hide it again. Then, goto the URL opera://settings/privacy and disable "Display promotional notifications". Then, goto the URL opera://flags/#history-onboarding, disable the flag and restart Opera. These are just guesses that might stop the sidebar from appearing. But, it might still appear again now and then when a new feature is added to it. But, it shouldn't appear on every single start of Opera.

  • That helped! Thanks so much

Log in to reply