Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flash Videos in Opera Laggy/Choppy/Stuttering... How to Fix?

  • I was using Kaspersky before I formatted. Now I just use the built-in Microsoft Security Essentials. I know it's not very thorough, but I guarantee I have no viruses or malware on this system.

  • Ok, I was just asking because in my PC Avast was giving me problems. For 480p (and higher) videos NPAPI Flash on Opera uses ~80% of my CPU and if I left Avast enabled the process manager would point to it using +25% of the CPU as the video streamed and that split is impossible of course it means it went above 100% of CPU usage in total, delaying processing causing lag/stutter.

    It occurred with NPAPI Flash, it was very bad on Firefox too. While with PPAPI Flash (beta version in the Dev Opera stream) it was normal like other browsers (up to ~10%) and Opera could "breath".
    IE uses ActiveX Flash and Chrome uses PPAPI so that's why they were not affected.

    I don't know how Avast is behaving now because I just "refreshed" Win8.1 and didn't install additional protection yet.

    It's better that you enable the hardware acceleration back for best performance.
    Are your graphic card drivers ok?

    Another suggestion: maybe you should try Opera Developer with the PPAPI Flash beta.

  • Thank you for your advice.

    I apologize, it would have been helpful to have provided my computer's specs earlier. Here are the basics:

    Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
    8.00 GB RAM
    64-bit Windows 8.1, x64-based processor
    NVidia GeForce GTX 670

    I notice that ActiveX seems to have the best performance for me, as well as PPAPI on Chrome. I notice such smooth videos on those browsers, but aside from video playback, I love Opera the most. I like the interface and the aesthetics as well as the speed and performance.

    I tried Opera Developer for a bit but I didn't give it much time. I also had tried Opera Next, but I had the same issues on that one. I will try Opera Developer again, and I am very grateful for all your help. I hope I can get videos to play smoothly on Opera.

  • When playing videos in Opera what do you see taking up the CPU in the Windows task manager?

    My PC is pretty old... I'd think yours would have no problems... Unless you're playing in 1080p.

    It might be good to try PPAPI in Opera Dev. You have to make sure to have it enabled in opera:plugins (and the NPAPI one disabled).

  • I've been using the same video at 720p to test the stuttering issues. Playing at 720p in windowed mode, my CPU went as high as 45%. After enabling PPAPI and removing NPAPI, I am noticing some improvement. Every now and then, there is stuttering, but it's quite a bit less than what I was experiencing before. Also, sometimes when I rewind the video, it plays very smoothly.

    Judging by the fact that this is developer mode and the flash plugin is in beta also, I believe this route is the key to solving the problem. To just test, I disabled hardware acceleration not only through Adobe Flash's settings in the context menu, but also in Opera's main settings as well as in opera://flags. I didn't notice any differences, so I re-enabled those.

    Thank you for the help, videos are watchable now!

  • I'm having the same issues.

    When hardware accelaration is enabled, i get stuttering, choppy picture. Its not constant, but pretty apperent. Using the latest version (30).

    My platform is using Intel Atom Z3735F with Intel HD graphics. I'm using the latest intel drivers.
    Disabling accelaration makes the issue go away, but this is not desirable, because CPU on its own isnt all that powerful and quite struggles with higher resolution videos.

    Also, HTML5 for some reason doesnt work with youtube.

    I tried with firefox and html5 and hardware accelearation work like a charm. But i want to stick with opera.

  • I am having the same issue.

    I believe we can rule out the possibility that you are having something "unique" wrong with your system. What's happening here is Windows 10 + Flash + Opera. I'll stay tuned until someone finds a fix.

    Opera Version: 30.0.1835.125

    I'm using Z97X-SOC Force with i5-4690k & GTX970 as my computer.

  • I, too, am having the same issue. Only since Windows 10 upgrade. Only on Opera, not Edge, not Firefox, not Chrome. I've reported it to Opera twice and haven't heard anything back. It's still broken as of today 09/13/2015. I've tried the fixes listed here and they don't work. Happens on YouTube as well as embedded videos. I like the speed dial in Opera but it's annoying when an embedded video starts to play and the audio is so choppy. I have to go to another browser.
    Opera About = "Version: 31.0.1889.174 - Opera is up to date Update stream: Stable System: Windows 10 64-bit (WoW64)"
    Like 'freezeware' above, I'll stay tuned until someone finds a fix.

  • Sounds like everyone's picking on Opera again. Purposely coding their web sites to work well with "mainstream" browsers like Internet Explorer & Firefox & Chrome and not worrying too much if their web sites work properly with anything else.

  • In my system and Opera, i found that disabling 'Media Source API' in opera://flags/ helped with high CPU at the beginning of the videos. This applied at least html5. Then enabling 'Hardware acculator' in settings helped even more to low down CPU.

    Btw, in Opera 31 there was some glitches with YT html5 when HWA enabled, but 32 update fixed it.

  • I have the same issues, but funny enough, only when I move my mouse.
    Firefox plays fine, but Chrome does the same as Opera.

    I have a i7 7700k, Geforce GTX 1080 and 16GB RAM.
    My laptop, which is an i7 4600U, Intel on-board GPU and 8GB RAM plays everything fine.

    If anyone knows what's going on, please help, as I love Opera.

Locked