Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon)

  • HI))

    Users of the Linux version of the Opera browser face the problem of playing some videos. For example, Opera refuses to play streaming on Youtube or native videos on Twitter
    Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon, etc)

    Playback errors look like this:

    Currently your browser does not recognize any of the available video formats
    This is the kind of error you can see when you try to watch a live broadcast on Youtube. However, some other videos may only be available as 360, without the ability to improve the playback quality.

    You cannot play the video in this browser. Try a different browser
    This message can be found when viewing a video on Twitter. We will not change the browser, this is not our way. But we will tell you about an easy solution to this problem.

    We fix the error of video playback by the Opera browser in Ubuntu distributions and the like
    First of all, you need to install the chromium-codecs-ffmpeg-extra package. You can do this using the terminal with the following command:

    sudo apt install chromium-codecs-ffmpeg-extra

    Usually the second step is to create a symlink for the file, but since now the Opera browser delivers a file with this name (but not solving the problem), we will delete it and then create a simlink to the new file. File deletion:

    sudo rm /usr/lib/x86_64-linux-gnu/opera/

    Creating a simlink:

    sudo ln -s /usr/lib/chromium-browser/ /usr/lib/x86_64-linux-gnu/opera/

    When will it be fixed ?

  • @vladimir-bardakov As said before, this is not a technical issue but a legal one. So it can't be fixed, at least not easily.

  • Hey guys, I tried this workaround but even though chromium-codecs-ffmpeg-extra is installed on my computer (Linux Mint 20), there is no /usr/lib/chromium-browser directory.

    Any idea where to get the correct

  • Got it! I needed to install the chromium-ffmpeg snap. It comes with a bunch of's in a number of folders, all of which you can find in ~/snap/chromium-ffmpeg. I linked this one:

    sudo ln -s /snap/chromium-ffmpeg/15/chromium-ffmpeg-95241/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/

    Did the trick!

  • Can confirm this solved the issue for me.
    I figured out how to use snap library, as @mr-matt-eastwood suggested.

    On Manjaro Linux 20, opera directory is /usr/lib/opera.
    You don't have to delete original file, but just rename it to whatever (including extension).


    # If you cannot use sudo -i, then just prefix your commands with sudo
    sudo -i 
    # Close your browser by hand. Following command will ensure no Opera processes are running in the background
    killall opera
    cd /usr/lib/opera
    # Some software automatically loads any .so/.dll file that is present. Not sure for Opera, but just in case
    mv libffmpeg.so_original
    snap install chromium-ffmpeg
    # Please note that chromium-ffmpeg-95241 path might differ. Just pickup one with highest number. 
    ln -sf /snap/chromium-ffmpeg/current/chromium-ffmpeg-95241/chromium-ffmpeg/

    Works like charm.

  • Seems like any file will do - other than the one that ships with my Ubuntu Opera packages!!
    I'm currently using the that came with the vsCode snap, and it seems I need to be updating the link after each Opera security update.

    I'd like to join the choir of people demanding Opera fix this issue.

  • @vladimir-bardakov
    Linux Mint 20 Cinnamon, Opera v.70 without Chromium browser
    $ sudo snap install chromium-ffmpeg
    in my OS the command and paths are:
    $ sudo cp /snap/chromium-ffmpeg/15/chromium-ffmpeg-9xxxx/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/
    9xxxx - there is a few of them, I chose 95241 only because I thoubht the higher number=latest version. Can't say it's true for sure.

  • @leocg -- I came in late to the game. Can you please give a link or reference to the legalities?

    Other browsers do not seem to have this trouble. Are they breaking the law?

    I'm sortof new to Linux, but would love to use my favorite browser --Opera.

    All of the suggestions to make it work seem really strange and weird. To my simplistic thinking they should be unnecessary.

    Please help me understand.


  • @cedarviola See

    Browsers like Chrome, Edge and IE for sure can afford buying a license.

  • Hello,
    I am trying to solve this problem with my Ubuntu 20.04 LTS. all above suggestions don't work with me.
    I have the chromium codecs installed and I can find them in my /snap/chromium.....etc folder. I also can find the opera installed in my /snap/opera/current/user/lib/x86_64-linux-gnu/opera folder.
    problem is I cannot remove the not working file since it is read only. Therefore i also cannot link the new one to the old one.
    I don't know how to solve this. (FYI I am a kind of newbie on this linux)
    Please help. Thank you.

  • This is what worked for me in Debian 10:

    [*]Install chromium-ffmpeg snap:
    $ sudo apt update
    $ sudo apt install snapd
    $ sudo snap install core
    $ sudo snap install chromium-ffmpeg

    [*]Keep the original file in /usr/lib/x86_64-linux-gnu/opera/ and create inside there a directory lib_extra:
    $ sudo mkdir /usr/lib/x86_64-linux-gnu/opera/lib_extra

    [*]Create a symlink in the lib_extra directory of the snap latest version

    $ sudo ln -s /snap/chromium-ffmpeg/current/chromium-ffmpeg-98516/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/lib_extra

    Note: the latest version in my case is 98516, make sure to check yours inside directory /snap/chromium-ffmpeg/current/

    After these steps Opera browser plays all kinds of videos i've come across.

    Thanks to @mr-matt-eastwood and this post that provided the solution steps!

  • @zarathustra-f90 said in Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon):

    sudo ln -s /snap/chromium-ffmpeg/current/chromium-ffmpeg-98516/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/lib_extra

    Thank you for your help.
    I tried to follow your instructions, but I had to adjust the location of opera.
    I installed thru snap and therefore /usr/lib/x86_64-linux-gnu/opera did not exist.
    It was installed in /snap/opera/current/usr/lib...etc
    Finally I removed opera and reinstalled. Now it was located in /usr/lib/....
    Then I followed your instructions to make a new directory and linked the lbffmpeg file.
    Result: It works !!
    Now I can use the beautifully designed Opera browser.
    Thank you foryour help.

  • @vladimir-bardakov The second step of your solution (sudo rm /usr/lib/x86_64-linux-gnu/opera/ produces an error about shared libraries, at least in recent Opera versions.

    This file must remain and as an extra step create a lib_extra directory inside /usr/lib/x86_64-linux-gnu/opera/lib_extra where the symlink must be placed.

    You can see my other detailed comment about the workaround in Debian 10. Many thanks for creating this post and part of the solution!

  • So Opera is not Linux compatible, that's my conclusion ...

  • Use latest ffmpeg deb files and all your problems will become the things of the past. You may peep into deb file and copy your file manually. As GNU/Linux users you should know all the priv issues, I hope.

    Do not delete lib_extra/*.so file. Name it *.so.old, then copy there *.so latest file, name it * Then
    ln -s * *.so

    • = libffmpeg

    [Fig. 1] MC Root (hence red) 🙂

    [Fig. 2] Oper view of Opera Developer nooks

  • If I have the same problem with Opera, Firefox and Brave, does this give a diagnosis ?
    It seems that for videos and video streams, they want or not want to accept Flash, but are unable to use another possibility, is that correct ? the question is why ?

    I am on Mint 19.3 64 and I allready have FFMPEG , so if I install FFMPEG by SNAP or by the deb, will this be fixed ? Do i have to uninstall the current FFMPEG before this ?

    or is this a problem with graphics, it is an APU AMD with no real good driver for it, must I try the AMD Driver ? 3D and HD video seem good working though, but not Nemo ...

  • My previous solution still works, but you might lose the changes (symlink) when Opera gets updated. At least that happened in my case. Applying the solution manually every time is a pain.
    You can use this handy script to fix ffmpeg support for you, whenever it gets broken.

    Fetch the always up to date script from here, or simply use this command to directly download the script:

    curl -fsSL -o

    Remember: When downloading the script from the internet, it is always a good idea to inspect the script first.

    Run with:

    sudo /bin/bash


    sudo /bin/bash /path/to/your-opera-installation

    The script will install or update snap chromium-ffmpeg and create symlink to latest bundled, in your opera directory.

    Note that sudo is required.
    Tested and working on Linux Manjaro. Should work for other Linux distros as well.
    Disclaimer: This script is provided as-is. Use at your own responsibility.

  • This post is deleted!
  • @annevance Indeed I have more video playbacks, but the live tv broadcasts which I watch with the VPN of that country still don't work on Opera, giving a DRM error.
    When this is not solved the browser is useless, unfortunately.

  • @annevance Give a try to my script above (very last post).