Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon)

  • That fixed the issue for me

    wget -P ~/Downloads/
    unzip ~/Downloads/ -d ~/Downloads/
    sudo mv ~/Downloads/ /usr/lib/x86_64-linux-gnu/opera/
  • @mau21mau Confirmed!. Your method works. Last version of Opera nd Linux Mint 20.1

  • If it was installed through Snap, you can try to connect system camera interface on the Opera camera interface

    sudo snap connect opera:camera :camera

    Restart opera and check if it worked.


  • simlink ubuntu 20.04

    sudo ln -s /snap/chromium-ffmpeg/17/chromium-ffmpeg-95241/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/
  • This is just a workaround, not a solution.
    This legal issue needs to be solved, and it's a Must
    I suggest to developers to work on this before to working for stuffs on Opera GX. (or maybe you can replace Opera GX with Opera, why you created GX while your normal browser is not working properly...)

  • @njt145 Maybe you can send money to Opera, so the company can afford the costs of a licensing. 😀

  • @mau21mau ty!

  • Another way is to download libffmpeg from here and replace the one in Opera directory

    locate libffmpeg.sp

    and copy the file from the repository and replace the one in this directory.

  • No method seems to be working for the version of opera released today (Version 79.0.4143.22, chromium 93.0.4577.63). Replacing the provided with any of the provided methods causes the entire page to crash if you try to play any video embedded on it. I have now defaulted back to the provided one.
    My go-to method before this was to download the latest version from iteufel's github repo and replace it manually. Had worked since I installed opera.

  • @rgplayzmc **Update To Previous Post **
    Solution: Until @xZero updates his script (It returns 15: [: Illegal number: 
    Error: snapd is not installed
    Command 'snap' not found

    Snap is actually installled
    Here's what to do (GUI method):

    1. Install the chromium-ffmpeg snap
    2. Navigate to /snap/chromium-ffmpeg/current
    3. Find the folder with the highest number and open terminal over there (Right click->open with terminal).
    4. Run
    sudo cp /usr/lib/x86_64-linux-gnu/opera

    (Replace opera directory with wherever yours is installed.)

    (CUI method) (I am a noob at bash, so please forgive me pros)

    snap install chromium-ffmpeg && cd /snap/chromium-ffmpeg/current 
    1. Find the highest number
    cd chromium-ffmpeg-highestnumber && cp /usr/lib/x86_64-linux-gnu/opera


    Now I request @xZero or anyone else to fix that script. Once the script is fixed, store the command the run it in a terminal utility known as keep for easy access.

  • @rgplayzmc

    Thanks a lot, works is great!

  • I've had this problem for about two years now. Can't the fix it? Vivaldi solved it somehow.
    Every time I update, I start looking for the damn file.

    For Opera 79.0 install latest Vivaldi browser 4.2 and the take the lib:
    sudo cp /var/opt/vivaldi/media-codecs-79b56700ea9558c50a5edacaeb70298120127d2f8b32bb5e05c3876a51bd64b5/ /usr/lib/x86_64-linux-gnu/opera/

  • @rgplayzmc
    Your solution worked like a charm. Thanks!

    I had tried copying libffmpeg from /usr/lib/chromium-browser/ but it worsened the situation. Not only the playback didn't work - opera cashed on any page with an embedded video.
    Now everything works as expected. Finally!

  • @rgplayzmc Thanks,

    Why only snap version works ? 😕

  • This post is deleted!
  • @dzanis English here please

  • @mr-matt-eastwood yop works fine

  • It's been quite a long time now that this problem has existed. Other browsers can obviously solve it, for example Vivaldi. Also the snap installation of Opera works with video. It would be time for the Opera team to make a clear statement here and provide a simple solution to the problem. By simple I mean that it should be workable even for users of Linux without background knowledge. Downloading files, unzipping them and then copying them into directories is from the last century!

    So what is the problem and what is the ultimate solution?


  • @linuc What is the problem was already explained in the topic, but you can check it in

  • @leocg

    Ok, I see you need exactly the right file with the right version. Vivaldi recently solved the problem and wrote to me that they have built in a "fallback". I suppose it means Vivaldi doesn't actually update until the correct version of the lib is in place.

    Opera snap works. Is the license paid by the snap makers there?

    How about a permanent solution? For example, the makers of different browsers form a company and this company buys the license, which is then valid for all of the company's products? Or what are the rules of the license?

    Now you can say that you would rather remain "independent". I understand that. But you are not independent, at least not with this problem.

    Opera is a very important browser (also Vivaldi), because I notice that none of the other browsers manage the memory and cache so well. With my 11 year old notebook with 1GB RAM and a swapfile of 2GB (swapiness 40) and single core processor I can open 6-8 tabs without any problems, without long waiting times. The Linux community doesn't like that these algorithms are not public 😉 Maybe you could publish the old versions? Sometimes you have to compromise to stay at the top 🙂

    I hope you continue to be successful and thank you very much for Opera Browser, I always use it and if there is a video that I really want to see, then I switch to Vivaldi for a moment. It is a shame that Vivaldi has no function to block the preload of videos. This is very bad with 1GB of RAM 🙂