Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon)

  • @leocg a browser that doesn't play videos is not only a issue, but a major issue. No matter if it's legal, commercial or technical.
    It's sad, I liked using Opera in my windows machine and it's a pity that you don't have a useful version on Linux.
    I'm not watching videos all the time, but it's very frustrating need to open chrome for playing a video when it's needed.
    I'm migrating back to chrome, and I'm sure that many people is doing the same.

  • @alex1real Ok, goodbye.

  • @alex1real I migrated to vivaldi on my linux mint workstation.

  • @alex1real to you and all folks here that keep complaining: Opera is a free web browser generously offered to the world by it's authors. You can't really expect, nor you should complain for missing functionality due to legal issues. Be grateful for what you got here, as it's far more than you "pay" for.

  • @xZero OK Mr Zero times by zero.

    • "@xZero to you and all folks here that keep complaining about us unthankfull deplorables: We, the common users, all know well that the deficient Who-Know-What-Its-Name (aka Crap) is a free web browser generously offered to the world by it's authors. We can really expect nothing, nor we complain for limited functionality due to unknown issues. We are more grateful for what we got here, thanks to your Sauron's vigilant Eye attitude and corrective policy attitude.
  • @xzero Thing is, my Opera (73.0.3856.344 in Ubuntu 20.04.1) seems to not be installed in /usr/lib/opera. Opening the about page in the browser informs me that it's actually installed in snap/opera/106/usr/lib/x86_64-linux-gnu/opera, which as it turns out it's a read-only directory.
    I later learned about the locate -b opera command, which tells me that that's the only directory that contains packages opera uses (I was expecting to find duplicates somewhere).
    Any clue what can be done here, if anything? This is my first Linux distro, I used to use Opera in Windows and loved it, hence why I'd really want to keep it now in Ubuntu, don't wanna migrate to Firefox or Chrome.

  • @zarathustra-f90
    Thank you for your help.
    It works !!!

  • @firigion My script supports overriding default directory. You just shall call it like so:

    sudo /bin/bash /path/to/your-opera-installation

    Not sure how to work around snap Opera though. You see, snap is by default just an image that provides all dependencies to Opera. Naturally so, you cannot modify it, therefore read-only directory.

    @annevance This explains why my script doesn't work for you. I doubt any solution here will work for Snap packaged Opera, unless you can make Opera load the library from somewhere else.

  • @xzero I ended up deleting my installation and re-installing opera, an now the installation directory is somewhere in /usr/lib, not in /snap. Now I ran your script and it said it worked correctly, but stuff like Netflix and Spotify still didn't work after resetting the browser. Is there something else I can take a look at to maybe fix it?

  • Live streams on youtube and twitch didn't work, this fixed it, thank you. Lubuntu btw

  • @xzero Unfortunately this didn't work for me in Pop OS. It did the opposite: Opera wouldn't open afterwards. It did again when I renamed the back to its original name though.
    I am so tired of this issue that I resorted to install Spotify as a stand-alone app.

  • @marek-online Is Spotify integrated into Vivaldi as it is in Opera?

  • @Firigion Can you post script output?
    Weird that it doesn't work, because it does work for me every time I need it. But again, I use Manjaro which is very different from Ubuntu/Debian. I'll try testing this script more in different distributions VM-s.

    @drpeppercan Can you send the script output? It feels like it didn't do everything it should have done.

    • Script creates backup of by renaming it
    • Script then installs new version of libffmpeg through snap and creates symbolic link named "" that points to the newly installed libffmpeg snap.
    • Script is basically wrapper of multiple solutions found in this thread.
  • I have tested a bit.

    • On Ubuntu 20.04, snap opera works out of the box. Opera deb from the official website doesn't, but my script fixes it just fine by supplying Opera path as argument '/usr/lib/x86_64-linux-gnu/opera'.

    I'll test more on Pop OS and other distros.
    In meanwhile, make sure to close the Opera before running the script, as that could cause issues.

  • @xzero Right now, if I rerun the script it just says that Symlink is already up to date. Nothing to do., and the first time I ran it, it output all the good output messages (I read the script to see what it did, so I saw the conditions for the output messages. The fact that Opera for Ubuntu 20.04 works out of the box for you is... well, strange? Since it doesn't for me. Maybe the issue was that I ran it with Opera running. I'll reinstall it sometime later when I don't need to use it.

  • @nickonicko said in Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon):

    Thank you for your help.
    It works !!!

    When I symlink that library Opera refuses to start. Changing in back to the original library, and Opera works again

  • @operafan123 Did you install the right version for your version of Opera? What version of Chromium is listed on the About Opera page?

  • @sgunhouse

    Opera is up to date
    Update stream:Stable
    System:Linux Mint 20.1 (x86_64; X-Cinnamon)
    Rate Opera
    Opera help
    Browser identification
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.82 Safari/537.36 OPR/75.0.3969.93

  • @operafan123 And did you install the codecs for Chromium 89.0?

  • @sgunhouse said in Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon):

    @operafan123 And did you install the codecs for Chromium 89.0?

    I simply followed the instructions from the above original post

    "First of all, you need to install the chromium-codecs-ffmpeg-extra package. You can do this using the terminal with the following command:

    sudo apt install chromium-codecs-ffmpeg-extra

    Usually the second step is to create a symlink for the file, but since now the Opera browser delivers a file with this name (but not solving the problem), we will delete it and then create a simlink to the new file. File deletion:

    sudo rm /usr/lib/x86_64-linux-gnu/opera/

    Creating a simlink:
    sudo ln -s /usr/lib/chromium-browser/ /usr/lib/x86_64-linux-gnu/opera/"

    I will also add that a fresh install does not work - even on a new machine, yet a fresh install of Vivaldi, and Chrome both work with Netflix without problems