Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon)

  • So Opera is not Linux compatible, that's my conclusion ...

  • Use latest ffmpeg deb files and all your problems will become the things of the past. You may peep into deb file and copy your file manually. As GNU/Linux users you should know all the priv issues, I hope.

    https://repo.herecura.eu/herecura/x86_64/

    Do not delete lib_extra/*.so file. Name it *.so.old, then copy there *.so latest file, name it *.so.new. Then
    ln -s *.so.new *.so

    • = libffmpeg

    [Fig. 1] MC Root (hence red) 🙂
    ssox_1921.png

    [Fig. 2] Oper view of Opera Developer nooks
    opera-dev.png

  • If I have the same problem with Opera, Firefox and Brave, does this give a diagnosis ?
    It seems that for videos and video streams, they want or not want to accept Flash, but are unable to use another possibility, is that correct ? the question is why ?

    I am on Mint 19.3 64 and I allready have FFMPEG , so if I install FFMPEG by SNAP or by the deb, will this be fixed ? Do i have to uninstall the current FFMPEG before this ?

    or is this a problem with graphics, it is an APU AMD with no real good driver for it, must I try the AMD Driver ? 3D and HD video seem good working though, but not Nemo ...

  • My previous solution still works, but you might lose the changes (symlink) when Opera gets updated. At least that happened in my case. Applying the solution manually every time is a pain.
    You can use this handy script to fix ffmpeg support for you, whenever it gets broken.

    Fetch the always up to date script from here, or simply use this command to directly download the script:

    curl -fsSL https://gist.githubusercontent.com/xZero707/ff2d5a76544c84e33086ed94092c0263/raw -o opera-fix-ffmpeg.sh
    

    Remember: When downloading the script from the internet, it is always a good idea to inspect the script first.

    Run with:

    sudo /bin/bash opera-fix-ffmpeg.sh
    

    or

    sudo /bin/bash opera-fix-ffmpeg.sh /path/to/your-opera-installation
    

    The script will install or update snap chromium-ffmpeg and create symlink to latest bundled ffmpeg.so, in your opera directory.

    Note that sudo is required.
    Tested and working on Linux Manjaro. Should work for other Linux distros as well.
    Disclaimer: This script is provided as-is. Use at your own responsibility.

  • This post is deleted!
  • @annevance Indeed I have more video playbacks, but the live tv broadcasts which I watch with the VPN of that country still don't work on Opera, giving a DRM error.
    When this is not solved the browser is useless, unfortunately.

  • @annevance Give a try to my script above (very last post).

  • @xZero Sorry, I did, but still no go.
    I can find the original ffmpeg.so in the opera directory.
    I also have your ffmpeg.so . Even when I login as admin, or sudo in terminal, the directory is "read only" and I cannot move the file.
    I tried to use opera every few years, but always the same. Nice layout, clean but not suitable for drm broadcast.

  • @annevance For DRM you need:
    libwidevinecdm.so 8.9 MB in
    /opt/google/chrome/WidevineCdm/_platform_specific/linux_x64/
    ssox_1927.png

  • Linux Mint 19.3 problem fixed
    I installed the Chromium-codecs-ffmpeg-extra package v86.0.4240.198-0ubuntu0.18.04.1 DEB File using Gdebi from this link
    https://launchpad.net/ubuntu/bionic/amd64/chromium-codecs-ffmpeg-extra/86.0.4240.198-0ubuntu0.18.04.1

  • This post is deleted!
  • @leocg a browser that doesn't play videos is not only a issue, but a major issue. No matter if it's legal, commercial or technical.
    It's sad, I liked using Opera in my windows machine and it's a pity that you don't have a useful version on Linux.
    I'm not watching videos all the time, but it's very frustrating need to open chrome for playing a video when it's needed.
    I'm migrating back to chrome, and I'm sure that many people is doing the same.

  • @alex1real Ok, goodbye.

  • @alex1real I migrated to vivaldi on my linux mint workstation.

  • @alex1real to you and all folks here that keep complaining: Opera is a free web browser generously offered to the world by it's authors. You can't really expect, nor you should complain for missing functionality due to legal issues. Be grateful for what you got here, as it's far more than you "pay" for.

  • @xZero OK Mr Zero times by zero.

    • "@xZero to you and all folks here that keep complaining about us unthankfull deplorables: We, the common users, all know well that the deficient Who-Know-What-Its-Name (aka Crap) is a free web browser generously offered to the world by it's authors. We can really expect nothing, nor we complain for limited functionality due to unknown issues. We are more grateful for what we got here, thanks to your Sauron's vigilant Eye attitude and corrective policy attitude.
  • @xzero Thing is, my Opera (73.0.3856.344 in Ubuntu 20.04.1) seems to not be installed in /usr/lib/opera. Opening the about page in the browser informs me that it's actually installed in snap/opera/106/usr/lib/x86_64-linux-gnu/opera, which as it turns out it's a read-only directory.
    I later learned about the locate -b opera command, which tells me that that's the only directory that contains packages opera uses (I was expecting to find duplicates somewhere).
    Any clue what can be done here, if anything? This is my first Linux distro, I used to use Opera in Windows and loved it, hence why I'd really want to keep it now in Ubuntu, don't wanna migrate to Firefox or Chrome.

  • @zarathustra-f90
    Thank you for your help.
    It works !!!

  • @firigion My script supports overriding default directory. You just shall call it like so:

    sudo /bin/bash opera-fix-ffmpeg.sh /path/to/your-opera-installation
    

    Not sure how to work around snap Opera though. You see, snap is by default just an image that provides all dependencies to Opera. Naturally so, you cannot modify it, therefore read-only directory.

    @annevance This explains why my script doesn't work for you. I doubt any solution here will work for Snap packaged Opera, unless you can make Opera load the library from somewhere else.

  • @xzero I ended up deleting my installation and re-installing opera, an now the installation directory is somewhere in /usr/lib, not in /snap. Now I ran your script and it said it worked correctly, but stuff like Netflix and Spotify still didn't work after resetting the browser. Is there something else I can take a look at to maybe fix it?