Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon)

  • HI))

    Users of the Linux version of the Opera browser face the problem of playing some videos. For example, Opera refuses to play streaming on Youtube or native videos on Twitter
    Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon, etc)

    Playback errors look like this:

    Currently your browser does not recognize any of the available video formats
    This is the kind of error you can see when you try to watch a live broadcast on Youtube. However, some other videos may only be available as 360, without the ability to improve the playback quality.

    You cannot play the video in this browser. Try a different browser
    This message can be found when viewing a video on Twitter. We will not change the browser, this is not our way. But we will tell you about an easy solution to this problem.

    We fix the error of video playback by the Opera browser in Ubuntu distributions and the like
    First of all, you need to install the chromium-codecs-ffmpeg-extra package. You can do this using the terminal with the following command:

    sudo apt install chromium-codecs-ffmpeg-extra

    Usually the second step is to create a symlink for the file, but since now the Opera browser delivers a file with this name (but not solving the problem), we will delete it and then create a simlink to the new file. File deletion:

    sudo rm /usr/lib/x86_64-linux-gnu/opera/

    Creating a simlink:

    sudo ln -s /usr/lib/chromium-browser/ /usr/lib/x86_64-linux-gnu/opera/

    When will it be fixed ?

  • @vladimir-bardakov As said before, this is not a technical issue but a legal one. So it can't be fixed, at least not easily.

  • Hey guys, I tried this workaround but even though chromium-codecs-ffmpeg-extra is installed on my computer (Linux Mint 20), there is no /usr/lib/chromium-browser directory.

    Any idea where to get the correct

  • Got it! I needed to install the chromium-ffmpeg snap. It comes with a bunch of's in a number of folders, all of which you can find in ~/snap/chromium-ffmpeg. I linked this one:

    sudo ln -s /snap/chromium-ffmpeg/15/chromium-ffmpeg-95241/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/

    Did the trick!

  • Can confirm this solved the issue for me.
    I figured out how to use snap library, as @mr-matt-eastwood suggested.

    On Manjaro Linux 20, opera directory is /usr/lib/opera.
    You don't have to delete original file, but just rename it to whatever (including extension).


    # If you cannot use sudo -i, then just prefix your commands with sudo
    sudo -i 
    # Close your browser by hand. Following command will ensure no Opera processes are running in the background
    killall opera
    cd /usr/lib/opera
    # Some software automatically loads any .so/.dll file that is present. Not sure for Opera, but just in case
    mv libffmpeg.so_original
    snap install chromium-ffmpeg
    # Please note that chromium-ffmpeg-95241 path might differ. Just pickup one with highest number. 
    ln -sf /snap/chromium-ffmpeg/current/chromium-ffmpeg-95241/chromium-ffmpeg/

    Works like charm.

  • Seems like any file will do - other than the one that ships with my Ubuntu Opera packages!!
    I'm currently using the that came with the vsCode snap, and it seems I need to be updating the link after each Opera security update.

    I'd like to join the choir of people demanding Opera fix this issue.

  • @vladimir-bardakov
    Linux Mint 20 Cinnamon, Opera v.70 without Chromium browser
    $ sudo snap install chromium-ffmpeg
    in my OS the command and paths are:
    $ sudo cp /snap/chromium-ffmpeg/15/chromium-ffmpeg-9xxxx/chromium-ffmpeg/ /usr/lib/x86_64-linux-gnu/opera/
    9xxxx - there is a few of them, I chose 95241 only because I thoubht the higher number=latest version. Can't say it's true for sure.

  • @leocg -- I came in late to the game. Can you please give a link or reference to the legalities?

    Other browsers do not seem to have this trouble. Are they breaking the law?

    I'm sortof new to Linux, but would love to use my favorite browser --Opera.

    All of the suggestions to make it work seem really strange and weird. To my simplistic thinking they should be unnecessary.

    Please help me understand.


  • @cedarviola See

    Browsers like Chrome, Edge and IE for sure can afford buying a license.

Log in to reply