Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

Youtube does not work in opera 18.0

  • I am forced to use Opera 12 again now. Its just ridiculous to use two different Operas and funny to watch how old works and new fails.
    As i said Youtube is very important palace and Opera dev team should put it on the priority list. I am not tech guy so i dont know how lots of priorities dev team have and i dont care.
    YT must work smoothly all the time end of story.

    Because picture is worth of 1000 words, here:

    opera 18 is on the left

    [img]http://i.imgur.com/zZm22SE.jpg

  • I'm having the same problem since today morning, Never had such a problem before. I too update flash player and did all that and yet it does not work. But in my case it's only a certain YouTube videos, Some work and some don't work It's still frustrating though, I could use some help if anyone knows what can fix this.

  • Same problem for me since yesterday ...
    Firefox and IE 11 work perfectly, so the problem must come from Opera , and not from our computeurs ...
    BTW, Opera on my tab works fine 🙂

  • YT is sending incorrect information to Opera. As a workaround, install the extension Youtube Center and force the use of flash.

  • Thank you kind sir, That worked for me, Hope you guys also get this solved.

  • I'm using v.18.0.1284.68 and have no problems viewing YouTube videos. I wonder why? Very bizarre.

  • Ditto here:

    Version information
    Version: 18.0.1284.68 - Opera is up to date
    Update stream: Stable
    System: Windows 7 64-bit (WoW64)

    No Youtube video loads, just spinning circle in the middle of where the video should be. Works perfectly in IE and Chrome.

  • Try to use the new Opera Next (19.x.x). The problem is solved there.

  • http://blogs.opera.com/desktop/2013/12/youtube-is-back/ Please read this. Restart the browser, after couple of minutes patch should be applied. If that doesn't help - locate your profile directory - on Windows it's %appdata%\Roaming\Opera Software\Opera Stable, on Mac delete ~/Library/Application Support/com.operasoftware.Opera/- and delete the browser.js file. Restart browser again, after 1-2 minutes file should be downloaded. We will remove the patch once YouTube will rollout their fixed version.

  • It is working now. Cheers!

  • Yes its working. Thanks all.

Log in to reply