Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 66.0.3515.2 developer update

  • @burnout426 There's a difference also if I hover the cursor over the tab or mute it, I forgot to mention. So, I'm not sure how big is the difference, it seems that the animation always shows the full speed, but when muted the cpu speed varies (but I see the full speed not so often with muted tab in contrast to the active equalizer)

  • @andrew84 I have similar results on Ytube with 720p (not 60fps) video. So maybe I can't confirm the issue on these 2 sites. I don't know.

  • @burnout426 on the site ok.ru when playing music:

    d06f5e83-7354-4370-87d1-7c04088eb933-image.png

    on the website ok.ru when playing music and when you hover the mouse cursor over the tab:

    645e74d4-5cf3-479c-bea0-8a99a46e5678-image.png

    on the website ok.ru while the video is playing:

    618bb044-91e5-455d-9141-f5d91a812640-image.png

    on the site ok.ru when playing a video and hovering over a tab:

    de7ba2a2-2f6e-485c-aabd-6b321f24c009-image.png

    on the site vk.com when playing music:

    edc74d6e-aca3-42bf-8ca3-7fc86a782463-image.png

    on the website vk.com when playing music and when you hover the mouse cursor over the tab:

    fb85d031-7642-4cff-9db1-43d4a1cca8e0-image.png

    on the website vk.com while the video is playing:

    78f22ca9-a394-4596-821b-d95d0e5edac5-image.png

    on the site vk.com when playing a video and hovering over a tab:

    d62c339f-911c-4cbc-b950-667e1bc1d4a6-image.png

    But the CPU load is not so bad. The video on the website vk.com and ok.ru started hanging and slow down . And if I hover my mouse over a tab of these sites, then the video starts to play well.

  • @temkem said in Opera 66.0.3515.2 developer update:

    The video on the website vk.com and ok.ru started hanging and slow down

    Are you sure this is Opera's problem? As soon as you open the video on vk.com and ok.ru, buffering begins, which can cause hangs and slowdowns within seconds.
    For me personally, the fix "DNA-82626 [Win] High CPU usage due to media indicator animation" solved the video problem, I don't see much difference with Сhrome now.

  • @johnd78 said in Opera 66.0.3515.2 developer update:

    Are you sure this is Opera's problem? As soon as you open the video on vk.com and ok.ru, buffering begins, which can cause hangs and slowdowns within seconds

    Yes, I'm sure, since I can see that the buffering has already passed.
    And when you hover over a tab vk.com or ok.ru the video starts playing normally.
    on stable Opera 65.0.3467.48 there is no such problem on the site vk.com

  • @temkem I checked again in Opera Developer 66.0.3515.2 and in Opera Bera 66.0.3515.3, I have no problem. It’s strange.

  • @johnd78 @temkem Dear fellows in front of the screen,

    There is nothing strange about having different hardware and software. 🙂

  • @burnout426 , @johnd78
    I turned off the opera://flags/#disable-accelerated-video-decode flag and the videos on these sites began to work normally.
    But why isn't there such a problem on stable Opera and no problem on the Vivaldi browser?

  • @temkem Not sure. Guess there could be a change in Chromium that caused the difference. I guess you could compare opera://gpu between stable and developer to see if there are any differences. Also, with Vivaldi, I'm assuming you tried the snapshot and not stable. Vivaldi is often behind in Chromium, so you want the latest snapshot to at least get a build with a newer Chromium.

  • @andrew84 Does the issue go away for you too when opera://flags/#disable-accelerated-video-decode is enabled?

  • @burnout426 opera://gpu/
    the difference between the stable version and Opera Developer is that Developer includes
    Viz Hit-test Surface Layer

    @burnout426 said in Opera 66.0.3515.2 developer update:

    Also, with Vivaldi, I'm assuming you tried the snapshot and not stable. Vivaldi is often behind in Chromium, so you want the latest snapshot to at least get a build with a newer Chromium.

    Have Vivaldi Snapshot 2.9.1735.3 version of Chromium(79.0.3945.45) higher than have Opera Developer and Opera Beta, but have Vivaldi there is no such problems and have him, too, included Viz Hit-test Surface Layer and all same sections that and have Opera Developer and Beta

    @burnout426 said in Opera 66.0.3515.2 developer update:

    @andrew84 Does the issue go away for you too when opera://flags/#disable-accelerated-video-decode is enabled?

    yes

  • @temkem said in Opera 66.0.3515.2 developer update:

    Viz Hit-test Surface Layer

    I guess you could disable opera://flags/#enable-viz-hit-test-surface-layer just to see if it makes a differencer for Opera. I guess you could also try disabling chrome://flags/#video-pop-out-surface-layers so Opera Developer doesn't use Chromium's new pop-out feature. Even if you're not using the video pop-out, maybe there's an issue with it behind the scenes. Just a wild guess though.

  • @burnout426 no, it doesn't help. Especially on Opera Beta by default disabled flag: opera://flags/#video-pop-out-surface-layers
    and there is this problem too.

    5eed1ace-35ef-4a2e-835f-facddfc5be54-image.png

  • @burnout426 said in Opera 66.0.3515.2 developer update:

    Does the issue go away for you too when opera://flags/#disable-accelerated-video-decode is enabled?

    I don't want to confuse you, but here with this flag disabled I have the same behavior. But I mean only the higher CPU load, I had no problems with hanging video on ok.ru previously too.
    And regarding the CPU load, I have similar behavior with both YouTube and ok.ru videos (720p not 60fps).
    *I can add that I'm using O58 currently, and the same YTube video (720p) consumes less resources in overall in 58version than in the last Dev version (with active equalizrer, antivirus is off), but in 58 there's also the cpu load become less when tab is hovered by the cursor. When I turn the antivirus on and put higher quality (1080+) it's already hard to say.

  • @burnout426 Edit: Sorry, I misread. I thought you mean to disable the flag because here that flag was enabled by default (so I tried with disabled after your post).
    2019-12-01_162921.png

  • @burnout426 said in Opera 66.0.3515.2 developer update:

    @zalex108 and @temkem, could you provide list of URLs where there's still high cpu uage when playing media?

    OS details too please.

    Any site.
    W7 x64 - Updated

    --
    Muting fixes the problem.

    --

    Thank you.

  • @andrew84 My fault on that. I was going by the name of the flag and not its description. I meant to turn off "Hardware-accelerated video decode where available".

  • suggestion I really like bookmarks and history in the sidebar panel. How about downloads in the sidebar panel, too?

  • I still keep praying for an intermediate theme. No matter how I adjust the brightness or contrast on my monitors, I can't distinguish the active tab from others when using the dark theme, and light is too bright for most purposes.

  • In recent builds, the google search field does not allow me to edit my search. I can type in a change but clicking on the search icon or hitting enter does nothing on my Win7 desktop. Is this Developer specific or something google has done.