Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Why have my bookmarks started appearing as suggestions in the Google search bar auto complete?

  • This literally only started happening today - when I start typing into the Google search bar, the first suggestions it tries to autocomplete are from my bookmarks. I don't want this to happen and don't know why it has suddenly started happening today! I've tried uninstalling and reinstalling Opera and it still happens. I've tried turning off autocomplete, but all that does is make it so it only shows my bookmarks as search suggestions!

    Does anyone know why this has happened and how to stop your bookmarks from being suggested by Google autocomplete? I want to keep the autocomplete function but I don't want all of my bookmarks coming up. I know where they are - that's why they're bookmarked!

    Thanks in advance for any helpful suggestions.

  • @robor10t You mean the search bar at www.google.com?

  • Or maybe the search field on the start page.

  • Hello,
    I mean the address bar at the top of a page/tab, where you would type a web address. I believe this also doubles as a Google search bar which is potentially where I hadn't made myself clear (e.g., whatever I type in there that isn't a web address will take me to Google search results). Apologies for the confusion.

    E.g. If I go to a new tab and in the address bar start typing the word "sound", the first suggestion is a bookmark I have for the guitar tab for a Soundgarden song, and so on. Opera suddenly uses my bookmarks as the first auto complete results, which it did not do before this weekend. I definitely would have noticed!

  • @leocg Please see reply to @burnout426
    Thanks

  • @robor10t Opera suggesting bookmarks and pages from your browsing history is a normal behavior and happens since a very long time. And it has nothing to do with search suggestions from Google or any other search engine.

  • @leocg I've been using Opera since the start of the year (Jan/Feb?) and it has never happened until this weekend. I definitley would have noticed as I noticed it straight away when it started happening!

    Is there any way to turn this off? I don't want my bookmarks coming up as suggestions. I know where they are - that was the whole point of bookmarking them!

  • @robor10t Not that I know.

  • @leocg Do you know if there has been an update or anything because this definitely only started happening for me this weekend. I have probably 100's of bookmarks so I definitely would have noticed as it would have happened almost every time I used the address/search bar...

  • @leocg Also, I uninstalled Opera then reinstalled it, then deleted my browsing history (from the very start), and it STILL persists! Where is it even getting the information from at this point?? It inlcudes a bookmark that I have deleted and I deleted my browsing history, so how is it still showing something I've deleted as a suggestion?

  • @robor10t Sync maybe? What do you see at the left of the address/site name? It's the heart indicating that it's coming from your bookmarks or it's something else?

  • @leocg Sticking with typing in the word "sound", the 1st suggestion is my Soundgarden-related bookmark and to the left of it is a tiny thumbnail of the website it's linked to (ultimate guitar).

    The same happens for one (a bookmark) which I deleted, after already reinstalling Opera and deleting my entire browsing history.

    Where is it still pulling that info from? There's nothing illegal on there or anything silly, but it's coming up to Xmas and I've been bookmarking things for Black Friday deals and I don't want the wife or kids stumbling across something!

    As I said, I've been using this browser for around 9 - 10 months and this definitely ONLY started happening this past weekend.

  • Goto the URL opera://flags/#reborn-3-dropdown, disable it, restart Opera and try again to see if the results in the address field are in the order and look like what you're used to. (If that works though, don't count on it being an option forever.)

    Also (without messing with the flag), if the bookmark entry shows up first in the drop-down, look to the right of it when you're hovering over it and see if there's an X (there was on mine). If so, click it and it might not show up as first next time.

  • @burnout426 Nope, it still happens. The only difference disabling that made was instead of there being a tiny thumbnail of the site that's bookmarked, it just shows a little heart (bookmark symbol). It still comes up as the first suggestion.

    I already looked if there was a "x" next to the suggestion(s), but there isn't.

  • I think there was an X on mine because I had searched for the term that matched the bookmark before-hand. So, never mind about that.

    I tested in Opera 63 and I didn't see any difference in behavior.

  • @burnout426 Well I'm going to be looking for a different browser because this means I can't bookmark anything without having to go to the trouble of setting up different profiles for myself and the rest of my family in my home. That's too much effort for a feature that's completely redundant. The whole point of bookmarking something is that you know where it is. Why would I need that to come up as a suggestion? And not be able to turn the feature off?

    I thought this browser had good promise, too after using Chrome. Oh, well. I hear Vivaldi doesn't do this. I'll have to try that.

  • @leocg It's 100% coming from my bookmarks. Otherwise it would be one hell of a coincidence for a Google suggestion to have it's top suggestion be the exact page I bookmarked 7 months ago but haven't visited since! It's exactly the same with all the other top suggestions that are from my bookmarks - they are my exact bookmarks!

  • @robor10t said in Why have my bookmarks started appearing as suggestions in the Google search bar auto complete?:

    I hear Vivaldi doesn't do this.

    It has an "include bookmarks" checkbox for this at vivaldi://settings/addressbar/ that you can uncheck.

  • @robor10t Did you erase your bookmarks?

  • @burnout426 Nice. Thank you for that!

Log in to reply