Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can't add to the cookie block (or delete on exit) list. Button does nothing.

  • I have four or five domain level entries in the "Clear on Exit" group. But if I try to add under either the "Allow" "Block" or "Clear on Exit" groups the Add button does nothing.

  • Confirmed. But, somehow I got it to work. I hit ctrl + shift + i to open the developer tools and switched to the console to see if there were any errors. I then cleared the console and refreshed the page. Then the buttons started working again.

  • Weird, but it worked for me. (At least so far.) I noticed in the developer console there were a few errors reported for "crisper.js" and clicked to expand those errors. Then I closed the developer window, and refreshed the page. Still it did not work.

    Then I noticed the URL was opera://settings/content/cookies?search=cook (because I had searched for the section in the Advanced settings area.) I removed the querystring parameter and viewed opera://settings/content/cookies and tried again... Then it worked. I'm not sure if the querystring was confusing the call to the JS or not, but I was able to add a new domain to the "Clear on Exit" list.

    Thanks for the suggestion!

  • The Add buttons for the JavaScript exception lists sometimes don't react either. This situation has occurred since some Opera versions, formerly on Windows 7 32 bit, now on Windows 10 64 bit, always installed as stand-alone installation.

    The most reliable way to reproduce this issue for me is this way:

    • Start Opera.
    • Open Opera's settings via Alt+P.
    • Type javascript into the search field (without ENTER).
    • Click through to the JavaScript settings.
    • Both Add buttons do not react.
      Operas address bar shows: opera://settings/content/javascript?search=javascript

      Opera_JavaScript buttons.png

      However, if I call the address opera://settings/content/javascript?search=javascript directly, both buttons react immediately.
  • @yanta Confirmed and thanks for the details.

    Can you confirm in Opera Developer too? I couldn't. I didn't try Beta yet.

  • @burnout426 Thank you for you confirmation. I am on the stable channel only, but I will try both developer and beta (it's going to take a while).

  • @yanta I tried Beta (which is actually an older build than stable at the moment) and it has the problem too (for me at least).

  • @burnout426

    On I got

    • Opera beta 64.0.3417.41 x64
    • Opera Developer 65.0.3466.0 x64

    I installed both programs Stand-alone, Language: English (United States), into their default destination folders C:\Opera beta + C:\Opera developer. After their first automatic program start after installation, I closed both programs once (to let them finish finalization operations if there are any) and then restarted them. I did not make any adjustments:

    • Opera beta shows the same error as Opera stable.
    • With Opera Developer I could not reproduce the bug.

    So all three Opera versions (stable, beta, developer) behave the same on my system as on yours.

    I am on Windows 10 Pro 1903 64-bit, build 18362.418

  • @yanta I can confirm this issue in Stable and Beta. There is no such problem in Opera 65 Dev. Win7 x64

  • @yanta This problem only occurs if you type something (no matter what) in the search field in opera://settings, and then go to any subsection.

  • I guess it's a known issue. Bug DNA-77410.