Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Updates Change Mail Handler Preferences

  • @jimunderscorep ....... Regular

  • What does
    gio mime x-scheme-handler/mailto
    return? It shows the app that is used for mailto:// links. E.g. on my system

    $ gio mime x-scheme-handler/mailto
    Default application for “x-scheme-handler/mailto”: thunderbird.desktop
    Registered applications:
    	thunderbird.desktop
    Recommended applications:
    	thunderbird.desktop
    
  • @jimunderscorep "Command not found". I have already changed the default back to Thunderbird, in preferred applications, and it works. This is 2nd or 3rd time in a row, that updating Opera, has changed the default/preferred mail handler to itself. The only way I knew it had changed the default from Thunderbird, was clicking on email links in Opera, did nothing. Once I figured out what it was, and changed it back to Thunderbird as default, it was fine.... till the next update.

  • The gio binary is in the libglib2.0-bin package. Please install it and try again.
    There was some xdg-something command that would do the same, but I do not remember it now.

  • And what does this gio binary package do, and exactly why do I need it?

  • You need it so as to run the command I posted above. The command is gio blablabla, its binary (executable) file is in /usr/bin/gio and the package that provides that binary file is libglib2.0-bin.

    Else, look up the forums about the same issue on magnet:// urls and you will probably find the xdg-something command I mentioned above.

    ---edit
    Found it. The xdg equivalent of gio is xdg-mime, so you can run
    xdg-mime query default x-scheme-handler/mailto
    instead and get something like this

    $ xdg-mime query default x-scheme-handler/mailto
    thunderbird.desktop
    

    p.s. I LOVE that inconsistent look of the code tags 😛

  • $ xdg-mime query default x-scheme-handler/mailto
    thunderbird.desktop

    Telling us what I already stated, that Thunderbird was the mail handler

  • I am out of ideas then, sorry. Clicking a mailto:// link here opens thunderbird, as it should.

    Debian testing x64, opera stable 60.0.3255.170, the deb version.

  • It does here also, after I changed it back via default programs

  • Well, I thought this was fixed, as a previous update to Opera did not change the mail handler settings to Opera itself. Then, updated Opera again his morning to Version:62.0.3331.18, and low and behold..... the first email link I click on, tries to handle it through Opera, asking for my gmail login information. This is getting ridiculous. Now, every time I update Opera, I have to fix the stupid video playback issue, and change my mail handler setting back to Thunderbird!

    Edit: Even after changing the mail handler preference back to Thunderbird, it still tries to handle it in Opera. When this first started, I could change the preference back to Thunderbird, close Opera and open it again, and it worked properly by opening a new email in Thunderbird, when clicking on an email link. This time, it wont. It shows Thunderbird as my preferred application for mail, but when I click on an email link in Opera, it tries to handle it in Opera through a gmail account online. I logged out of/back into Mint.... still wrong. I rebooted the system.... still wrong. The preferences still show Thunderbird, but it still tries to handle it in Opera. Im about ready to go back to Firefox and be done with these aggravations.

    Edit #2: It is now working again. Simply going through the steps above, did not rectify the situation. For grins and giggles, I changed the mail handler to Kmail. Shut down Opera, and opened it back up. Then I changed it to Thunderbird, shut down Opera, and opened it back up.... and NOW it finally is working correctly!

  • Goto the URL opera://settings/handlers and remove the mail.google.com email entry if it's there. That might stop it from happening again. Turn off "allow sites to ask..." to block all sites if you want.

  • @burnout426 said in Opera Updates Change Mail Handler Preferences:

    Goto the URL opera://settings/handlers and remove the mail.google.com email entry if it's there. That might stop it from happening again. Turn off "allow sites to ask..." to block all sites if you want.

    I disabled the option there and I just tried that with a magnet:// link.
    Although I had allowed opera to directly open the magnet:// links in the past, I see that there is no option for these links in there, even after disabling the forementioned option.

  • @burnout426 said in Opera Updates Change Mail Handler Preferences:

    Goto the URL opera://settings/handlers and remove the mail.google.com email entry if it's there. That might stop it from happening again. Turn off "allow sites to ask..." to block all sites if you want.

    The only thing at that URL, was "Allow sites to ask to become default handlers for protocols (recommended)". I turned it off. Although, that wasnt the problem, as I wasnt being asked anything about the mail preferences. Im just sick of having to fix Opera, after they update it and break it.

  • @jimunderscorep said in Opera Updates Change Mail Handler Preferences:

    I disabled the option there and I just tried that with a magnet:// link.
    Although I had allowed opera to directly open the magnet:// links in the past, I see that there is no option for these links in there, even after disabling the forementioned option.

    The option is for website handlers, not system handlers. Although, if there's an entry in there for a certain protocol and it's set as the default and then as the default in the system, it can override the system handler.

    If you see no protocol-specific options in there, it just means there are no websites currently handling any protocols in Opera and that Opera should pass the link on to the system handler. Turning the option off will disable support for websites handling protocols.

  • @SilverFox66 said in Opera Updates Change Mail Handler Preferences:

    The only thing at that URL, was "Allow sites to ask to become default handlers for protocols (recommended)".

    Okay. That means no website handlers are/were interfering. Must be something in the update script for Opera that does it.

Log in to reply