Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Bookmark bar reappears even after disabling it repeatedly

  • It's annoying. The same issue on Linux, Windows and MacOS 😞

  • @moppera So you dont use bookmarks bar? I find it the most useful tool there is. But and its a big but, I have the word bookmarks (BMKS) on the bar and use that to quickly find my favorite sites not on the speed dial. Speed dial is fine but not for like 20 icons or more.
    Ya if your bookmarks bar only has like google maps and such it serves no purpose. Try opening bookmarks bar and seeing if your bookmarks is on it. You may like it.

  • I had the same problem but fixed it tonight and here's how:

    Next time you're at a page that you want to bookmark, DON'T right click and add to bookmarks. Instead, go to the small heart icon at the far right of the address bar and click that to save. You'll probably see 'Bookmarks Bar' as the save option. Change that to something else, speed dial or as I do, 'Other Bookmarks'.

    Right click the bookmarks on the bookmarks bar and choose 'send to bin'. Do them all and assuming that you've unchecked the 'Show Bookmarks Bar' option, then the bar will disappear and won't return. Mine has been fine.

    For the bookmarks that you've deleted from the bookmarks bar and sent to bin, go into the bin, open each page individually and using the heart icon again, re-save them to wherever your preferences are.

    Now, next time you're on a page that you want to bookmark, just right click on it and choose the usual 'Add To Bookmarks' option. The heart icon will open and you can see that it's not being saved to the bookmarks bar.

    And that's it. It's worked for me and it'll work for everyone else too.

    MS

  • @holecrap Different people, different opinions, what can I say? I neither use the bookmarks bar, which I find annoying, nor speeddial, one of the most needless features that Opera came up with and all other browsers copied, I have no clue why. Oh, I see, there are people who like it like you. Could you explain why?

  • @popinjay01 How long did it take? I have got hundreds of bookmarks in kind of 50 categories. I cannot imagine this is what the developers had in mind, it seems like a tremendous waste of time, while there should be a button that ensures one simply does not use the bookmarks bar and it should never pop up. Something that was default state in earlier Opera versions.

  • @leocg
    Why should I have to select another place to save my Bookmarks? I have no issue with the bookmarking system in Opera. THAT works just fine. What i take issue with, is the fact, every time I add a new bookmark, the dumb bar REAPPEARS at the top of the browser page.. wasting space. So I have to open the bookmark page, uncheck "show bookmark bar".. then close. If I add another.. there's the damn thing AGAIN... I can access bookmarks via the heart at the top of the browser.. and I have access in my sidebar.. where I want it... I have no use for the dumb bar that keeps hogging browser page space up top each time i add one.. THAT is the issue here. There is NO NEED for it to keep popping back up, once I un-check show it!! If I UN-CHECK "show bar".. it should STAY UN-SHOWN!!
    Get it now?

  • @hankster1958 No need to shout. Banned for a week.

  • @hankster1958 Answering your question, since adding a bookmark to the bookmarks bar seems to make it show up, placing the bookmark somewhere else will probably avoid that behavior.

  • @leocg Sorry, but that is not possible. The bookmark bar pops up before you select a place to store it

  • I think it's a bug. This issue doesn't occur in early versions.

  • When I hit ctrl + d to bookmark a page, if "bookmarks bar" was the last-selected location, the bookmarks bar will automatically show with "Bookmarks bar" selected in the drop-down in the Bookmarks dialog that shows up. But, if I click that drop-down and switch to "other bookmarks", the bookmarks bar automatically disappears. I can swicth back and forth between "bookmarks bar" and "other bookmarks" in the drop-down in the dialgo the bookmarks bar with switch on and off to match.

    If I hit ctrl + d to bookmark a page where the last-selected save location is "other bookmarks" (as in, anything but "bookmarks bar"), the bookmarks bar isn't automatically enabled.

    That behavior seems makes sense to me. However, I can understand that some users might want to save to the bookmarks bar without it automatically showing where they only enable the bookmarks bar themselves when and if they're ready. But, if one never plans to make use of the bookmarks bar at all, they should just set the save location to "other bookmarks" (anything but "bookmarks bar") and they'll be good to go from then.

    For users that never wanted to use the bookmarks bar and just discovered that all their bookmarks have been saved there, they can goto the URL opera://bookmarks, click on "Bookmarks bar", click in the area in the right-hand pane under the line that's under the "Bookmarks bar" text, hit ctrl + a to select everything and then drag the selection to "other bookmarks" in the left-hand pane. Then, create/update an bookmarks on the page and set the location to "other bookmarks" and you'll be all good.

  • @moppera It doesn't happen here on Opera developer 65, so maybe it's just a matter of time.

  • @leocg Good to know, thank you

  • @burnout426 said in Can't get rid of bookmarks bar:

    But, if I click that drop-down and switch to "other bookmarks", the bookmarks bar automatically disappears. I can switch back and forth between "bookmarks bar" and "other bookmarks" in the drop-down in the dialog the bookmarks bar with switch on and off to match.

    I should clarify. That's when there are no bookmarks on the bookmarks bar and I'm trying to add one. If there's already at least 1 bookmark on the bookmarks bar, switching back n forth between "bookmarks bar" and "other bookmarks" just adds and removes that bookmark from the bar. It doesn't shut the bookmarks bar off when switching to "other bookmarks". Nothing does. You have set it to "other bookmarks" to make "other bookmarks" the last-selected save location, close the dialog and then manually shut the bookmarks bar off. So, in that case, it can be a little more annoying. The way around it though is to just set "other bookmarks" for a bookmark and then manually turn the bar off. Then it won't come back up. And, to get the behavior I quoted, you need to clear the bookmarks bar of bookmarks like @popinjay01 said.

  • It's annoying 😡 😡 . The same issue on windows10 😞

  • @hannijke said in Can't get rid of bookmarks bar:

    It's annoying 😡 😡 . The same issue on windows10 😞

    In the bookmarks page, move everything in "Bookmarks Bar" to "Other bookmarks". Then, bookmark a page to "other bookmarks" so that "other bookmarks" is now the default save location. Then, it should stay off.

  • @jin8864y
    Same problem for week now - I've never experienced it before.
    I keep unchecking it, it keeps showing up.
    It shows up even when it's already unchecked (?!?).
    Help, anybody, please? This is really, really annoying...

  • @popinjay01
    Thank you! This actually worked!
    (But I don't know how it got changed to "bookmark bar" (from "other bookmarks") in the first place?!)

  • @tanjanjanja I've been getting this problem for awhile now. They will not fix it, and refuse to do anything about it. It's like they just do not care at all. And just shove it under with every other bug.

  • @leocg Just popped in, after having been banned for "shouting" ?? sheesh, Really?? anyway.. your "suggested solutions" such as use "alternative bookmarking" ...now... why should a person have to use some weird "other" method if opera has in it, a bookmarking program that ought to work properly? But doesn't because their is either a bug, or flaw in the program coding? Your replies did not address the issue which frankly, is The Opera team has a program glitch it needed to fix.
    Anyway, after nonsensical answers to a simple question, and then getting booted because I voiced my frustration at this.. I decided to look to a better solution on my own. I found it... I tested... then switched to VIVALDI.. seems they don't have the issue.... So. thanks to you being a snowflake and banning me.. I had the motivation to find a superior solution... and I've moved all our computers here to it.... Great Job Rufus!! See ya.

Log in to reply