Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flashplayer not working

  • Adding to the above, twitch uses a combination of flash, for the player, and html5 (h264), for the stream, so do not use it to judge opera if you do not have chromium ffmpeg codecs installed and working, at the very least.

    And the above reason is the one I have never watched twitch inside a browser, because, let's be honest, that flash + html5 combination is trash.

    Also, are you on snap opera or on the deb one? This is a trick question that will trigger a lot of other answers 😛

  • @leocg I can't do that since I use some websites that uses Flash.

    @jimunderscorep Chrome was working for the majority of websites that I visit, but a few was problematic and it didn't work properly, so I had to switch between Chrome and Firefox everytime I wanted to visit a specific website. I installed chromium ffmpeg via snap and now Chrome is working 100%. I want to migrate to Opera, though... Just to try something new.

    I downloaded Opera on the official website which is the deb version.

  • @Lotts Those sites know that Flash is going to disappear, right?

  • @leocg Yeah... But I can do nothing since they're using it yet :/. I don't know what they'll do in the future, but probably they'll use Flash until it's no longer possible.

  • @Lotts Did you already try to use those sites with Flash blocked? I remember have seen some sites that asked for Flash if it's available but if you had it blocked, they used HTML5.

  • @leocg Yeah, it doesn't work.

    Screenshot with Flash blocked:

    alt text

  • Please remind me again what distro you are on. Ubuntu? If so, do you have chromium ffmpec codecs installed?
    The black box on twitch.tv is because of opera's poor codec support, h264 in this case. I have the same one here.

    2019-06-14-180923_1280x1024_scrot.png

    On the other window, with the flash elements... no idea. But flash works for me as seen above

  • @jimunderscorep Yes, Ubuntu 19.04. Yes, I did install chromium ffmpec codecs today via snap (sudo snap install chromium-ffmpeg).

  • Let's get some things straight...

    Snap apps and regular (apps you install via deb, apt, etc) apps are 2 different things.
    Snap apps come as a set with all their libraries and run in a sandboxed enviroment. They also have permissions on what they can and can not access, e.g. external storage.
    Regular apps are like... the ones we were using all these years, e.g. they share libraries, they are installed system wide, they have access to other libraries installed seperately (e.g. flash) and many more.

    When you install opera as a snap app, you must also install chromium ffmpeg codecs as snap, because snap opera "links" to the ffmpeg codecs snap. Also, there is no flash if you install opera as a snap, because snap apps are sandboxed and do not have access to other libraries of the system.

    When you install opera as a regular app, you must also install chromium ffmpeg codecs via apt or something similar, because the regular opera will look for the regular ffmpeg codecs, And because it has access to other libraries in the system, it will also use flash if it is installed.

    So, first things first. Remove the snap opera and the snap version of ffmpeg codecs. Second, make sure you have opera installed from the deb package and chromium ffmpeg codecs installed. Third, make sure you also have flash installed. Do all that and come back if you still have issues.

  • @jimunderscorep I'll try my best here but it might be not understandable because English is not my first language.

    When I installed Opera, I did install it as a regular app (.deb from official website). But with your last reply I realized that the version of Flash that was installed was the 32 bit, so I removed it and installed the 64 bit one. Then I removed chromium ffmpeg codecs from Snap since I installed Opera as a regular app.
    When I tried to install chromium ffmpeg codecs with apt, I got this: "chromium-codecs-ffmpeg-extra is already the newest version (74.0.3729.169-0ubuntu0.19.04.1)" so it was already installed before I install Opera.

    So basically:

    Opera is installed as a regular app;
    Chromium ffmpeg codecs was already installed;
    Flash now is installed correctly.

    But I got the same error.

    I tried this, though:

    1 - Remove Opera as a regular app;
    2 - Install Opera and chromium ffmpeg codecs with Snap;

    The result was: (predictable since it was the Snap version and you told me that a Snap app is run sandboxed)

    Twitch.tv worked fine, but here (https://helpx.adobe.com/br/flash-player.html) Flash was undetectable and websites that uses Flash didn't work (there was a green button telling "Install Flash").

  • How can you tell you installed the 32bit version of flash? It takes some "effort" to install any 32bit lib or app at a 64bit system.
    Basically, how did you install flash originally?

    Hint: the output of
    dpkg -l | grep flash
    may somehow help us.

  • @jimunderscorep I found on a brazilian website that using it (sudo apt-get install flashplugin-installer) was the 32 bit version and it (sudo apt-get install adobe-flashplugin) was the 64-bit. But when I used the above command, I could see thats not correct. Anyway, neither works.

    That's the output of dpkg -l | grep flash:

    https://pastebin.com/raw/F7RaiSGR

  • What you read is wrong, and let me explain why.

    a) In order to install anything 32bit on a 64bit distro, you first need to enable 32bits in apt, like so

    sudo dpkg --add-architecture i386 
    sudo apt-get update
    

    and then install something like so

    sudo apt-get install mpv:i386
    

    This will install the 32bit version of mpv from the repo, along with all its dependencies in 32bit. If the howto you read did not have the "--add-architecture" part, you probably did not install anything in 32bit, not only flash.

    b) The package adobe-flashplugin is from canonical's partner repo, it contains both the npapi version (= flash for firefox and other browsers with less than 0.01% market share) and the ppapi version (= flash for chromium based browsers, like chromium, opera, vivaldi etc). Imho, this is the only right way to get flash on ubuntu and derivative distros, why? Because...

    c) The package pepperflashplugin-nonfree is in fact a script that downloads the ppapi flash from adobe, extracts it and places it in the right place so that browsers can access it. Sounds good as an idea, but it has one major flaw.
    The download url changes everytime there is a new version, so the script relies to an online file mentioning the version, and someone has to change that file from time to time. And he simply doesn't, making the script useless, or, as I have said before, poorly maintained rubbish. Remove it.

    d) The package flashplugin-installer is script for the the npapi version of the above and it is poorly maintained too, for the same reason. Remove that one too.

Log in to reply