Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

IP Address is plainly shown using Opera's VPN

  • Is there any way of getting my IP address not to display for the world to see when using Opera's bizarre VPN? I've read so many posts and tried what they did to no avail. I've installed ScriptSafe, WebRTC Leak Prevent and when their auto test pops up its all blank which I think is good but when I just go to a website that tells me my IP there it is. Isn't the first order of privacy the masking of your IP address? How could they get this wrong? What's the point if this doesn't even work? Its like a browser that can't display websites. Maybe that will be Opera's next surprise.

  • Any examples of sites where your real IP address is listed even with the VPN enabled?

    I tried a few sites and they only displayed the VPN IP address.

  • @leocg Sure. How about Google.com? Just type in "what is my ip address" and BAM....there it is. If Google knows it doesn't everyone know it? Its the same address that shows up with Firefox. If I use an extention like KP Proxy it doesn't. I get an IP address in another part of the country. I think that's how its supposed to work. There are tons of people with exactly the same problem.

  • I only got a list of sites, what are the same I got when I did my test.

    Are you logged in to Google? If so then it may be getting your location from your phone.

  • @leocg I was logged into Google on my computer (not using a phone). I logged out, cleared cache/cookies and its exactly the same. The fact that its working for others gives me hope though.

  • @rh99 7ada8177-15d3-487a-88eb-368d9d2dde30-image.png

    Do you have the 'Bypass VPN for default search engines' option turned on? If so, that disables VPN for search engines only.

  • I totally forgot about that option.

  • @luca786toni Mine has been off. Tried turning it on....exactly the same. I'm trying with a search engine and at the website itself, just in case.

  • @rh99 5d03ddea-089d-4ae5-8f02-3df8b5568cff-image.png

    I don't know your full setup but have you tried setting WebRTC (3rd section in Privacy & security) to "Disable non-proxied UDP"?

    You might lose voice-chat in the web version of Discord but it's worth a shot.

  • Also check this
    https://www.iplocation.net

    About G
    2019-04-27_231403.png


    Windows 7 (x64)
    Opera Test profile | Opera Reset / Back up

  • @luca786toni Yes as I mentioned above I did that. Tried all the options.

    For some inexplicable reason I checked again and the IP Address wasn't showing my home city. I guess you can't control where it takes you. It took me to Sweden so everything was in that currency even though I had my home country's currency as the default in Settings. We need a VPN in our own country sometimes. You'd think the speeds would be faster as well if the geographical distance was a lot less.

Log in to reply