Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Forums Search Box Drop Down List

  • Yes, indeed, I think the issue still exists.

    SnagIt-16072019 052654.png

    SnagIt-16072019 052826.png

    Note: Initially I thought the issue was solved - reason why I wrote a comment to 'ignore my previous post'. However, after checking again just now, indeed, as said, the problem still exists.

  • @mopw69 I am a little bit confused.

    On this video it can be seen that you are first here: https://forums.opera.com/topic/31654/opera-forums-search-box-drop-down-list/14 (as I can see the fragment of that post). After typing "sync now" and clicking that search result you are taken to https://forums.opera.com/topic/30969/syncing-is-now-manual/1 (you can see the displayed topic changed). So... isn't that expected behaviour? Where's the issue?

  • @amatczak not working

  • Is anyone looking at this issue? I reported it back in April 2019 and as far as I can see the problem still exists!

  • @sharkyca Did you read the topic?

  • @leocg Many times since April when I posted it!

  • @leocg cc0d3e2d-d8a7-47a6-9e31-05c78d0050ad-image.png

  • @sharkyca So i guess I can assume that you already know the answer for your question.

  • @sharkyca I was looking into this issue quite extensively. Sorry, but I cannot reproduce it on any of my browsers and any of my devices, though. I honestly have no idea why some users have problem with that feature - and what's more confusing is the fact that even people in this thread have a hard time figuring out whether it works for them or not. For instance @mopw69 posts a video that is supposed to show the issue, but as far as I can tell it shows the opposite - that the search box works.

    So unless someone can provide a reliable way to reproduce this or figure out what all of the affected people have in common - I cannot spend more time chasing this.

  • @amatczak said in Opera Forums Search Box Drop Down List:

    @sharkyca I was looking into this issue quite extensively. Sorry, but I cannot reproduce it on any of my browsers and any of my devices, though. I honestly have no idea why some users have problem with that feature - and what's more confusing is the fact that even people in this thread have a hard time figuring out whether it works for them or not. For instance @mopw69 posts a video that is supposed to show the issue, but as far as I can tell it shows the opposite - that the search box works.

    So unless someone can provide a reliable way to reproduce this or figure out what all of the affected people have in common - I cannot spend more time chasing this.

    @amatczak I tried getting more info for you on this and duplicating the results on my end. Using 3 different browsers I was able to recreate the problem on MS Edge vers 44.18362.1.0, Chromium vers 75.0.3770.142 and Opera vers 62.0.3331.99.
    The real interesting part was when I turned on "screen recorder" from Windows accessories to record the problem it seemed to reset the browsers and the drop downs worked OK in ALL 3 BROWSERS, this leads me to suspect since they are ALL based on Chrome and I am running in a Windows 10 environment that it is more likely related to Windows than Opera! I am not a programmer but I do have a long history with computers going back to the days of IBM and mainframes, please give a quick look at the "screen clips" from Windows Recorder if you can! The shared links are here: https://drive.google.com/file/d/1Y5y4ThPtJ1A9ANNUMsEB9f643q6xVwgC/view?usp=sharing
    https://drive.google.com/file/d/15CoTXuUxy802AamtCgm4oWHILsse0MRn/view?usp=sharing

  • @sharkyca OK, thanks. I did some more research using BrowserStack and indeed the problem seems to happen when I tried in Edge on Windows 10. It looks very weird, because clicking the same item sometimes does not work, and usually work when clicking it again. I also got more failures the quicker I clicked after the dropdown shows. Waiting a little bit between hovering and clicking the item usually made it work (though not always!).

    I will look on your recordings of course. But I'll be honest - the issue seems non-trivial to pinpoint and does not affect all users, so probably it won't be the top of our priority list 😞

  • @amatczak
    As said, initially I assumed it was solved, but later I discovered it wasn't. Sorry for the confusion.

    I just made a new video and you will see that sometimes picking a thread from the drop down search results works fine, but sometimes it doesn't, it is a bit 50/50.

    Obviously I have no idea why sometimes it doesn't work. Leave it to the website developers to figure out.
    Please give it some extra tries.
    Right now I use Google site search, site:forums.opera.com

    https://youtu.be/fs-0bwREM7k

  • @mopw69 Thanks for the new video. That is consistent with my latest experience via BrowserStack.
    Can you please tell me what OS and what browser(s) have you tried? @sharkyca suggests this might be specific to Windows.

  • @amatczak My default browser is Opera, but Chrome and Edge are also on my system. Edge I never use. Chrome, very occasionally at best.
    Opera version: 62.0.3331.99
    Windows 10 x64: 1809 (build 17763.529)
    Don't know whether it has something to do with cookies.

  • @sharkyca How do I open these screen clips? They look like a text documents with HTML in it, not videos.

  • @mopw69 If you have access to mac or linux machine somewhere, can you check if the issue is present there as well? I want to rule out that it depends on the particular user here on the forums. If you don't see a problem when on a different OS than Windows, then it would suggest that indeed this is OS-specific, not user-specific.

  • @amatczak The files open with Internet Explorer. They were created using "steps recorder" Windows 10
    https://support.microsoft.com/en-ca/help/22878/windows-10-record-steps

    https://whatis.techtarget.com/fileformat/MHTML-MHTML-document-MIME
    d8ac3195-bb49-416e-aca6-f01bb085ba3f-image.png

    MHTML (short for MIME HTML) is a file extension for a Web page archive file format as saved by Internet Explorer. The archived Web page is an MHTML document. MHTML saves the Web page content and incorporates external resources, such as images, applets, Flash animations and so on, into HTML documents.

  • @amatczak Regretfully I don't have neither one of them on my system, so I can't test it.

    FWIW, I just gave it a try with a fairly clean Windows 10 x64 running in VMware Workstation. That Windows version is v903 (build 18362.267 - currently the latest one).
    Same problem.
    Enter any search string, scroll down in the drop down result list and pick anything from there. After 3 different search strings and three attempts, I didn't test it any further.

    I merely wanted to check whether it also happened with a later version of Windows.

  • @mopw69 @amatczak Sorry I was away from Opera for a bit, I see the problem still persists. Just an update on "My" browser and system I am using.
    Opera Version:62.0.3331.116
    Windows & Computer ! About Windows Specs.jpg

  • @amatczak I also can confirm this glitch on my computer (Windows 7 32-bit, screen resolution 1024x600px, with both Opera v62.0.3331.116 stable and Firefox v68.0.2).

    Other forums that use NodeBB as forum software also seem to be affected by this issue, for example:


    Thread title: Search function of the forum


    Question by Franz47:

    There is such a question in the forum, only if I click on this result of the search function, it doesn't trigger anything. Is there a solution? I tried it with Firefox and Chrome, it doesn't work with both browsers.

    Answer by styroll (a highly respected member there):

    You probably mean the suggestions that appear directly below the search field. When I click on a suggestion, nothing happens (I can't remember that it ever worked).


Log in to reply