Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Google photos not working

  • Clearing cookies made the job for me.

  • Update:

    After first visit after removing cookies it worked, second time doesn't.
    So it explains why it does work only in private mode...

  • It was the same for me, clearing cookies fixed the issue.

  • @tjall Exactly the same here, you clear them and it works the first time, then it doesn't after that.

  • @leocg Sorry to sound dumb, but what settings need to be reset? Can you give me instructions? So, google photos works in a private window, but not in a normal one. Clearling cookies, etc. works the first time you access the page after clearing them, but then not after that.

  • Opera's settings. Check menu > recover and update

  • Now it's my turn to sound dumb. Is there a Settings menu that I haven't found yet? I went to the Settings menu from the O Menu up in the left corner of the screen and checked all the items and did not find a Recover and Update setting. I also did a search for those terms and it did not find anything.
    So where exactly should I be looking?

    I have the same problem with Google Photos not working. I've disabled all of my extensions, all four of them, and it still doesn't work. I've tried clicking on the little vpn box on the address bar which I thought opened a private window but I guess not because Google Photos doesn't work that way either.

    When I opened a new window and then went to the O Menu and clicked on New Private Window, then it worked. But I don't think I should have to do that. It should be easier than that. You know, one of those transparent to the user things.

    Of course, Google takes no responsibility for this and makes a bunch of suggestions, all of which I tried and they didn't work. I went there before coming here.

    Is the New Private Window from the O Menu my only option? Is that going to be addressed in your next update?

    Thanks for the help, Carole

  • @morlaine said in Google photos not working:

    When I opened a new window and then went to the O Menu and clicked on New Private Window, then it worked.

    Here's an update on what I posted about an hour ago.

    Isn't there some way to White List this URL somewhere?

    Using the New Private Window option worked the first time, but not the next, or the next, or etc. Here's what I get. You can see it is in VPN mode.

    ![alt text](0_1551311966032_191d9d5e-1184-47f1-ac3f-de5ea91fd5b9-image.png image url)

  • It works with VPN off?

  • Update and recover is part of Opera's menu. It's below help.

  • i am facing the problem too for few days.
    the problem get solved if i Disable the option "Block third-party cookies
    Prevent third-party websites from saving and reading cookie data", and reload the page again. but after if i again Enable it, the page shows me "ERR_TOO_MANY_REDIRECTS".its really annoying. same thing i faced while browsing Gmail.but Gmail works perfectly now. whats the issue??

  • @leocg

    No it does not. One of the suggestions to get it to work but try it in VPN mode but that doesn't work either.

  • @leocg
    Thanks for the clarification. I clicked on it and then on the Update button but it finished as fast as I clicked it, so I don't think it updated anything. And I still have the same problem with Google Photos.

  • Did you check the suggestion about cookies?

  • @morlaine i get the same screen.

  • Have the same issue for several weeks!
    Tried everything what was suggested above, didn't help.
    Have to use another browser.
    I've found this page https://photos.google.com/browser-not-supported/

  • As it happens Google's own Chrome was hit this same way. Not every user seems to have the problem - Opera, Chrome, and all Chromium based browsers run into this. But not all of their users experience it. Sadly, Google, Opera, etc., have responded poorly to this bug.

    WORKING SOLUTION:

    You want to go to Settings, Content, Cookies, and instead of a destructive clearing, you want to Allow:

    GoTo opera://settings/content/cookies?search=Content+settings

    OR

    opera://settings/content?search=Content+settings
    (then find Cookies)

    OR

    Goto opera://settings
    (then look for Content Settings, then Cookies)

    Clicky triangle to open Cookies panel.

    Under the Allow section, select ADD.

    Refer to the tab where you got your original ERR_TOO_MANY_REDIRECTS error.
    You'll see a URL just below the error. That's what you plug into the Cookies-Allow section.

    We should not have to fudge around like this, but, blame the Chromium makers and Google:

    In the case of our GMail problem you want to Allow mail.google.com
    Or if it's an accounts problem, then allow accounts.google.com
    You get the idea.

    0_1552102205185_81b17ccf-6cc5-4e47-8cc2-7cd907a0e418-image.png

  • @veganamigansagan said in Google photos not working:

    opera://settings/content?search=Content+settings

    thank you for your idea and suggestion.

  • @veganamigansagan said in Google photos not working:

    veganamigansagan

    veganamigansagan Thank you so much. Finally a solution that works and works more than once. I hate it when I have to use a different browser other than Opera. Opera is the best without a doubt and seems to get better all the time. Keep up the good work guys.

  • This post is deleted!
Log in to reply