Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Latest Opera does not work with Sandboxie

  • The latest Opera version does not work with Sandboxie on Windows 10.

    My details -
    Sandboxie 64 bit version = 5.27.2.0 created 05/12/18
    Opera browser version = 57.0.3098.76
    Windows 10 - 64 bit version 1803 OS build 17134.441
    Anti-virus = McAfee

    Action -
    Simply installed Opera
    Simply installed Sandboxie
    When finished, clicked Sandboxie icon to open browser.
    White screen appeared and note saying Sandboxie default box was loading.
    The red border I configured on Sandboxie was present around the white screen.
    The default box stuck frozen at loading and never stopped.
    Killed it.

    The problem is with Opera.
    Reason ? Because Chrome and Firefox work instantly with Sandboxie in seconds, no problems.

    So until Opera sort this software bug out, all Opera users with Windows 10 will have to find another default browser if they wish to use Sandboxie. I have used Opera for many years with Sandboxie using Windows XP.

    I will now use Chrome or Firefox as my default browser until Opera sort out their software compatibility with Sandboxie.

  • I can confirm the issue. But, I don't know much about Sandboxie except that it usually causes issues with Opera unless you do some extra configuration in the settings for the sandbox. I got issues about start/run restrictions for launcher.exe, opera_crashreporter.exe and opera_autoupdater.exe, but I'm not sure yet how to fix those.

    I think you have to add some access to Opera's profile folders too.

    Maybe the extra configuration is only needed when using newer operating systems that have more security than WinXP.

    I'll play with Sandboxie more to see if I can figure out what settings need to be set.

  • I have posted this matter on the Sandboxie Forum.

    I am not alone, there are a great number of Opera users moaning about this issue.
    The consensus of opinion is that it is purely the latest Opera updates that have screwed it up and it is entirely an Opera matter.
    Like I said - Chrome and Firefox are not affected. I will just use one of these browsers until Opera sorts themselves out.

  • Could you link to the forum thread here so we all can see it?

  • I see that modifying the "Sandboxed Web Browser" shortcut command and adding --no-sandbox to it (a Chomium command-line option which gets passed to Opera's launcher.exe) works around the issue.

    --disable-gpu-sandbox helps some, but not all the way, which is why you have to use --no-sandbox.

    For Opera, I guess you have to disable the Chromium sandboxing to let Sandboxie's sandboxing do its work.

    Not sure why it's not needed for Chrome though.

    I also read from that thread that Opera might be a little crashy with --no-sandbox, but I can't confirm that yet.

  • From another Sandboxie thread, I see that in addition to --no-sandbox being used, you might have to add OpenIpcPath=*\Sessions\*\BaseNamedObjects\CrSharedMem_* to sandboxie.ini.

  • One thing is certain, adding "--no sandbox" or "-no-sandbox" to the Opera target line is totally useless -
    it simply does not work ! Back to the drawing board.

  • @johnbull44 It worked for me.

  • @burnout426 said in Latest Opera does not work with Sandboxie:

    burnout426

    @burnout426
    Then why not for me ?
    My computer is brand new, only 3 days old. I have done nothing but elementary learning and basic user operations. I am no novice, having had 14 years of experience, most of that using Sandboxie.
    Chrome and Firefox work perfectly with Sandboxie and Opera does not, even with the DIY fixes applied.

    Users should not have to fiddle about trying to make Opera work. Why should they when the other browsers give no problem. It is an Opera software matter.

  • @johnbull44 said in Latest Opera does not work with Sandboxie:

    Then why not for me ?

    Try this.

    Windows Key + r
    Type cmd and press enter.

    Type the following command and press enter

    "C:\Program Files\Sandboxie\Start.exe" "C:\Program Files\Opera\launcher.exe" --no-sandbox
    

    (Adjust path to Opera's launcher.exe to match where your Opera's launcher.exe is at)

    Does it work that way?

  • @johnbull44 said in Latest Opera does not work with Sandboxie:

    Users should not have to fiddle about trying to make Opera work. Why should they when the other browsers give no problem. It is an Opera software matter.

    Not disagreeing with you. Just seeing if there's a workaround.

  • @burnout426

    "C:\Program Files\Sandboxie\Start.exe" "C:\Program Files\Opera\launcher.exe" --no-sandbox
    Never worked
    [img]https://i.imgur.com/REfsOxN.jpg[/img]

  • @johnbull44 said in Latest Opera does not work with Sandboxie:

    Never worked

    That error dialog says that it can't find launcher.exe. Open up Opera directly, goto the URL chrome://about and look at the Install path under the "Paths" section. That'll tell you what directory launcher.exe is in so you can fix the path for the command. For example, it might be:

    "C:\Program Files\Sandboxie\Start.exe" "C:\Users\YourUserNameHere\AppData\Local\Programs\Opera\launcher.exe" --no-sandbox
    

    that you have to do.

    Also in the dialog, it shows that you didn't type --no-sandbox correctly.

  • @burnout426

    I sincerely thank you for all your help and effort in trying to get me going with Sandboxie. Very grateful indeed.

    Promise -
    I will definitely try your latest fix and let you know. It looks very promising.
    John

  • @burnout426

    I am deeply disappoinjted, but your last fix -
    "C:\Program Files\Sandboxie\Start.exe" "C:\Users\YourUserNameHere\AppData\Local\Programs\Opera\launcher.exe" --no-sandbox
    never worked - still a white screen.
    Gone back to normal Opera opening.

  • @johnbull44 said in Latest Opera does not work with Sandboxie:

    @burnout426

    I am deeply disappoinjted, but your last fix -
    "C:\Program Files\Sandboxie\Start.exe" "C:\Users\YourUserNameHere\AppData\Local\Programs\Opera\launcher.exe" --no-sandbox
    never worked - still a white screen.
    Gone back to normal Opera opening.

    I assume you replaced "YourUserNameHere" with your Windows account username since you said you got a white screen Opera?

    In addition to --no-sandbox, try doing this fix.

    If that doesn't work, in addition to those, try doing the same command but also add --disable-gpu.

    "C:\Program Files\Sandboxie\Start.exe" "C:\Users\YourUserNameHere\AppData\Local\Programs\Opera\launcher.exe" --no-sandbox --disable-gpu
    

    If that doesn't work, click on the start button, type cmd, right-click on the command prompt shortcut and choose "run as administrator". Then try the command again.

    Please report back your findings. Thanks.

  • A few other things to try in addition to the previously-mentioned stuff.

    Try disabling McAfee temporarily to see if it's interfering.

    Try disabling all extensions in Opera. You can try the --disable-extensions command-line switch to/instead if you want.

    Download the Opera installer, launch it, click "options", set "install path" to a folder named "Opera Test" on your desktop, set "install for" to "standalone installation" and install. Once that Opera loads, close it.

    Then, open up a command prompt and run the command:

    "C:\Program Files\Sandboxie\Start.exe" "C:\Users\YourUserNameHere\Desktop\Opera Test\launcher.exe" --no-sandbox
    

    just to see how things behave with a fresh profile.

  • The Windows user account you're testing on, is it an administrator account or a standard user account?

  • What GPU and driver version do you have? Thanks.