Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hi,

    I've just updated to the latest Opera 57 and the TrackPoint Scroll (hold middle mouse button and move TrackPoint up or down) stopped working. That's reallly annoying.
    Anybody else having this problem or a possible solution?

    Now I've downloaded the last Opera 56 stable and I'll try to downgrade.
    Lacking such a crucial ability like scrolling a page is unacceptable for me.

  • If you have a middle mouse button, you could use autoscroll. Just tap the middle button then move the pointer.

  • The trackpoint autoscroll (when holding down the special middle button) is working for me in 57.0.3098.76 64-bit on Windows 10 Pro 64-bit.

    Lenovo T520 + Synaptics driver I think this driver is a generic driver from that I got to fix some issues with the touchpad not working for a sec after typing on Windows 10. However, I can't seem to find the generic drivers on their site anymore. I looked at, but the download links are missing now. I see them on other sites though when searching Google. You might have to update your drivers. Lenovo's support site has really old drivers (for mine at least) that don't work well with Windows 10.

    @sgunhouse said in TrackPoint Scroll doesn't work (Lenovo ThinkPad):

    If you have a middle mouse button, you could use autoscroll. Just tap the middle button then move the pointer.

    The button in question is different than a regular middle-click button. It's a button that you hold down the whole time when you're moving the trackpoint up and down or left and right on the laptop. You can't click it and release to autoscrol. It's in the middle of the left and right mouse buttons that are below the keyboard. These are separate from the left and right buttons below the trackpad.

  • I'm running Windows 7 64-bit with Service Pack 1 on a Lenovo ThinkPad X61 Tablet and TrackPoint Software 4.73.1 (which seems to be the latest one available).

    Opera Version 56.0.3051.116 is the last to support the TrackPoint Scrolling functionality.

    Unfortunately on the latest Opera 57 Stable and Opera 59 Developer TrackPoint Scrolling doesn't work anymore.
    Horizontal Scrolling is working, but Vertical Scrolling isn't.

    Therefore I have downgraded Opera to the latest 56 release, but I will lack all new features and bug fixes. Right now that seems to be a fair solution. Anyway, is there an option to disable automatic Updates of Opera so that I don't need to re-downgrade to Version 56 each time?

    With the latest Mozilla Firefox, Google Chrome and other Software like Total Commander, Windows Explorer, etc. the TrackPoint Scroll is working properly. So it is an Opera Issue.

    Is there a chance this message reaches the Opera Developer Team, so they can work on it? Or am I doomed with my antique Hardware?

  • @celadyn said in TrackPoint Scroll doesn't work (Lenovo ThinkPad):

    Anyway, is there an option to disable automatic Updates of Opera

    Close down Opera and rename opera_autoupdate.exe in Opera's program files folder. The one you want to rename is the one that's in the latest version folder.

  • @celadyn said in TrackPoint Scroll doesn't work (Lenovo ThinkPad):

    Is there a chance this message reaches the Opera Developer Team, so they can work on it?

    There's a chance.

    @celadyn said in TrackPoint Scroll doesn't work (Lenovo ThinkPad):

    With the latest Mozilla Firefox, Google Chrome

    Can you test with Vivaldi, the latest snapshot of Vivaldi on the right side of, Chromium and Chrome Canary and report back if it's broken in any of them?

  • I have just tested the TrackPoint on Wikipedia: Google with following browsers


    • Opera Version: 56.0.3051.116, Update stream: Stable
    • Chromium Version 73.0.3638.0 (Developer Build) (64-bit)
    • Google Chrome Version 73.0.3637.0 (Official Build) canary (64-bit)
    • Vivaldi 2.1.1337.51 (Stable channel) (32-bit)
    • Vivaldi 2.2.1388.29 (Official Build) (32-bit)


    • Opera Version: 57.0.3098.91, Update stream: Stable
    • Opera Version: 59.0.3167.0, Update stream: developer
  • I have the same problem as people above. Is there any fix for it already?

  • @celadyn As Opera Developer is based on Chromium 72 while Vivaldi is still on a previous version of Chromium (they are only now releasing builds based on 72 to testers), I'd say the issue is probably Chromium 72. You could check in Opera 56 (the About Opera page, where it lists the Browser Identification) to check, but I'm sure it'll be an older version of Chrome. Based on your Chromium results, it should be fixed when Opera updates to Chromium 73.

  • @sgunhouse Hi, Do you know when Opera updates to the new version of Chromium? It is almost March and trackpoint still doesn't work in this browser.

  • Opera Developer is using Chromium 73. You can try in it to see if the issue is fixed.

  • @burnout426 0_1551310565614_84f134f8-401e-4bc3-9b9e-67b4341ab812-image.png

    It still doesn't work

  • That's not Opera Developer.

    Goto and click on "CLICK HERE FOR BETA AND DEVELOPER VERSIONS OF OPERA". Then, under "Opera for computers developer version", click "Download the offline package.".

    Once downloaded, launch the installer, lcick "options" set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. Test in that Opera when it loads. To load it again, double=left-click launcher.exe in the install folder on your desktop.

    The version you're going to get is 60. In that Opera, goto the URL opera://about and take look at the "Browser Identification". You'll see that it's using Chromium 73.

    Long story short, you have a while yet till Chromium 73 gets in the stable version of Opera. But, you can test Opera Developer to see using Chromium 73 will even fix the issue in Opera.

  • @burnout426 You are right, I didn't have Deveolper version before.
    So now I've installed the correct one (60.0.3242.0) and unfortunately still only horizontal scrolling works - left/rigth. I can't scroll up/down with the trackpoint.


    So to make it clear and updated for people visiting this topic:
    Chromium 73 does not resolve the issue with TrackPoint in Opera.

    I still love Opera but I miss this feature really much 😔

  • Hello, try adding this to your C:\Program Files\Lenovo\TrackPoint\tp4table.dat

    ; Opera web browser

    add right before the line that reads:

    ; Pass 1 rules (These rules run last)

    Then kill tp4serv.exe and re-run it.

    I have successfully restored the trackpoint scrolling under Opera 60.0.3255.27

  • @polardbt1014
    One more thing because it didn't work on the beginning.
    I had to comment the original rule few lines earlier.

    But after that, YES.
    Trackpoint scroll now works again. After half year of scrolling with arrows I can use Opera comfortably again.
    Thank you @polardbt1014