Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

auto start torrent link

  • @tis681 The command prompt or the "start" command?

  • @burnout426 the "start" command.

  • Okay. "Start Menu -> Settings -> Apps -> Default Apps -> "Choose default apps by protocol" -> magnet". Click the icon to the right of it and choose your torrent program. If "magnet" isn't available or it is but your torrent program isn't shown for the magnet protocol, you need to fix the installation of your torrent program so that it adds magnet support to the registry for itself.

  • @burnout426
    the "magnet" isn't available and torrent program(tixati) isn't shown for the magnet protocol. what am I going to do now ΅?

  • @tis681 Is the program shown for the "torrent" protocol at least?

    @tis681 said in auto start torrent link:

    what am I going to do now ΅?

    Maybe reinstall tixati first and or look in its settings for an option to register itself. If nothing else, we'll have to come up with a reg file that you can import to add magnet manually.

  • @burnout426 there is only by default archive type

  • I just downloaded the tixati windows 64-bit installer. When I run it, there are checkboxes in the installer to register torrent and magnet. Sounds like you just need to run the installer again and make sure those are checked.

  • @tis681 said in auto start torrent link:

    @burnout426 there is only by default archive type

    ![alt text](0_1542798115331_Screenshot_2.png image url)

    @tis681 said in auto start torrent link:

    @burnout426 there is only by default archive type

  • I just installed Tixati and tested the "start" command I mentioned earlier and Tixati loads up like it's supposed to.

  • @burnout426 οκ .Thanks my friend

  • I guess Tixati doesn't add itself to "Default Apps", so I guess you can't set it with "Set default by apps" or "Set default by protocol". But, the Tixati installer does the trick.

  • If you go into the Tixati settings and goto "Shell Integration", there are options for torrent files and magnet links etc. It should allow you to fix things that way.

  • Once you get the start command working, let us know whether it works in Opera or not.

  • And, for future reference, if you every have to, these are the keys Tixati creates for the magnet protocol, just in case you every have to do things manually.

    tixati_magnet.reg

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\magnet]
    @="URL:torrent magnet link"
    "URL Protocol"=""
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\magnet\DefaultIcon]
    @="\"C:\\Program Files\\tixati\\tixati.exe\",1"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\magnet\shell]
    @="open"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\magnet\shell\open]
    "FriendlyAppName"="Tixati"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\magnet\shell\open\command]
    @="\"C:\\Program Files\\tixati\\tixati.exe\" \"%1\""
    
    [HKEY_CLASSES_ROOT\magnet]
    @="URL:torrent magnet link"
    "URL Protocol"=""
    
    [HKEY_CLASSES_ROOT\magnet\DefaultIcon]
    @="\"C:\\Program Files\\tixati\\tixati.exe\",1"
    
    [HKEY_CLASSES_ROOT\magnet\shell]
    @="open"
    
    [HKEY_CLASSES_ROOT\magnet\shell\open]
    "FriendlyAppName"="Tixati"
    
    [HKEY_CLASSES_ROOT\magnet\shell\open\command]
    @="\"C:\\Program Files\\tixati\\tixati.exe\" \"%1\""
    

    (for the 64-bit Tixati in the default location)

  • @burnout426 said in auto start torrent link:

    Once you get the start command working, let us know whether it works in Opera or not

    dont working in opera.
    I will send you to all the answers and photos to see and what exactly .... prevails ..hahahah😁

  • @tis681

    @burnout426 said in auto start torrent link:

    "Shell Integration" all Set default

    3_1542806814964_Screenshot_13.png 2_1542806814964_Screenshot_12.png 1_1542806814964_Screenshot_11.png 0_1542806814963_Screenshot_10.png

  • @burnout426 👁 translate
    προεπιλογή = default
    τύπος = tupe
    όνομα =name
    δεδομένα = data
    η τιμή δε έχει οριστεί = the value is not set

    5_1542806897222_Screenshot_8.png 4_1542806897222_Screenshot_7.png 3_1542806897222_Screenshot_6.png 2_1542806897221_Screenshot_5.png 1_1542806897221_Screenshot_4.png 0_1542806897220_Screenshot_3.png

  • @tis681 said in auto start torrent link:

    dont working in opera.

    Is the start command at least working now?

    If so, in Opera, goto the URL opera://settings/handlers and make sure "magnet" is NOT listed there. If it is, remove it.

  • Another thing you can do:

    Goto the URL opera://about and take note of the "profile" directory. Then, close down Opera. Then, use JSONedit to edit the "Preferences" file in the profile directory. As a child of root/protocol_handler/excluded_schemes, make sure there's a boolean node type named magnet with a value of false. Save your changes.

    What that will do is set the "always allow" checkbox that you see in the dialog the first time you try to use a magnet link in Opera.

    If that doesn't help, close down Opera and remove the magnet node. Then, when you start Opera and type magnet://test in the address field and press enter, you should get prompoted to allow it ot open in Tixati or not with the option to always allow.

  • Also, where at in Opera are you testing magnet links? As in, what page specifically? What happens if you type magnet://test in Opera's address field and press enter? Does that at least work?

    Another thing you can try. Download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. Try in that Opera. Does it work there at least?

Log in to reply