Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera opens smaller than the screen

  • @jimunderscorep Thanks a lot for the answer.

    It's kinda strange that Opera, a Chromium spin, would have that behavior while Vivaldi and Brave, also Chromium spins, would not, not to mention Chromium itself.

  • @jimunderscorep

    I've been using this fix for a long time.

    The latest Opera v56.0.3051.31 breaks the fix, with Opera opening in a 4:3 ratio window, and, so far, not maximizing with any control I can find. Full Screen mode is a useless alternative.

    Frankly, it's easier just to roll back to v55 than try to communicate with developers.

  • Opera 56 still works with that switch for me...
    To be fair, I have been using the switch for the last 10 or so versions of opera., with no problem at all. If it helps, I use openbox as my window manager.

    As for being "a chromium spin thar behaves differently than the other spins", this is not the case. The issue above does not have to do with the engine used to render web pages but with the way that the app draws its ui.

  • I just noticed something odd...
    I opened opera earlier, from the typical shortcut that lauches it with the above switch (--start-maximized) and it did launch in a maximized window as usual.
    When I wanted to open a new window, I clicked the same shortcut again, but this time the switch was ignored and it opened in a non-maximized, centered window 😕

    Opening a new window from the running, maximized instance of opera, via ctrl+n or via the o-menu > new window, opened up maximized.

  • There's another twist to this Problem.
    A while ago,I replaced windows with Linux on all familly-PC,so we got 3 laptops,one with Ubuntu Unity 16.04,one Kubuntu 16.04,one Mint 18.3 and 2 desktops with Mint 18.2 and 18.3.
    The problem occurse only on all laptops.Editing the opera.desktop file in /usr/share/applications/ with: opera %U --start-maximized solves the problem.
    BUT: With every update,it is overwritten AGAIN.
    So it's an update problem too,and where is the difference between laptop and dektop?

  • This worked for me in Linux Mint 19 xfce

    Edit launcher
    Change Command to:

    opera %U --new-window --start-maximized

  • Решение для Xubuntu 18.04. Входим в Opera> открылось окно в центре экрана > Разворачиваем окно на весь экран> Боковая панель O>Расширения>Получить расширения> в поиске full Screen, выбираем Fullscreen Anythig>Устанавливаем и активируем>Закрываем Opera. При следующем запуске Opera раскрывается на весь экран.

  • Sorry @Sera53 , but this part of the forum is in English.

  • An update on this.

    v57.0.3098.91 is working OK

    As of right now, a new version is available, but I had to back out of the upgrade because of loading problems. Linux, it seems, is such a broad target that, when you have a working Opera version, you need a way of getting back to it.

  • The fix doesnt work for everything. Case in point:

    1: Thunderbird and Opera are open (both full screen, Opera opened from the panel full screen via the edited launcher shortcut in my panel)
    2: I click the shortcut in the panel to view my desktop (leaving Opera and Thunderbird in full screen, but focus taken away from both and given to desktop)
    3: I then click a hyper-link (shortcut on desktop, or in Thunderbird in an email)
    4: I click on Opera (the link opens, but it doesnt shift focus back to Opera, I have to do it manually by clicking on the Opera tab in the panel) and Opera is actually shrunk down again, just like it is when opened without the "maximized" launcher edit.

    So opera wont even stay full screen, once focus is taken away from it, and you return back to it. I like the browser, but some of these bugs (not playing videos after an update is another) are about to push me back to Firefox.

    P.S. Running Linux Mint 18.3 W/Cinnamon 3.6.7 and Opera 57.0.3098.102

  • @silverfox66 said in Opera opens smaller than the screen:

    4: I click on Opera (the link opens, but it doesnt shift focus back to Opera, I have to do it manually by clicking on the Opera tab in the panel) and Opera is actually shrunk down again, just like it is when opened without the "maximized" launcher edit.

    This is EXACTLY what I said above. A new instance of opera, regardless of where it was launched from, starts in a non-maximized window.
    And lets assume that thunderbird launches opera like so, with no extra switches

    opera http://example.com

    Why does it launch in a smaller window when it is launed by the launcher that starts it with the right parameter, i.e

    opera --start-maximized

  • @jimunderscorep Same thing, but different. You said "When I wanted to open a new window, I clicked the same shortcut again, but this time the switch was ignored and it opened in a non-maximized, centered window". I wasnt clicking the same edited shortcut to open a new window, but rather clicking a hyperlink elsewhere, to open a new tab in the already maxmized window, which was now running in the background. The window was maximized when the focus left the window, but upon returning focus to the window after clicking a hyperlink, the window was now small. So yeah, same buggy outcome, but different circumstances getting there

  • @silverfox66 I can confirm this small issue with the opera --start-maximized workaround.
    Any fix for this fix? 😏

Log in to reply