Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Colored background showing in text/search fields

  • @sgunhouse Bollocks. It's not "hardware dependent" when problem all of a sudden happened with Opera update across various hardware from crappy integrated Intel graphics to top of the line GTX 1080Ti cards. And it's not even only happening on webpages, it's happening within Opera components themselves. I was just editing a bookmark and the text in bookmark name field was flashing and sperging like we've reported it already. So, clearly Opera team broke something and has nothing to do with our systems or configurations we have.

  • Hardware dependent means that it only occurs on some hardware - which it does. That is not saying it is caused by the hardware. But if they don't know what hardware is required in order to reproduce the bug they won't be able to see the bug and will never know if something they try actually fixes it.

    If you're not interested in seeing a fix, just keep ranting. Otherwise tell them something that might help them identify it.

  • So, I guess this is the moment where a random nobody (me) needs to teach actual developers how to fix things in their own program...

    Instead of waiting months for people to post obvious things like the fact it appears on ALL NVIDIA and Intel GPU's (still waiting for mystery AMD users to show up, shall we wait for couple more months?) and apparently ALL Windows 8 and 10 versions starting with Opera 56, they could backtrack through Opera versions to the version which wasn't doing this (we have a rough timeframe and even version reports, the first Opera 56 build), read the changelogs what they changed back then, which may have caused this problem in that version and start from there? Just pointing out the Jupiter sized elephant in a room... When you know what was the exact version that started doing this, but one version back didn't, you literally just compare the changes done between the two and you'll find the problem. But hey, what do I know about the very basics of debugging stuff...

  • You know that they probably have been doing it already, right? And maybe they couldn't (easily) reproduce the problem, so they may haven't been able to narrow down in which build the issue started to compare anything.

  • @xpvb48 said in Colored background showing in text/search fields:

    Intel Celeron CPU 1000M - Driver v. 6.2.9200.16451

    That narrows it down to the HD 2500 or HD 4000 for 3rd-gen Intel processors.

    Looking for the last driver for those on the Intel website brings me to The first one in the list is for Win 8.1 etc. If you view the release notes for it, it's version For the others, those are WinXP drivers and are 6.xxxx drivers. Makes me wonder if your 6.2 drivers (while working on Win 8.1), are the correct and latest drivers.

    @derloopkat has Win 8.1 and HD 4xxxx Intel GPU too. Wonder if that matters.

  • @rejzor What specific Nvidia/Intel GPUs can you reproduce with? Can you reproduce with Vivaldi, Chromium and Chrome also or just Opera?

  • Main specs:

    • Win 10 x64 - 1803
    • Opera 56.0.3051.52 (bug appeared for all 56 builds so far)
    • NVidia GForce GTX 1070 Ti w/ driver 397.64

    Potentially relevant ...

    • two monitor setup
    • main @ 4k, secondary @ WUXGA

    Vivaldi 2.1: no problems

  • @burnout426 said in Colored background showing in text/search fields:

    @derloopkat Have you tried ths newest driver from Intel?

    When I try to update my Acer laptop using the Intel Assistant I get this error:

    A customized computer manufacturer driver is installed on your computer. The Intel Driver & Support Assistant is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer."*

    So I've got my serial number and checked Acer web site support. It seems I have the latests "customized" driver version provided by Acer.

    Aspire E1-572, Model Name: E1-572, Windows 8.1 64bits

    • VGA Driver Date: 2013/12/19 Version:
    • VGA Driver Date: 2013/10/11 Version:
  • @derloopkat said in Colored background showing in text/search fields:

    When I try to update my Acer laptop using the Intel Assistant I get this error:...

    Yeah, the intel drivers are generic, but they might work better. You have to ignore that warning or uninstall your current drivers first to use the ones directly from Intel. They could work worse as said, but there's only one way to find out.

  • @tabmow I'm with you on this.

    Just today Opera updated to Version:56.0.3051.52 and the text box issue other's have posted have shown up.

    I'm on Win 10 x64 - 1803
    newest driver for Nvidia GeForce GTX 1070 416.34 - WHQL
    Release Date Thu Oct 11, 2018

    Turning off hardware acceleration fixed it but what's up with this bug? It wasn't there in the previous version of Opera I had before hand. Can't say exactly what version it was though.

  • If you look in Opera's program folder, there may be a subdirectory named for Opera's previous version. Possibly several versions even. So you might be able to find the previous version.

  • @sgrandin said in Colored background showing in text/search fields:

    Using each version of 56b (Win 10, 1803).

    So, it started with at least?

    Can someone with this problem check with the first build of 56 to hit the developer channel?

    If it doesn't happen there, see and move up to the next 56 build to see if you can narrow it down to the first 56 build that has the problem.

    If it does happen in that first 56 developer build, see and try the newest builds of 55 and work backwards till you don't have the issue anymore.

  • @burnout426 it started with 56.0.3051.36

    Straight away once that Installed it started and it doesn't happen in Chrome.

  • @magma500 said in Colored background showing in text/search fields:

    @burnout426 it started with 56.0.3051.36

    As in, it works fine in the last Windows build before which is 56.0.3051.31?

    Can you download the installer for 56.0.3051.31, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", install and try in that Opera to make sure?

  • @derloopkat To get around that you need to go into the device manager, manually update the driver, choose "Have Disk", then point it to an extracted version of that driver. (Use 7-zip and right-click -> Extract the Intel driver update.) Once you replace the OEM specific driver with a generic intel one, you can install it properly immediately after. I did that to an old HP laptop a while back, and saw WEI scores jump from like 4.9 to 5.4. What a difference an up to date graphics driver makes.

    That said, guess why I am here?

    Flickering crazy selection crap (up to 4 different shades/colours jostling and jumping around in the background as I type) on:

    Win10 x64 1803
    GTX 1070

    I typically have at least two or three web browsers open at once, and also office software like LibreOffice.

  • @kramy Could you also try narrowing it down to the first build that has this issue on your system?

  • @kramy said in Colored background showing in text/search fields:

    GTX 1070

    Searching for the latest driver for the 1070, I get, which is 416.81. Can you try that one just to see if there's any difference?

  • I'm testing on a Win10 x64 laptop with an Intel n4200 that has an HD 505 GPU and can confirm the issue,

    As in, it works fine in the last Windows build before which is 56.0.3051.31?

    The issue is still in that build too. I'm going to keep trying previous builds to see if I can find out when the issue started exactly. However, with Opera Developer build 58.0.3134.0, I can't reproduce the problem. So, maybe the issue is already fixed.

  • I can also confirm that the issue doesn't affect Chrome, Chromium and Vivaldi.

  • Issue still present following Opera 56.0.3051.99 update on my Win 8, 64 Bit using Intel built in graphics.

    Solution still the same: Turn off hardware acceleration.

Log in to reply