Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Colored background showing in text/search fields

  • Since it is hardware-dependent, it can only be reproduced on similar hardware. My own system here (64-bit Windows 10, 64-bit Opera, AMD GPU) has no issues.

    As far as what version of Opera you have - the network installer should detect what version of Windows (64-bit or 32) and download the corresponding version of Opera. If you look at Help > About Opera and the Browser Identification included "Win64, x64" then Opera is 64-bit. If it says WoW64 then it is a 32-bit Opera on 64-bit Windows. And of course if you have 32-bit Windows then you can't run 64-bit software at all so it will be a 32-bit Opera version.

  • @xpvb48 said in Colored background showing in text/search fields:

    What GPU do you have (Brand, Model, Driver version)?

    Intel(R) HD Graphics, Resolution setting 1366 x 768, Driver version 9.17.10.3040 Haven't updated yet!

    I have Intel HD Graphics 3000 GPU with WHQL driver version 9.17.10.4459, which is a Win10 driver. The latest Win 8.1 driver for mine is 4229.

    I can't reproduce this problem at all. What CPU do you have (to better identify the GPU like in this thread?

  • @burnout426 I have Windows 8.1. My chip type says Intel(R) HD Graphics Family and adapter string is Intel(R) HD Graphics 4400. Driver version is 10.18.10.3355. Downloaded latest Opera and it's turning hardware acceleration on, which is causing issues in my case. Today I had to disable this setting again. No sure what changed it.

  • @sgunhouse said in Colored background showing in text/search fields:

    As far as what version of Opera you have - the network installer should detect what version of Windows (64-bit or 32) and download the corresponding version of Opera. If you look at Help > About Opera and the Browser Identification included "Win64, x64" then Opera is 64-bit. If it says WoW64 then it is a 32-bit Opera on 64-bit Windows.

    It says WOW64 on my 64 Bit Win 8 machine, which is correct as it is the 32 Bit Opera. So why isn't it the 64 Bit Opera and does it matter?

  • @burnout426 said in Colored background showing in text/search fields:

    @xpvb48 said in Colored background showing in text/search fields:

    What GPU do you have (Brand, Model, Driver version)?

    Intel(R) HD Graphics, Resolution setting 1366 x 768, Driver version 9.17.10.3040 Haven't updated yet!

    I have Intel HD Graphics 3000 GPU with WHQL driver version 9.17.10.4459, which is a Win10 driver. The latest Win 8.1 driver for mine is 4229.

    I can't reproduce this problem at all. What CPU do you have (to better identify the GPU like in this thread?

    Intel Celeron CPU 1000M - Driver v. 6.2.9200.16451

  • @sgunhouse Bollocks. It's not "hardware dependent" when problem all of a sudden happened with Opera update across various hardware from crappy integrated Intel graphics to top of the line GTX 1080Ti cards. And it's not even only happening on webpages, it's happening within Opera components themselves. I was just editing a bookmark and the text in bookmark name field was flashing and sperging like we've reported it already. So, clearly Opera team broke something and has nothing to do with our systems or configurations we have.

  • Hardware dependent means that it only occurs on some hardware - which it does. That is not saying it is caused by the hardware. But if they don't know what hardware is required in order to reproduce the bug they won't be able to see the bug and will never know if something they try actually fixes it.

    If you're not interested in seeing a fix, just keep ranting. Otherwise tell them something that might help them identify it.

  • So, I guess this is the moment where a random nobody (me) needs to teach actual developers how to fix things in their own program...

    Instead of waiting months for people to post obvious things like the fact it appears on ALL NVIDIA and Intel GPU's (still waiting for mystery AMD users to show up, shall we wait for couple more months?) and apparently ALL Windows 8 and 10 versions starting with Opera 56, they could backtrack through Opera versions to the version which wasn't doing this (we have a rough timeframe and even version reports, the first Opera 56 build), read the changelogs what they changed back then, which may have caused this problem in that version and start from there? Just pointing out the Jupiter sized elephant in a room... When you know what was the exact version that started doing this, but one version back didn't, you literally just compare the changes done between the two and you'll find the problem. But hey, what do I know about the very basics of debugging stuff...

  • You know that they probably have been doing it already, right? And maybe they couldn't (easily) reproduce the problem, so they may haven't been able to narrow down in which build the issue started to compare anything.

  • @xpvb48 said in Colored background showing in text/search fields:

    Intel Celeron CPU 1000M - Driver v. 6.2.9200.16451

    That narrows it down to the HD 2500 or HD 4000 for 3rd-gen Intel processors.

    Looking for the last driver for those on the Intel website brings me to https://downloadcenter.intel.com/product/97499/Graphics-for-3rd-Generation-Intel-Processors. The first one in the list is for Win 8.1 etc. If you view the release notes for it, it's version 10.18.10.5059. For the others, those are WinXP drivers and are 6.xxxx drivers. Makes me wonder if your 6.2 drivers (while working on Win 8.1), are the correct and latest drivers.

    @derloopkat has Win 8.1 and HD 4xxxx Intel GPU too. Wonder if that matters.

  • @rejzor What specific Nvidia/Intel GPUs can you reproduce with? Can you reproduce with Vivaldi, Chromium and Chrome also or just Opera?

  • Main specs:

    • Win 10 x64 - 1803
    • Opera 56.0.3051.52 (bug appeared for all 56 builds so far)
    • NVidia GForce GTX 1070 Ti w/ driver 397.64

    Potentially relevant ...

    • two monitor setup
    • main @ 4k, secondary @ WUXGA

    Vivaldi 2.1: no problems

  • @burnout426 said in Colored background showing in text/search fields:

    @derloopkat Have you tried ths newest driver from Intel?

    When I try to update my Acer laptop using the Intel Assistant I get this error:

    A customized computer manufacturer driver is installed on your computer. The Intel Driver & Support Assistant is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer."*

    So I've got my serial number and checked Acer web site support. It seems I have the latests "customized" driver version provided by Acer.

    Aspire E1-572, Model Name: E1-572, Windows 8.1 64bits

    • VGA Driver Date: 2013/12/19 Version: 10.18.10.3355
    • VGA Driver Date: 2013/10/11 Version: 13.152.0.0
  • @derloopkat said in Colored background showing in text/search fields:

    When I try to update my Acer laptop using the Intel Assistant I get this error:...

    Yeah, the intel drivers are generic, but they might work better. You have to ignore that warning or uninstall your current drivers first to use the ones directly from Intel. They could work worse as said, but there's only one way to find out.

  • @tabmow I'm with you on this.

    Just today Opera updated to Version:56.0.3051.52 and the text box issue other's have posted have shown up.

    I'm on Win 10 x64 - 1803
    newest driver for Nvidia GeForce GTX 1070 416.34 - WHQL
    Release Date Thu Oct 11, 2018

    Turning off hardware acceleration fixed it but what's up with this bug? It wasn't there in the previous version of Opera I had before hand. Can't say exactly what version it was though.

  • If you look in Opera's program folder, there may be a subdirectory named for Opera's previous version. Possibly several versions even. So you might be able to find the previous version.

  • @sgrandin said in Colored background showing in text/search fields:

    Using each version of 56b (Win 10, 1803).

    So, it started with https://blogs.opera.com/desktop/2018/08/opera-56-beta/ at least?

    Can someone with this problem check with the first build of 56 to hit the developer channel? https://blogs.opera.com/desktop/2018/07/opera-56-developer/

    If it doesn't happen there, see https://blogs.opera.com/desktop/changelog-for-56/#b3003.0 and move up to the next 56 build to see if you can narrow it down to the first 56 build that has the problem.

    If it does happen in that first 56 developer build, see https://blogs.opera.com/desktop/changelog-for-55/ and try the newest builds of 55 and work backwards till you don't have the issue anymore.

  • @burnout426 it started with 56.0.3051.36

    Straight away once that Installed it started and it doesn't happen in Chrome.

  • @magma500 said in Colored background showing in text/search fields:

    @burnout426 it started with 56.0.3051.36

    As in, it works fine in the last Windows build before which is 56.0.3051.31?

    Can you download the installer for 56.0.3051.31, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", install and try in that Opera to make sure?

Log in to reply