Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Colored background showing in text/search fields

  • I've recently noticed that input fields or textareas on websites are not behaving as expected and they get this default Windows button sort of look. You can see what happens in the screenshots below.

    The Opera version is 56.0.3051.36 and it's running on Windows 10. There are no plugins or any special addons installed in the browser and this behavior happens on any website. Since it looks kind of like a graphical glitch, it may be worth mentioning that the graphics card used is Intel HD Graphics 620. In Edge or Firefox, there is no such problem.

    Do you know what the problem is and how to fix it?

    0_1538903763802_8998253b-0ee3-4526-b477-22befa254189-image.png

    0_1538903800287_f1b7be1d-20dc-4cc1-9483-f6dd18b64a40-image.png

    0_1538903869232_fcafb71a-456c-4799-9698-40f6ac7a258f-image.png

  • Yeah, I'm having the same highlighting issues too on several other websites. The moderator itt has not been helpful at all, so I was disappointed when I found this thread. At least I'm not alone. I hope you resolve your issue soon - if you do, please share what you did! This highlight is an annoyance.

  • You can temporaraily disable hardware acceleration (or GPU compositing) - there seems to exist some incompatibility between Intel video and Opera. There are few other threads with similar problem; I'm waiting for fix either.

  • So, I have a problem. On some websites (like LiveJournal and Dreamwidth), typing in a text box highlights in blue everything I type

    -see image-

    as well as the bottom of the text box. It also highlights certain things in gray when I hover over them.

    -see image-

    Some buttons (like a 'logout' button, for example) look like I've clicked them when I hover over them. Though, they don't get clicked. This only seems to happen on blogging sites that are not affiliated with one another.

    Things I've tried:
    Restarted my computer.
    Uninstalled Opera and Re-installed
    Uninstalled again, restarted again, re-installed again
    Re-set my settings

    Nothing works. I hate this update lol. And Please just help me in this thread. Don't link to any other posts unless there is a direct answer for this specific issue. I want real help here, I'm close to uninstalling Opera and leaving it that way

  • @picard Me too, I think Opera 65 not stable.

  • @blackcoffez Yeah, it's a shame. I've seen a few other people have the same issues. It's a shame, because Opera is the best browser I've seen in a while. I hope this gets resolved soon

  • @picard
    I found a way to fix in my Opera:
    Setting -> advanced setting -> system -> turn off "Use hardware acceleration when available".

  • @blackcoffez Oh, nice! Thanks so much 😃 worked for me too!

  • @leopik2
    Setting -> advanced setting -> system -> turn off "Use hardware acceleration when available".

  • @blackcoffez @donq yeah but cmon that would also disable acceleration of videos and such ... I mean, honestly, how can something like this even ship? I got the same issue on a GeForce 1070, so it's definitely not intel only.

  • @tabmow said in Graphical problems with inputs/textareas:

    I mean, honestly, how can something like this even ship?

    Oh, have you been involved in software development? I am (not Opera dev of course) - and this is relatively minor issue, affecting mostly only visual appearance.
    Often much more serious problems (like corrupting data - or like latest W10 update, which sometimes just deletes user documents) slip into releases. Read dilbert comics strips - you will discover many (sad) truths about software development...

    As you see problems on GeForce too, then that is for better - we can hope fix sooner 🙂

  • @donq Yes I am, working in a very big company in fact ... and user interface is one of the most important things of any product, so how this could not receive the utmost amount of testing is beyond me, especially as this doesn't seem to be a rare issue at all (I have very common hardware).

    PS: oh and that's from me as a service developer. For the end user, having "trivial" bugs in the UI/UX can break your product much more than any technical debt or other stupid bugs that will make us cringe as developers.

  • @blackcoffez you re the best!

  • Hi,

    Since I updated the last version of Opera Version :56.0.3051.40
    The text fields and textarea are showing strange sort of shadow on the bottom of them + the text inside is backgrounded blue as it would be selected.
    This doesn't make this under other browser like Firefox and Chrome.

  • @pololopo

    Same question and answers all over the thread. See, for instance:

    'Text problems with Opera 56'

    https://forums.opera.com/topic/29018/text-problems-with-opera-56

  • This post is deleted!
  • Text input fields are flashing in an odd manner. When i try it on an unstylized html text input element, the following happens: Once you start typing, after one second anything you typed will be surrounded by gray. If you hover your mouse over it it will turn white again, but after one second it will turn blue. When i hover over another input element (while i was still typing in the first one) the text gets the same gray background as before in the first element, but in addition the rest of the first input field becomes a lighter shade of gray. This lighter shade of gray only goes as far to the right as the right edge of the input element below it. Tried putting on deafault settings did not work. tried in other browsers functions normally. Opera Version 56.0.3051.36 on Desktop Windows 10.

  • @jakobo Lots of people are encountering this issue. There are other threads on it. Long story short, you need to disable hardware acceleration in settings for now.

  • I wasn't getting this with Opera 55, so I'm confused what is causing it exactly. It looks like this:
    0_1539676068973_reddit_wtf.png

    Whole field gets highlighted and as I'm typing, all the text gets highlighted like I'm selecting it (or using Ctrl+A). And as I'm typing large amounts of text, whole field starts flashing like it's selecting and unselecting the whole field. Why I'm suspicious it's something specific is because I'm not getting this ANYWHERE else but on Reddit.

    Only addons I'm using is Feedly Notifier and Bitwarden. I do have integrated AdBlock enabled with all the basic lists selected except Malware blocking list.

  • Disable hardware acceleration in settings for now.

Log in to reply