Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

New (lack of) Opera menu bar is UNUSABLE

  • The most recent version of Firefox does allow the use of a title bar. It can be enabled in the Cutomize menu. Chrome also has the title bar, as does Vivaldi.

  • There is a way to restore the title bar in Kubuntu so probably the same method applies to vanilla Ubuntu.

    Try setting a Window Rule for Opera windows. In KDE we do this under System Settings > Window Rules and set 'No title bar and frame' to 'Force' and 'No'. That's how I got mine back.

    There is a quick guide to restoring Opera the menu bar here.

  • @vr51 Thank you for the suggestion! The article you linked is nice, but I haven't found a way to do this in vanilla ubuntu yet. I installed compiz, which seemed to offer many of the custom settings available in KDE, but it doesn't have the options described in the article for forcing a title bar/frame.

  • Hi @ricitron,
    1. Regarding the lack of the Opera's menu, you can try to run the Opera with the following switch: /usr/bin/opera --show-opera-menu.
    2. On bringing back the GTK window decorations, you can try the following steps: open a new shell window, and run: /usr/bin/gtk-window-decorator --replace &>/dev/null &. If it still dosn't show up, click the Restore/Maximize button, and see if this helps.

  • @l33t4opera said in New (lack of) Opera menu bar is UNUSABLE:

    1. On bringing back the GTK window decorations, you can try the following steps: open a new shell window, and run: /usr/bin/gtk-window-decorator --replace &>/dev/null &. If it still dosn't show up, click the Restore/Maximize button, and see if this helps.

    This bit implies that compiz-gnome is installed and used as window manager for gnome, thus it is useless for the ones not using gnome or compiz at the very least.

  • @l33t4opera thanks for the suggestions! Suggestion 1 started showing an opera logo in the upper left of the window, but still no title bar. Suggestion 2 didn't work as @jimunderscorep mentioned, because I'm using 16.04 with Unity. Will it definitely work in GNOME? Maybe it's time to upgrade to 18.04.

  • Hi @ricitron, you're welcome, the above tips are only workarounds for the issues, they may work or not under various circumstances. Do you have installed the compiz-gnome package? If not, then install it, run the command mentioned above again, and check if this helps.

  • @l33t4opera thanks again for the suggestion. I did try it again with compiz-gnome installed, and it still didn't work. Hopefully they add an option to re-enable to the title bar soon.

  • I also don't understand why the title bar buttons have moved to the right to match the Windows style rather than unix

  • Hi @ricitron, not at all ;-) You can try to log out and log in again to your user account, and see if it helps. Yep, it would be nice if it can be added/unified for majority of the desktops in the future.

  • This must by far be the most useless change ever!!
    I makes my tabs go "micro" sized because i use the whole tab bar when surfing. Not a nice surprise.
    And i have found no way to change it sitting on Ubuntu 18 and Opera 55.
    And the fact that the HTML% needs to be redone every time there is an upgrade to the browser. As of this update i cant even play games on FB .
    I need ti switch browser if this doesn't go away in a hurry. 😞

Log in to reply