Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Setting Opera Mail as default program in Windows 7 (64bit)

  • burnout, that did it! Thank you very much.

    The only thing I'd add to your awesome directions is a general Windows tip, and that's how to change a file extension. I'd never had to do that before. Your instructions said to remove the .txt extension from a file after I downloaded it. To make that happen, I found out I had to go to Control Panel > Appearance and Personalization > Folder Options > View and under Advanced Settings, temporarily unclick "Hide extensions for known file types." Then when I changed the name on the file, I could eliminating .txt, turning it into a .reg file.

    I appreciate everyone's help here. Thanks again.

  • burnout, that did it! Thank you very much.
    The only thing I'd add to your awesome directions is a general Windows tip, and that's how to change a file extension. I'd never had to do that before. Your instructions said to remove the .txt extension from a file after I downloaded it. To make that happen, I found out I had to go to Control Panel > Appearance and Personalization > Folder Options > View and under Advanced Settings, temporarily unclick "Hide extensions for known file types." Then when I changed the name on the file, I could eliminating .txt, turning it into a .reg file.
    I appreciate everyone's help here. Thanks again.

    Could you upload the reg file, please? Forget it, I just find it 😛

  • It is not working here. I open the reg file but it does not wotk.

  • burnout, that did it! Thank you very much.

    What parts/reg file did the trick?

    The only thing I'd add to your awesome directions is a general Windows tip, and that's how to change a file extension. I'd never had to do that before. Your instructions said to remove the .txt extension from a file after I downloaded it. To make that happen, I found out I had to go to Control Panel > Appearance and Personalization > Folder Options > View and under Advanced Settings, temporarily unclick "Hide extensions for known file types." Then when I changed the name on the file, I could eliminating .txt, turning it into a .reg file.

    Yeh, windows stupidly sets "hide extensions for known file types" by default. It's actually dangerous to have that option checked, so keep it unchecked. If you keep it checked though, press F2 when the file is selected or right-clicking on the file and going to properties should allow you to edit the extension.

  • It is not working here. I open the reg file but it does not wotk.

    which reg file did you try?

  • It is not working here. I open the reg file but it does not wotk.

    which reg file did you try?

    The second link you posted.

  • @sidneyneto Did you untick 'Hide extensions for known file types' as mentioned by ggergm in their last post ?, and then renamed the files extension (last three letters after the '.') to '*.reg' ?.

  • @sidneyneto Did you untick 'Hide extensions for known file types' as mentioned by ggergm in their last post ?, and then renamed the files extension (last three letters after the '.') to '*.reg' ?.

    Yes, and I edit it to the right installation folder(in the reg file).

  • What parts/reg file did the trick?

    The shorter, first one you posted, opera_mail_protocol.reg.txt

  • What parts/reg file did the trick?

    The shorter, first one you posted, opera_mail_protocol.reg.txt

    K. Thanks.

  • It is not working here. I open the reg file but it does not wotk.

    which reg file did you try?
    The second link you posted.

    http://shadow2531.com/opera/wiki/opera_mail_protocol.reg.txt is the 2nd link I posted. But, it's the first reg file link I posted. The 2nd reg file link I posted was http://shadow2531.com/opera/wiki/operamail_win7x64_full.reg.txt

    So, which reg file link?

    Yes, and I edit it to the right installation folder(in the reg file).

    Did you reinstall Opera Mail over the top of itself first like mentioned in http://www.reddit.com/r/operabrowser/wiki/m2tips/default_programs (including installing for All Users)?

    Just curious, since you have 32-bit Win8, did you make sure Opera Mail is installed to "C:\Program Files\Opera Mail" where you edited the paths in the reg file to that?

  • It is not working here. I open the reg file but it does not wotk.

    which reg file did you try?
    The second link you posted.

    http://shadow2531.com/opera/wiki/opera_mail_protocol.reg.txt is the 2nd link I posted. But, it's the first reg file link I posted. The 2nd reg file link I posted was http://shadow2531.com/opera/wiki/operamail_win7x64_full.reg.txt
    So, which reg file link?

    The first one, my windows is 32bit.

    Yes, and I edit it to the right installation folder(in the reg file).

    Did you reinstall Opera Mail over the top of itself first like mentioned in http://www.reddit.com/r/operabrowser/wiki/m2tips/default_programs (including installing for All Users)?
    Just curious, since you have 32-bit Win8, did you make sure Opera Mail is installed to "C:\Program Files\Opera Mail" where you edited the paths in the reg file to that?

    I edited to the one you said. Yes, I reinstalled.

  • I edited the reg file several times and the only I could do it is to put Opera Mail as defaut to open MAILTO protocol, but when I try to open mailto, it does not happen nothing

  • Thanks for the clarifications.

    I edited the reg file several times and the only I could do it is to put Opera Mail as defaut to open MAILTO protocol, but when I try to open mailto, it does not happen nothing

    Hmm, not sure why it works for some (and me), but not others.

  • AFAIK there's a bug with the opening of mailto: links in Opera's latest versions. Which version were you using primarily when doing these tests @sidneyneto?

  • AFAIK there's a bug with the opening of mailto: links in Opera's latest versions. Which version were you using primarily when doing these tests @sidneyneto?

    The latest Opera Mail standalone version.

  • Check all the paths in each of the following keys (and their sub-keys) to make sure they point to where your operamail.exe is at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail
    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaMail
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OperaMail.protocol
    HKEY_CURRENT_USER\Software\Classes\mailto
    HKEY_CURRENT_USER\Software\Classes\Opera.Protocol
    HKEY_CLASSES_ROOT\mailto
    HKEY_CLASSES_ROOT\OperaMail.protocol

    Also, make sure OperaMail is set in the (default) string in HKEY_CURRENT_USER\Software\Clients\Mail

    Also, make sure HKEY_CLASSES_ROOT\Applications\operamail.exe is present and that it has the shell/open/command sub-keys with the (default) string's value in "command" key being "path to operamail.exe" "%1" (quotes included). Do the same with HKEY_CURRENT_USER\Software\Classes\Applications\operamail.exe

    Also, look in "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\MAILTO" to make sure "operamail.exe" is listed in the "OpenWithList" sub-key. In the "OpenWithProgids" sub-key, Make sure the binary "URL:MailTo Protocol" is present (with its value set to nothing (as in, just the 0000) as that's what the default string's value in "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto" points to.

    Make sure there's a string in "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto" that's "URL Protocol" with no value set. Make sure there's a dword named "EditFlags" (no quotes) with its value set to 2.

    Also, make sure "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\OperaMail.exe" is present and that its (Default) string's value is set to the path to operamail.exe (in quotes). There should also be a "Path" string where its value should be the path to the folder operamail.exe is in (with the trailing backslash and the path in quotes). There are no sub-keys to this OperaMail.exe key.

    Also, in HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaMail\Capabilities\UrlAssociations there should be a "mailto" string where its value is set to OperaMail.Protocol. In "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaMail\Capabilities\Startmenu", there should be "Mail" and a "StartMenuInternet" strings strings with both their values set to "OperaMail" (minuse the quotes).

    In "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail", make sure the DLLPath string's value is the path to OperaMAPI.dll (do not quote the path). The (Default) string's value should be "OperaMail" (no quotes) and the "LocalizedString" string's value should be "OperaMail" (no quotes).

    Make sure all that's right, restart the computer, go into Default Programs in Windows, choose "set default programs", select "Opera Mail" and then choose "set this program as default". Then, after that you can go back to "choose defaults for this program" to confirm and both mailto and MAPI are set. Then, you can go back to "associate file type and protocol" and confirm that mailto is associated with Opera Mail there too.

    That might do the trick as long as you don't check the box in Opera Mail's preferences. If it still doesn't work, test to see if it fails just when Opera Mail is already open or not.

    If that doesn't help still, maybe delete all the OperaMail keys in the registry and install Opera Mail again (for all users) and then add the Opera.Protocl reg keys etc.

    The best wayt to really fix this is to pretend that operamail.exe is your program and research the microsoft docs for how to properly add it to the registry so that it's associated with mailto, news and MAPI. Then, maybe someone can write a script that you put next to operamail.exe where when you load the script, it adds all the necessary stuff to the registry for that operamail.exe.

  • Also, try adding the "Opera Mail" (or "OperaMail") string to HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications where its value is Software\Clients\StartMenuInternet\OperaMail\Capabilities.

    Then, make sure HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaMail\Capabilities\UrlAssociations has the mailto string with "OperaMail.Protocol" (no quotes) as its value.

    In "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaMail\Capabilities", make sure there are ApplicationDescription, ApplicationIcon and ApplicationName strings in there. The icon one should have the path to operamail.dll,0.

    Also, maybe add an "Opera Mail" (or "OperaMail" key to HKEY_LOCAL_MACHINE\SOFTWARE. (Look at the others in there for more info). Or, maybe add the "Opera Mail" (or "OperaMail") key under HKEY_LOCAL_MACHINE\SOFTWARE\Opera Software" instead where the "Opera Mail" (or "OperaMail") key has its "(Default)" string's value set to the path to operamail.exe (no quotes around path). Have a string InstallDir where its value is the path to the folder operamail.exe is in (again, no quotes).

    I need to strip all Opera Mail stuff from my registry, install Opera Mail and see just exactly what's missing again.

    Make sure HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\OperaMail.exe is present too. Again, "(Default)" string's value should be the path to operamail.exe (path quoted) and Path string's value should be the path to the folder operamail.exe is in (path quoted).

  • Nevermind the above. Just download make_m2_default_client.zip, extract it, view the readme and merge. That should do the trick. (Basically researched how Thunderbird does it and copied it.)

  • look this:

Log in to reply