Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

При воспроизведении видео(некоторых), звук идёт а вместо изображения- черный экран.

  • Ура! Как и было сказано, дело в аппаратном ускорении, отключаем его и всё Агонь! : Настройки \ Браузер\ включаем "Показать дополнительные настройки" (в левом нижнем углу монитора- под Браузер, сам еле нашел)\ Система (снимаем галочку).... профит.

  • спасибо! аппаратное ускорение - зло, тоже столкнулся с этой проблемой, только артефактами экран был ,а не черным экраном

  • Такая же проблема, отключение аппаратного ускорения не помогло.

  • @cryneploho

    Такая же проблема, отключение аппаратного ускорения не помогло.

    Попробуйте некоторые варианты решения проблемы :

    • поставить самые свежие видео драйвера
    • обновите свои видео кодеки, например, K-Lite Codec Pack
    • обновите Flash Player
    • просканировать свой компьютер на вирусы, например. Malwarebytes Anti-Malware и Dr.Web CureIt
    • временно отключите свой антивирус и проверьте свою проблему
    • убрать из автозагрузки утилиту для видеодрайвера будь то AMD или Nvidia.
    • отключить Opera Turbo
    • зайти в приватное окно, если проблема исчезнет, значит виновник какое-то расширение браузера
  • @operasilver40 а для Linux? Нет кодеков K-Lite Codec Pack?
    Не воспроизводится flash. Скачал с официального сайта https://get.adobe.com/ru/flashplayer/ плагин libpepflashplayer.so
    Залил в /opt/google/chrome/PepperFlash/ (так же пробовал заливать в /usr/lib/x86_64-linux-gnu/opera/ , но автоматом не подхватывается плагин. Пробовал открывать через терминал вводом
    opera --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version=32.0.0.101).

    Теперь flash запускается: звук идет, видео не отображается(черный экран). На некоторых сайтах (vk.com) флеш отображается нормально.
    debain 9
    4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux

    Что я делаю не так?
    p.s. все вышеперечисленные действия с антивирусами, кодеками, отключением аппаратного ускорения не помогают.

  • @sx88

    1. Попробуйте отключить блокировщики рекламы на проблемном сайте.
    2. Ошибки воспроизведения видео
  • @operasilver40
    Проверки проходили на vimeo.com и сторонних сайтах.
    1.блокировщик рекламы (БР) включен + аппаратное ускорение(АУ) включено = звук есть , видео нет
    2. БР вкл + АУ выкл = звук есть , видео нет
    3. БР выкл + АУ вкл = звук есть , видео нет
    4. БР выкл + АУ выкл = звук есть , видео нет

    На официальном сайте
    https://helpx.adobe.com/ru/flash-player/kb/video-playback-issues.html
    предлагают протестировать на страницах, которые
    поддерживают html5 https://www.youtube.com/watch?v=PxDzTkWBIpc
    и не поддерживают html5 http://wwwns.akamai.com/hdnetwork/demo/flash/default.html
    Видео со звуком и изображением проигрывается и там, и там, при всех ранее описанных комбинациях с блокировщиком_рекламы и аппаратным_ускорением.
    Фото сторонних сайтов и vimeo.com
    alt text
    alt text

  • @sx88 у меня в Версия:57.0.3098.106 на указанном сайте все воспроизводится как надо. Причем с включеннымми блокировщиками Adblock и встроенным. Ищите проблему у себя (Flash, Windoows)
    0_1546671686038_Ashampoo_Snap_2019.01.05_09h53m21s_002_.jpg
    0_1546671696160_Ashampoo_Snap_2019.01.05_09h54m27s_003_.jpg

  • @keks6067 Вы не читали мой пост выше. Прочтите, пожалуйста.

  • может в настройках отключил этот парамерт : opera://settings/content/protectedContent
    Или запретил сторонние куки :
    opera://settings/content/cookies

  • @operasilver40 как устранить ошибку?

    @temkem said in При воспроизведении видео(некоторых), звук идёт а вместо изображения- черный экран.:

    может в настройках отключил этот парамерт : opera://settings/content/protectedContent
    Или запретил сторонние куки :
    opera://settings/content/cookies

    и то, и другое включено

  • Скачал с официального сайта adobe https://labs.adobe.com/downloads/flashplayer.html rpm пакет
    Распаковал содержимое архива согласно инструкции в /usr/lib/adobe-flashplugin/
    Не запускается видео на https://vimeo.com

    Распаковал rpm в /usr/lib/x86_64-linux-gnu/opera/
    Не запускается видео на https://vimeo.com

    Скачал согласно инструкции https://wiki.debian.org/ru/FlashPlayer 
    https://packages.debian.org/sid/flashplugin-nonfree
    Устновил через gdebi
    Не запускается видео на https://vimeo.com

    Что я делаю не так?

  • Скачал с официального сайта adobe https://labs.adobe.com/downloads/flashplayer.html rpm пакет
    Распаковал содержимое архива согласно инструкции в /usr/lib/adobe-flashplugin/
    Не запускается видео на https://vimeo.com

    Распаковал rpm в /usr/lib/x86_64-linux-gnu/opera/
    Не запускается видео на https://vimeo.com

    Скачал согласно инструкции https://wiki.debian.org/ru/FlashPlayer 
    https://packages.debian.org/sid/flashplugin-nonfree
    Устновил через gdebi
    Не запускается видео на https://vimeo.com

    Что я делаю не так?

Log in to reply