Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera is not keeping any site logged in

  • Same problem here. For Facebook, for example, 2 cookies are handed out when you log in there. facebook.com and www.facebook.com. Opera is only getting the first one and not the second one. I use CCleaner to save some cookies from some sites that I want to stay logged into. Right now there are many things broken in Opera 51. Small font on the bookmarks bar also. For now it is removed from my system until everything is verified as being repaired.

  • Same here, Google and eBay only.

  • Hi. I'm having the same problem with the pages of Google, Facebook, Twitter, Twich and other pages ...

  • Same here - with google, facebook, twitter and other websites on Windows 7 x64.
    When we will have a fix?

  • Same problem here since upgrading to Opera 51. Hope a fix will soon be provided! 😉

  • A temporary solution is to use a custom user directory.
    Opera's user directory is usually in
    C:\Users\<your name>\AppData\Roaming\Opera Software\Opera Stable if it isnt you can look it up under "about opera" and the appdata folder is usually hidden, just google if you dont know how to view hidden folders.

    Copy everything from the opera stable folder to another folder of your choosing, lets say D:\Opera_Profile for example.
    Now go into your Opera Install directory and make a shortcut to the launcher, open the Shortcut's properties
    and paste the following to the "Target" field

    C:\Program Files\Opera\launcher.exe --user-data-dir=D:\Opera_Profile
    Adjust the Folder Paths according to your system, also it is very important to add a space after the launcher.exe, otherwise it wont work, furthermore there cant be a space in the user-data-dir for example
    --user-data-dir=D:\Opera Profile instead of Opera_Profiles will not work

    you will have to launch Opera with that shortcut from now on, and it doesnt work in the taskbar for some reason and pinning it to the start menu only works if you pin regular Opera on it and edit the Shortcut made by the system, it should be in C:\ProgramData\Microsoft\Windows\Start Menu\Programs

    so far this works fine for me

  • The Opera Developer version works fine

  • Is there any news on fix? It is really annoying..
    I did uninstall, delete all data from Appdata folder, clean registry, new install of x64 version. Still not stay logged in.

  • Working now after latest update, thanks!

  • It works! 🙂

  • @toninho3rd said in Opera is not keeping any site logged in:

    toninho3rd

    After going back to version 50 all was OK. Shortly afterwards it automatically upgraded to version 51. Everything was fine for a few days and then the problem reoccurred. Forcing an upgrade to 51.0.2830.34 (using About Opera) seems to have fixed the issue again. Hoping that's the last of it 🤔