Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera is not keeping any site logged in

  • I have the exact same problem. Plus, the gesture for closing at tab doesn't work correctly either.

  • @marv241 The second part is something for another topic.

  • Make sure you have logged outta google 1st..

    disconnect my Google account and clear all data from Opera (both the 32 and 64-bit versions) and either re-install a pristine default Opera or a new default profile Opera should reset everthing and then log back into google.

  • also disable anti virus esp malwarebyes.. (to see if there is a conflict)..

  • @nvmjustagirl

    Nope it just doesn't work. It made it even worse. Now I have to type in the code for 2-Factor Authentication every single time I restart the browser altough cookie settings are fine.

  • I have the same problem for several days after the last update.
    Opera developers, please fix it quickly!

    Recently, the same problem was in Chrome after updating, but it was removed successfully.

  • @campedor92
    If it's been fixed in Chrome, I'm sure it will be fixed in Opera and the other Chromium browsers soon.
    馃檪

  • If the problem is a Setting started on old Synced' data, for those using only "Bookmarks" sync, you can export your Bookmarks and start with a new profile "again".

    Reset Sync data and do the Set Up, import bookmarks, install extensions...

    Could be tedious for some cases but could fix the problem earlier.

    PS:
    Passwords could be exported also enabling the Flag option:

    0_1518278678329_2018-02-10_170404.png


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Opera Test profile | Opera Reset / Back up LinuxMacWin

  • @zalex108 Doesn't help unfortunately. It doesn't matter whether you use the sync option or not. I personally didn't use the sync option and it didn't work either.

    Theres actually no work around. It's just a bug that got fixed in Chrome but not for Opera right now.

  • Same problem here, but only for some sites, not all of them

  • Same problem here. For Facebook, for example, 2 cookies are handed out when you log in there. facebook.com and www.facebook.com. Opera is only getting the first one and not the second one. I use CCleaner to save some cookies from some sites that I want to stay logged into. Right now there are many things broken in Opera 51. Small font on the bookmarks bar also. For now it is removed from my system until everything is verified as being repaired.

  • Same here, Google and eBay only.

  • Hi. I'm having the same problem with the pages of Google, Facebook, Twitter, Twich and other pages ...

  • Same here - with google, facebook, twitter and other websites on Windows 7 x64.
    When we will have a fix?

  • Same problem here since upgrading to Opera 51. Hope a fix will soon be provided! 馃槈

  • A temporary solution is to use a custom user directory.
    Opera's user directory is usually in
    C:\Users\<your name>\AppData\Roaming\Opera Software\Opera Stable if it isnt you can look it up under "about opera" and the appdata folder is usually hidden, just google if you dont know how to view hidden folders.

    Copy everything from the opera stable folder to another folder of your choosing, lets say D:\Opera_Profile for example.
    Now go into your Opera Install directory and make a shortcut to the launcher, open the Shortcut's properties
    and paste the following to the "Target" field

    C:\Program Files\Opera\launcher.exe --user-data-dir=D:\Opera_Profile
    Adjust the Folder Paths according to your system, also it is very important to add a space after the launcher.exe, otherwise it wont work, furthermore there cant be a space in the user-data-dir for example
    --user-data-dir=D:\Opera Profile instead of Opera_Profiles will not work

    you will have to launch Opera with that shortcut from now on, and it doesnt work in the taskbar for some reason and pinning it to the start menu only works if you pin regular Opera on it and edit the Shortcut made by the system, it should be in C:\ProgramData\Microsoft\Windows\Start Menu\Programs

    so far this works fine for me

  • The Opera Developer version works fine

  • Is there any news on fix? It is really annoying..
    I did uninstall, delete all data from Appdata folder, clean registry, new install of x64 version. Still not stay logged in.

  • Working now after latest update, thanks!

  • It works! 馃檪

Locked