How to fix Video playback in Opera 51 / H.264/MP4 problem in Opera 51.0.2830.26

  • I had some time to play around. On Debian (amd64) based systems (Debian, Ubuntu, Mint, ect) you need to uninstall
    chromium-codecs-ffmpeg-extra with the command:
    sudo apt-get remove chromium-codecs-ffmpeg-extra

    You can uses this version as replacement:
    https://launchpad.net/ubuntu/xenial/amd64/chromium-codecs-ffmpeg-extra/64.0.3282.119-0ubuntu0.16.04.1

    or as direct download:
    http://launchpadlibrarian.net/354818683/chromium-codecs-ffmpeg-extra_64.0.3282.119-0ubuntu0.16.04.1_amd64.deb

    download the file and double click on the file to install it. Afterwards completely restart Opera.

    If you want to prevent further updates of this package use this command (not recommended):
    sudo apt-mark hold chromium-codecs-ffmpeg-extra

  • Please allow me some corrections...

    a) Debian does not have chromium codecs on its repos, so the above do not apply to it. Ubuntu does have it, and mint does too, since it uses ubuntu's repos for most of the packages it has.
    On top of that, I suggest not installing an ubuntu package in debian, because they are built with a different set of compilers, libs etc.

    b) Instead of searching in launchpad's countless repos and packages fo find that... precious deb file, you can install it via apt like so

    sudo apt-get install chromium-codecs-ffmpeg-extra

    and, as of today (February 10th 2018) it will install version 64.0.3282.119, which is what someone using opera 51 wants.
    In case someone does not like the command line, the same package can be found and installed via anything that uses apt as a backend, eg synaptic or software center.

    c) Chromium (package chromium-browser) depends directly on chromium-codecs-ffmpeg-extra, so if someone already has chromium installed, that "apr-mark hold" above will also prevent chromium from updating as well.

    If you have any more questions, post them and I will try to asnwer them.

  • @jimunderscorep Ok, I have Opera 51 installed also Chromium installed, I am running Linux Mint 17.3, all on a 32 bit machine. is the fact that I am using a 32 bit computer, be the reason Opera won't play videos on say Facebook? And if so, is there a work-a-round for this?

  • @tomiki Latest version of Opera for Linux with support for 32 bits was 45 so maybe you are not on a 32 bits system?

  • @tomiki
    As leocg said, you are probably on 64bit, else you would be stuck on opera 45. To check if you are on 32 or 64, open a terminal and run this

    uname -m

    If it says "x86_64" you are on a 64bit mint 17.3, if it says i686 you are on 32. There are may other ways to check that, but this is the one that I remember now.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.