Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Disabling Auto Startup

  • go to settings and turn off run apps in the background.. restarted pc *may help..

    or i may be confused with google chrome..
    it may be called this now.. Background sync - Do not allow recently closed sites to finish sending and receiving data

    also look in here.. *Opened Run (Windows key + R) and typed in: shell:startup remove opera if its in there restart pc..

    also i found this thread explaining that this is not an issue but a new Feature of Windows 10
    +Programs autostart after boot+ - https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/programs-autostart-after-boot-in-windows-10/09dd8d3e-7b36-45d1-9181-6587dd5d53ab?page=2

  • @nvmjustagirl said in Disabling Auto Startup:

    also i found this thread explaining that this is not an issue but a new Feature of Windows 10
    +Programs autostart after boot+ - https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/programs-autostart-after-boot-in-windows-10/09dd8d3e-7b36-45d1-9181-6587dd5d53ab?page=2

    To avoid that, before shutting down or restarting the system, I'd close Opera and then check the task manager to check if all the opera processes are really closed. If some were still running, I'd kill them.

    @nvmjustagirl said in Disabling Auto Startup:

    go to settings and turn off run apps in the background.. restarted pc *may help..
    or i may be confused with google chrome..
    it may be called this now.. Background sync - Do not allow recently closed sites to finish sending and receiving data

    I was wondering if that's Opera's name for Chromium's background app setting or if Background Sync is something for Opera Sync. Either way, disabling all extensions in Opera should rule this out. But, maybe one of Opera's apps in the sidebar keeps Opera running.

  • @burnout426 This may be a stretch *long shot since a win 10 update.. - The answer may be in Cortana settings .Open Cortana then go to the" pick up where I left off" and toggle that to off then save the settings. lol

    also check this page out - Disable Apps Auto Reopening in Windows 10 - https://winaero.com/blog/disable-apps-auto-reopening-windows-10/

    chome has this flag - chrome://flags and disable

    Enable Push API background mode..

    to sleepy to see if opera does..

  • @nvmjustagirl I always turn everything off before shutting down. Added the step you suggested and checked the task manager. AND Turned off Apps running in the background. AND Turned off Cortana's Pick up wherre I left off. After all that, same result. Opera reopens in whatever way I left it, PLUS three additional speed dials.

  • @dowder46
    Is Opera your default browser?
    If so, try making something else, such as Internet Explorer, your default browser.
    Does Opera still open automatically, or does IE open instead?
    If IE opens instead, whatever it is that's doing it is opening the default browser, not Opera specifically, which may help to narrow things down.
    🙂

  • My default browser is Chrome

  • @dowder46
    Interesting, so whatever it is is specifically targetting Opera.
    Curiouser and curiouser!
    Sorry if this has already been asked, but what do you have Opera set to start with in its settings?
    🙂

  • continue where I left off - and before you say anything, I just tried changing that, for the first time - no effect. I had high hopes, though!

  • @dowder46
    You anticipated my next question, which was to see if changing it affects anything!
    I assume that whatever you have it set to that it does what it should do when you start Opera manually?
    🙂

  • @davehawley Interesting question. I hadn't though of that, so I tested it just now, closing and re-opening Opera without rebooting the computer. And the answer is yes, it opens, in that case, correctly. So it only does this weird thing when I reboot the computer.

  • @dowder46
    Hmmm, OK.
    I assume that if Chrome is your default browser, that if you click on a link in an e-mail say, it's Chrome that opens and displays the site.
    Just as an experiment, temporarily make Opera your default browser, which you can do in the settings.
    Do links then open correctly in Opera instead of Chrome?
    Then put Chrome back to being the default browser and make sure it's now opening links again as before, and see if Opera's behaviour has changed at all.
    🙂

  • Made the change you suggested. Link opened in Opera. Made Chrome the default again. Rebooted computer. Same thing.

  • @dowder46
    So apart from Opera running automatically in a very strange configuration when the computer starts up, everything seems to be working as it should do.
    This may seem a bit drastic, but what I would next try is backing up the Opera profile folder somewhere (look in "About Opera" to see where it is) and then uninstalling Opera completely.
    Then reinstall it from the standalone installer, but this time set the installation folder to a different place from the default offered.
    See if the new installation runs by itself as well.
    If whatever is running it is using an absolute path to launcher.exe or opera.exe this should stop it happening.
    The new version should keep the same profile as long as you didn't delete it during the uninstall, but in case it did delete it you will still have your backup to fall back on.
    🙂

  • @davehawley Yikes. Thanks, Dave. I'll try that once I summon the nerve...

  • You could close down Opera, rename any opera.exe files you have and launcher.exe to something else. Then, restart your computer and see if you get any "application/file not found" dialogs on startup or something like that. If so, there's a small chance that it will reveal what program/thing is trying to launch Opera.

    You could also delete the Opera program files folder, download the Opera installer, launch it, click "options" and set the install path to "C:\Program Files\Opera Moved" for example and install. Opera should use the same profile as before, but if the issue goes away, whatever was trying to load Opera was targeted the old Opera directory specifically.

    What version of Windows? 64-bit or 32-bit? If Win8 or newer, do you sign into the computer with a Microsoft account or do you just use a local account and a normal username/password?

  • @burnout426 said in Disabling Auto Startup:

    You could also delete the Opera program files folder, download the Opera installer, launch it, click "options" and set the install path to "C:\Program Files\Opera Moved" for example and install. Opera should use the same profile as before, but if the issue goes away, whatever was trying to load Opera was targeted the old Opera directory specifically.

    Which is virtually the same thing as I suggested!
    We now know that Opera is being specifically targetted, not the default browser, so this should be a good way of seeing if the default path to the Opera executables is being specifically targetted by something.
    😃

  • I have been experiencing the same issue with Opera opening automatically each time I start Windows. It starts each time with three blank Speed Dial tabs opened.

    I can add, that when this first started, I ran a Google search to see if anyone else was experiencing a similar issue. I initially didn't find any recent messages, but the consensus of what I did read pointed toward possible malware. While scans showed nothing abnormal, to be sure I restored my C: drive from a backup from about 30 days prior. Once the restore was complete, Windows started without Opera opening automatically. However, once I opened Opera, I received a message that it was updated to the latest version and since that time it launches automatically each time I start Windows.

    So, I believe whatever is causing the problem is related to the latest Opera update.

  • Have you tried to redefine default programs on Windows settings/control panel?

  • @nsdash9 said in Disabling Auto Startup:

    I have been experiencing the same issue with Opera opening automatically each time I start Windows. It starts each time with three blank Speed Dial tabs opened.

    I can add, that when this first started, I ran a Google search to see if anyone else was experiencing a similar issue. I initially didn't find any recent messages, but the consensus of what I did read pointed toward possible malware. While scans showed nothing abnormal, to be sure I restored my C: drive from a backup from about 30 days prior. Once the restore was complete, Windows started without Opera opening automatically. However, once I opened Opera, I received a message that it was updated to the latest version and since that time it launches automatically each time I start Windows.

    So, I believe whatever is causing the problem is related to the latest Opera update.

    Yes, now you say that, it does start to look that way, but obviously not everyone is suffering the problem, so there must be other factors in play as well.
    🙂

  • If you have an auto-starting program that, for whatever reason, calls a protocol type for which Opera is defined as default, then Opera will be launched as well in order to satisfy that request. It may be that updating Opera alters that default protocol list in some way on your system, such that now Opera appears instead of whatever else was previously defined there.

Log in to reply