Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

user interface chromecast tab missing

  • @mohammedpatla

    Use, es on Local State, and then, mark the file as Read only.

    I've posted that steps on Mac few days ago this week - now seems that Read only is needed - .

    Look there if needed.

  • @zalex108 said in user interface chromecast tab missing:

    @mohammedpatla

    Use, es on Local State, and then, mark the file as Read only.

    I've posted that steps on Mac few days ago this week - now seems that Read only is needed - .

    Look there if needed.

    Here,
    the linked and the next post.

    Add the mark as Read only option step for the file when finish.

  • @zalex108 Yup Changed location to us, but does not help , Chromecast still missing. I even reinstalled Opera, and changed location , marked as read-only, but still , no chromecast option .

  • Well...,
    You should try with es / ES.

    Maybe there is another part where the country is configured.

    I would share a clean Data folder on a working cast feature if you like to test it.
    Just the needed files with out the installer itself.
    Then you just need to copy the folder on the needed path and test it.

  • @zalex108 I could try that .

  • Profile and install files - if needed -.

    I don't know if that way would keep the attributes, so, mark as read only if needed.

  • @zalex108 OMG this worked. I marked that one file readonly and i got the chrome cast option . I have yet to check if it cast.

    Edit:
    It can find my chrome cast device so it should cast.

  • @mohammedpatla

    :o

    👏

    Very good! 🙂

    Did you used the Data folder only or the install files too?

    EDIT:
    Keep a copy of the profile since we don't know what will happen once Opera will be updated.

  • new at all this is it easy to do?

  • @dutch

    It's easy,

    Go to:

    • Opera Help > Find solutions.
      | - And rename the profile folder -.

    Then copy the downloaded profile there, if works, copy the Bookmarks file, WebData... from one profile to another.

    In case you have extensions or its settings to backup/export, rename the folders back, do it and rename them again.

    Do a profile backup before any modification.

  • Was driving me nuts how no one was confirming anything you said.

    So I'm here to confirm that simply changing the "Local State" file (as noted here) will allow you to see the Chromecast option, but enabling it will do nothing.

    Downloading your Profile files did enable it to work (zalex's file in case you missed the download link)

    I wish I had a better understanding of which file I copied over enabled it to work so that the process could be simplified.
    I wanted to go through the work of finding out which file fixed it, but it seems installing that ticked some other file and now I have Chromecast on a fresh install (so long as I change the Local State file).

    So in conclusion, download Zalex's file, extract the contents, and copy everything in the red "Data" folder into you profile folder (Opera Menu -> About Opera, for me my path looked like this "C:\Users\my_username\AppData\Roaming\Opera Software")

  • @waffo Though of something else to mention:

    I'm in the US, so if you are also in the US you will have to follow these steps. (Mohammedpatla is in Canada).

    The option to cast a tab didn't show up in the option menu as described in the developer update, but it did on youtube videos. While casting a youtube video the Chromecast icon showed up in the top right. I right clicked that icon and selected "always show icon" so now I can cast ANY tab, not just youtube videos.

  • @mohammedpatla This is "working" but not on the "home page" -- once you have setup if you start opera and then try to cast it dose not work, load a web page and right click cast is in the drop down menu... WHY not on the home page I spent hours trying to find why I could not make chromecast work with opera until I tried after starting opera AND loading a web page (any site) then right click......

Log in to reply