Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera & Netflix

  • @leocg what exactly I must copy ?

    For chromium I have install the package chromium-widevine who contain:
    /usr/lib/chromium/libwidevinecdm.so
    /usr/share/licenses/chromium-widevine/eula_text.html

    In the the profile directory of chromuim I have this directory
    /home/xxx/.config/chromium/Profile 1/File System/Plugins/000/application_x-ppapi-widevine-cdm
    who contain:

    ➜ ...n_x-ppapi-widevine-cdm# ls
    -rw------- 1 xxx wheel 76 17 nov. 12:32 00/00000009
    -rw------- 1 xxx wheel 3,8K 17 nov. 12:32 Paths/000003.log
    -rw------- 1 xxx wheel 16 20 oct. 12:42 Paths/CURRENT
    -rw------- 1 xxx wheel 0 20 oct. 12:42 Paths/LOCK
    -rw------- 1 xxx wheel 375 14 déc. 11:22 Paths/LOG
    -rw------- 1 xxx wheel 375 17 nov. 12:30 Paths/LOG.old
    -rw------- 1 xxx wheel 41 20 oct. 12:42 Paths/MANIFEST-000001

    00:
    total 4,0K
    -rw------- 1 xxx wheel 76 17 nov. 12:32 00000009

    Paths:
    total 20K
    -rw------- 1 xxx wheel 3,8K 17 nov. 12:32 000003.log
    -rw------- 1 xxx wheel 16 20 oct. 12:42 CURRENT
    -rw------- 1 xxx wheel 0 20 oct. 12:42 LOCK
    -rw------- 1 xxx wheel 375 14 déc. 11:22 LOG
    -rw------- 1 xxx wheel 375 17 nov. 12:30 LOG.old
    -rw------- 1 xxx wheel 41 20 oct. 12:42 MANIFEST-000001

    In opera profile directory I have no plugins directory.
    I don't know what I must copy and where.

    Do you know where Opera download Widevine and where it copy it ? maybe I can do it manually.

    In chromium //components I have:
    SSL Error Assistant - Version : 4
    CRLSet - Version : 4194
    File Type Policies - Version : 14
    Origin Trials - Version : 0.0.0.0
    Signed Tree Heads - Version : 619

    Thanks

  • @yaute The folder named with the version number, inside Widevine's folder located under the browser's profile directory.

  • @leocg what I do :
    ➜ ~/.config/opera# mkdir Widevine
    ➜ ~/.config/opera# cd Widevine
    ➜ ~/.config/opera/Widevine# cp -r ../../chromium/Profile\ 1/File\ System/Plugins/000 .

    I have nothing in opera://components and it doesn't work.

    Thanks

  • @yaute There should be a Widevine folder under Opera's profile directory already.

    0_1514978670627_widevinefolder.PNG

    Inside of it there should be a folder with Widevine's version number. I'm on Windows but I don't think it is much different in Linux.

  • @leocg Ok, Iwill try with another Linux in a VM.

  • While I don't have Netflix, I did search for Widevine on ElementaryOS. It found the following results....

    /home/user/.config/chromium/WidevineCdm
    This folder is empty but may work for you.

    /usr/lib/chromium-browser/WidevineCdm
    Contains the manifest.json

    Files found were....
    /usr/lib/chromium-browser/libwidevinecdmadapter.so
    /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json
    /usr/lib/x86_64-linux-gnu/opera developer/resources/widevine_config.json

    I'm running Opera version 49.0.2725.39

  • Fyi, opera looks in here for the widevine libraries

    $ cat /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json
    [
    {
    "preload" : "/opt/google/chrome/libwidevinecdm.so",
    "plugin" : "/opt/google/chrome/libwidevinecdmadapter.so"
    },
    {
    "preload" : "/opt/google/chrome-beta/libwidevinecdm.so",
    "plugin" : "/opt/google/chrome-beta/libwidevinecdmadapter.so"
    },
    {
    "preload" : "/opt/google/chrome-unstable/libwidevinecdm.so",
    "plugin" : "/opt/google/chrome-unstable/libwidevinecdmadapter.so"
    }
    ]

    And as it seems, all of them are the ones that come with the chrome packages.

  • @minuteman I have no directory WidevineCdm on my arch

    @jimunderscorep I create and copy libwidevinecdm.so & libwidevinecdmadapter.so manually into /opt/google/chrome and it work !

    thanks guys for your help.

    PS: in opera://components I have always nothing

  • Glad I helped 🙂
    In case anyone of the devs is reading this...

    As we all see from the above, opera expects to find the widevice libs inside chrome's installation path. Why not add the

    /usr/lib/chromium-browser/

    path to the above. It is where ubuntu's chromium package installs the same libs. I mean, opera checks for the ppapi flash in various locations in order to find it, so why not look for the widevine libs elsewhere? Editing these files to add the proper path, as far as I know, breaks opera because it somehow checks the "originality" of them and fails to start.

    And all that is just a part of a bigger discussion about customizability, e.g. the default search engines follow the same rules and cause the same problem if their file is altered.

  • Solution to this problem is simple - just turn off Opera Turbo mode. Yeah, it was that easy.

  • @yaute Is this solution still working for you? It worked for me for some time but now it doesn't although I have both files under /opt/google/chrome

  • @yaute didn't work. I am running Manjaro with the latest Opera.
    I mean ffs this issue has been plaguing Opera for years, years and nobody does a thing. Netflix does not work on Opera (Linux) out of the box and this is the only single reason why I don't use this browser. I can understand that Opera does not give a damn for those poor 3% Linux users. But please do invest some of your precious time to write at least a tutorial or howto or am I asking too much?

  • @tastymineraler Same thing with Ubuntu and Majanro here.
    Sometimes i fixed this just putting widevine files on /opt/google/chrome, but did't work now.

    I used Opera 52 on Ubuntu and Opera 51 on Manjaro.

  • @tastymineraler IMHO, any browser that is considered to compete with Chrome or Firefox should be able to play Netflix and other sites with movies. It is a big part of browsers' use nowadays and I cannot imagine a modern browser without that functionality.

    BTW, it works in Vivaldi out of the box.

  • I have the same problem - I think.
    Widevine files (libwidevinecdm.so & widevine-1.4.8.1008) are in /opt/google/chrome, I used this script to install them:
    https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1#file-non-vivaldi-readme-md

    If I use a user agent switcher, Netflix loads and neither gives me a widevine error nor redirects me to the support site (https://help.netflix.com/en/node/23742).
    But the problem is that the video is loading forever (https://imgur.com/WWyH4vt).
    And it doesn't matter if I have Chrome installed or not, i. e. if there's an additional libwidevinecdmadapter.so file, the video will still load forever. The widevine_config.json file is also configured correctly.

    I don't know what I'm doing wrong...
    Any help is appreciated 😄

  • Hi, I found a solution, just follow my small how to. 🙂

    1. Put files libwidevinecdm and libwidevinecdmadapter to /opt/google/chrome
      If that folder doesn't exist then create it. If you don't have those files you can
      download them from my googledrive
      libwidevinecdm
      libwidevinecdmadapter
    2. Install User-Agent Switcher addon and setup it to chome Linux and the highest chrome number
    3. Watch Netflix 🙂