Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Just about all videos won't play!

  • Before I start writing about apt-mark and other apt kung-fu, what do you mean with this bit

    Tried all solutions, I have chromium codecs repo and copy libmpeg from chromium codecs into Opera dir

    Which is that "chromium codecs repo" you mention? And which distro are you on?

  • Everyone having problems with videos on Twitter (or GIFS) or with the H.264 codec videos. I'm running Opera 52 for Linux (Deepin 15, Ubuntu based).

    I downloaded the last libffmpeg version from this github repo:

    Just placed in the /usr/lib/x86_64-linux-gnu/opera and restarted Opera. All working like a charm! I've been searching for solutions like last 2,3 hours and finally found that solution. Hopes that helps some other Linux buddies here! 🙂

  • @dawy Thanks for that link. I downloaded it and tested it out. It works fine. However, it seemed a little big because it is unstripped. I stripped mine by strip -s first and that knocked it down to 2.5 megabytes. That is not necessary though.

  • Under Arch Linux and probably more the package name to fix this problem is "opera-ffmpeg-codecs" install that package and restart the Opera browser and the issue should be resolved.

  • For the ubuntu or ubuntu-based, this
    should work for those not wanting to manually drop a lib in the opera dir or opera/lib_extra dir.

  • Post for reference:

  • Here we again!

    Made the mistake of updating to Opera 52.0.2871.99 - Stable- Opera is up to date - on Ubuntu 16.04.4 LTS (x86_64; Unity), just a few minutes ago and now just about all videos DON'T play!

    Videos played fine before updating Opera......

  • Did your distro upgrade chromium and its dependencies (i.e chromium ffmpeg codecs) to version 66.x? Packages-ubuntu-com reports that chromium is still on version 65 for ubuntu 16.04.

    For the record, the latest update of opera stable (52, based on chromium 65) was on April 25th while chromium was updated to v 66.x on April 17th, so yes, things would and did break after all.
    In fact, I am amazed that there has been no complaint earlier.

    Please check the thread on my signature for the connection between the vesions of opera and chromium and you will understand.

  • @jimunderscorep
    Synaptic says: chromium-codecs-ffmpeg-ex 66.0.3359.159-OubuntuO.16.04.3 are installed. Description: Extra ffmpeg codecs for the Chromium Browser.

    That said videos still do not play.

    Also noted in Synaptic there are: chromium-codecs-ffmpeg 66.0.3359. 139-0ubuntu0.16.04.3 Description: Free ffmpeg codecs for the Chromium Browser that are not installed. When trying to install these Free ffmpeg codecs Synaptic says the Extra ffmpeg codecs will be removed first to be replaced by the Free ffmpeg codecs. So I left the Extra ffmpeg codecs in place.
    Was that the correct thing to do?

    Well just got done. Did remove the Extra x66 ffmpeg codecs and replaced them with the Free x66 ffmpeg codecs. Then restarted Opera 52 and videos still will not play with the Free ffmpeg x66 codecs either.

  • That's exactly what I said above and what I describe at the other thread.

    You have opera 52 (based on chromium 65) and chromium ffmpeg codecs 66, and these things do not work together. Wait until opera 53 is released, it will be based on chromium 66 and it will obviously work with chromium ffmpeg codecs 66. And a few days later, chromium will be updated to 67 and the circle of whining will start over 😛

  • @jimunderscorep

    Made another interesting discovery related to this. You know how some sites like Yahoo, will not show you their videos unless your ad blocker is disabled. Well discovered some of these sites also will not play vids if you are in 'Private Browsing' mode, or using Opera VPN! Was playing around with this and found some sites play video well until you go into 'private browsing' or turn on Opera VPN, which causes videos to no longer play. It happens and seems to vary from site to site.

  • First of all, opera 53 was released a few hours ago, which is based on chromium 66 and it should work with chromium ffmpeg codecs 66.

    Second, opera's poor html5 support is irrelevant to its adblock and its vpn. It is a "flaw" that is built in in the app itself and it is reproducible with those 2 disabled.
    For the record, I use neither opera's vpn, nor its adblock at all. I use ublock origin for my ad blocking needs and that's all.

  • 65.0.3325.181 version of still works, even with:

    Browser identification
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3371.0 Safari/537.36 OPR/54.0.2920.0 (Edition developer)

    and also
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.117 Safari/537.36 OPR/53.0.2907.31 (Edition beta)
    a couple of "V's" at 65.

    So, still good for now. Those newer v67's tend to be linked to glibc 2.27. When those are used on system with glibc 2.26, browser won't start.
    The Xenial versions are compatible for debian 9.x.

  • What distro are you on?

  • @jimunderscorep

    For the record, I use neither opera's vpn, nor its adblock at all. I use ublock origin for my ad blocking needs and that's all.

    Just got Opera 53.0.2907.37 and videos are running fine again.

    Been using the AdBlock extension that seems to perform well.
    Been using Opera's VPN some but not all the time when. Heck it's free and been running decent lately.

  • @cybrsaylr said in Just about all videos won't play!:

    Just got Opera 53.0.2907.37 and videos are running fine again.

    Because opera 53 is based on chromium 66, and you already have chromium ffmpeg codecs 66 installed, so it works. Plain math 😛

  • Tried all but nothing worked!
    Copying to opera directory force opera to crash.

    Sooo annoying! Can not use a Browser without showing Videos!

    It is unprofessional and i will deinstall and never use Opera again!

    I am a software engineer and developer on my own and i never would accept such a behaviour of one of my applications...

    no good work!!!

  • Same here. Worked fine till a day or two ago. Now, no videos play. Certain sites tell me to enable adobe flash even. Version:57.0.3098.102 on Linux Mint 18.3

  • @silverfox66 The ubuntu-like distros may need this package updated:

Log in to reply