Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Swfs not opening, downloading instead

  • @sgunhouse As I said, it worked perfectly just 5 days ago. Did something change in between ? I have the latest flash plug-in, even installed it twice.

  • @kuna I'm having the same problem, started after the latest Windows 7 security update four days ago.

  • By the way, the whole game works perfectly without any problems, it's the files alone, which don't want to play

  • I have same issue, haven't managed to find anything helpful to fix it.
    Worked just fine a couple days ago, now they keep downloading.

  • In Opera 12, when visiting a direct link to an swf file (and or file with application/x-shockwave-flash mime type), Opera would load a page with HTML like:

    <embed type="application/x-shockwave-flash" src="" width="100%" height="100%">
    

    where the blank src="" would resolve to the document's address, which would be the link to the swf file.

    This would cause Opera to embed the swf file with the flash player so that the swf would play inside Opera.

    AFAIK, Chromium-based browsers like Chrome and current Opera don't do that and just offer to download the file.

    But, you said it worked fine a few days ago, so I don't know.

  • Ok, as far as I can see, Chrome users also have this problem.
    The problem is, that the site should load up and then ask, if it should download the .swf
    But in Opera there's nothing like that, not even asking, it starts downloading
    Maybe it will be fixed soon, at least I hope so
    There's some stuff having to be archivised before 2020

  • @kuna said in Swfs not opening, downloading instead:

    not even asking, it starts downloading

    There's an "ask where to save" checkbox in the settings that should allow you to cancel when it tries to download. It might help with that part.

  • @burnout426 Thanks, that's good to know. It still doesn't change anything (ok, something), I can't access the pages, so I don't do this. I'll wait for any response from the Support (wrote to them), so maybe there will be any feedback.

  • Looking on the net, if this did work fine in Chrome and Opera before, it's most likely due to changes Chromium made with the handling of flash.

    To check, download the Opera 48 setup file, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "Standalone Installation (USB)" and install. When that Opera opens up, immediately close it. Go into the Opera folder on your desktop and in the version folder, rename the opera autoupdate exe so that Opera doesn't update to 49 on you.

    Then launch that Opera and test. What you should see is that it works as expected.

  • @burnout426 Thank you kindly, this worked for me!

  • @burnout426 Thanks, it seems like it's the only way to so it, so far
    I hope they'll actually support Flash until 2020, not just abandon it, because "no one cares about these 15% of users", like Chromium actually did

Log in to reply