Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

None of the versions of Opera runs a site with flash even in the block exception list

  • Note also that Opera requires the 64-bit PPAPI version, not the plugin from Firefox (NPAPI).

  • @sgunhouse I added two screenshots.
    One of Opera Stable (could be Beta or Developer that I also use and have the same problem) and another one of Chromium.
    As Opera uses the Chromium project engine and if in Chromium the Adobe website says that Flash (in this case PPAPI) is installed, enabled and which version why Opera should do the same but does not?

  • @leocg Nope.
    It's redirect to https://get.adobe.com/br/flashplayer/

  • Flash used to work before in Opera? Maybe you could try those instructions?

  • I've had flash stop working only on Opera twice in the past. It's been a while so I don't remember if it happened during an update or what. I do remember that it was working on Chromium. Each time, I fixed it by updating Flash.

    Download the flashplayer from Adobe and extract the file libpepflashplayer.so from it. Copy it to /usr/lib/pepperflashplugin-nonfree

    I update flash that way now as it seems the switch to pepflash messes up updates.

    Hope that helps.

  • @leocg I long time ago I switched to adobe-flashplugin and everytime works great including now.
    It appears that something get wrong with opera but Chrome and Chromium works fine.

  • @minuteman I switched long time ago to adobe-flashplugin because that.
    And I ever maintain updated manually if necessary.
    And you forgot to mention that manifest.json its necessary to be updated too or cause a mess.

  • @minuteman If you take a deep look on the screenshots that I have uploaded you perceive that currently I'm using flash version 28.0.0.105 and this is a beta from adobe labs and it's the more recent.

  • These days, Chrome comes with Flash built-in. Chromium is another story, but Flash should work in Chrome as long as it is enabled.

  • @sgunhouse Yep.
    And to use the non-internal version just add the following list of keys getting like this (in the example it is in the Windows version being that in Linux is very similar):

    chrome.exe --disable-bundled-ppapi-flash --always-authorize-plugins --allow-outdated-plugins --ppapi-in-process --enable-nacl --ppapi-flash-path=c:\Windows\System32\Macromed\Flash\pepflashplayer64_28_0_0_105.dll --ppapi-flash-version=28.0.0.105

    Remember that specifically in my case both Linux and Windows this is the version that I have installed.
    And on both systems Opera (Stable, Beta or Dev) have the same problem even if the site is in the exception list to run flash content.

  • same issue for me in fedora 26 and opera 49.0.2725.39

  • @msxmaniac said in None of the versions of Opera runs a site with flash even in the block exception list:

    @sgunhouse Yep.
    And to use the non-internal version just add the following list of keys getting like this (in the example it is in the Windows version being that in Linux is very similar):

    chrome.exe --disable-bundled-ppapi-flash --always-authorize-plugins --allow-outdated-plugins --ppapi-in-process --enable-nacl --ppapi-flash-path=c:\Windows\System32\Macromed\Flash\pepflashplayer64_28_0_0_105.dll --ppapi-flash-version=28.0.0.105

    In case you're using Linux depending where the flash .so file.
    In my case for example the command line is like:

    /usr/bin/google-chrome-unstable --disable-bundled-ppapi-flash --always-authorize-plugins --allow-outdated-plugins --ppapi-in-process --enable-nacl --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version=28.0.0.105

  • @msxmaniac but the last versione of flash player is 27.0.0.187. Error or beta version? with opera 48.0 works correctly

  • @scorpion2782 The stable version yes.
    The beta version is 28.0.0.105 and works like a charm in Chrome/Chromium in Windows and Linux platforms.
    The great problem is that neither the exception list mechanism work on Opera. And Chrome/Chromium the exception list work.
    Simply that!

  • I conducted a test here and I think I have a clue as to what might be going on.
    I made it with Opera Stable updated (49.0.2725.39) in Linux environment X86_64.
    As I did the update now I made sure if the problem persisted, that is, of being ignored what was in the exception list of the flash and the answer was affirmative.
    I quit the browser, renamed the folder where the original profile was, and started the browser that created a new profile.
    I went straight to the adobe test page (https://helpx.adobe.com/flash-player.html) and it already appeared that it flash not enabled.
    I went into the settings and placed the URL in the exception list and reloaded the page "THAT WAS PERFORMED PROPERLY".
    I quit the browser and returned to the original profile and even removing and replacing this URL in the exception list does not work.
    From the result of this test I believe that there must have been some change in the structure of some file that stores the profile settings from one version of Opera to another and there is a transposition of these values ​​and functionalities leading to the non-functioning of the exception list of the flash plugin.
    This occurs in all 3 versions, either Linux or Windows.
    The most immediate workaround for those who do not save the settings in the cloud is to somehow even list them in a text file to list all open pages to manually re-type in the new profile.
    I would not run the risk of exporting data because it may happen that this bug is related to the data that will be exported which means more tests but I think enough for the developers of Opera to check it out, if they give the work of read these topics and all posts (I doubt)
    I did this manually (which gave me a hard time) and despite losing the history, bookmarks and addons installed the exception list NOW WORKS perfectly.

  • If need it, you may try if this fix your's too.

    PS:
    Just navigate to Linux in the FTP site.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • @zalex108 To solve this problem I simple delete the file "Preferences" that are located in different places depending if in Linux or Windows (I don't have a Mac).
    The issue is that for me I need to reinstall the addons, but the bookmark and history are preserved.
    So in my GNU/Linux installed system the file preferences stay in a path like:
    /home/username/.config/opera
    In Windows installed system the path is:
    C:/Users/username/AppData/Roaming/Opera Software/Opera Stable

  • @msxmaniac but the problem still remain... in adobe about page it's possible to auto add page in whitelist, in other site no.
    this is in my amazon page:
    0_1511189907428_Istantanea_2017-11-20_15-55-06.png

    i need to add manually every website that require flash? the "click to enable flash" don't works....

Log in to reply