Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera updated to 49 and now having flash player problems

  • @nvmjustagirl clicking the placeholder does nothing.
    http://www.ultrasounds.com/US.html - this doesn't work too.
    Allowing flash for www.ultrasounds.com has no effect.

  • @ripperfrvr
    if you have flash installed go here get.adobe.com/flashplayer/about/

    to enable flash looks like this

    0_1510911464729_1a.png

    If that does't happen then ya got troubles..

    works on all latest versions opera with vpn on or off

    Hope this helps

  • @leocg in Fedora 26 i cannot see any banner. and the whitelist exception don't work

  • @leocg Opera 49.0 simply does not support Flash. Revert to an older version if possible or use a different browser. It's not a Flash issue but an Opera one, and Opera seems to be unable or unwilling to fix it.

  • @leocg https://forums.opera.com/topic/23278/none-of-the-versions-of-opera-runs-a-site-with-flash-even-in-the-block-exception-list

    No buddy. It isn't true.

    In Chromium still working without exception list and in Google Chrome only if in the exception list and in Opera neither.

    All 3 versions in Windows or Linux.

    Now if the developers of Opera because the flash plugin is to be replaced over time consider as a feature Opera browsers no longer have any support right now even if the engine it uses does not have this restriction we have a point to be questioned.
    Or it's simply a design flaw that has been hard hit because most sites are migrating to HTML5 and few users are aware of it.
    What I'm saying that?
    Because neither the exception list work and this is no related to flash plugin anyway.
    And because in Chromium/Chrome the exception list work like a charm.

  • @msxmaniac I've tested it in Chrome and that's why I could say that Chrome behaves the same.

  • @johngoode Last time I've checked, Flash was working in Opera but you may need to manually add some sites as exceptions for Flash on them.
    So i guess I can say that Flash still works in Opera 49.

    In 51 I'm sure it works.

  • For some reason Opera 49 does not open the "Allow Flash dialog" on number of web sites. But I manage to get it work after all by adding those web sites on exception list. I try to report in details what worked for me.

    1. I have updated Opera to version 49.0.2725.39 (PGO) for Windows. In my case I use Windows 7.

    2. Because Flash did not work after update, I downloaded Adobe Flash Player 27,0,0,187 installer.

    3. I uninstalled all previous versions of Adobe Flash Players from my computer, just in case.

    4. I closed all browsers, and then installed Adobe Flash 27,0,0,187.

    5. I opened Opera, went to Flash settings (see the attached image), and added the URL address for each site where I wish to allow Flash.

    Flash_setting.jpg

  • @johngoode said in Opera updated to 49 and now having flash player problems:

    @leocg Opera 49.0 simply does not support Flash. Revert to an older version if possible or use a different browser. It's not a Flash issue but an Opera one, and Opera seems to be unable or unwilling to fix it.

    That's untrue.

    馃斀

    0_1510935909567_2017-11-17_171312a.png

    But there are some problems that has unknown causes.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • @leocg Well, buddy, I conducted a test here and I think I have a clue as to what might be going on.
    I made it with Opera Stable updated (49.0.2725.39) in Linux environment X86_64.
    As I did the update now I made sure if the problem persisted, that is, of being ignored what was in the exception list of the flash and the answer was affirmative.
    I quit the browser, renamed the folder where the original profile was, and started the browser that created a new profile.
    I went straight to the adobe test page (https://helpx.adobe.com/flash-player.html) and it already appeared that it flash not enabled.
    I went into the settings and placed the URL in the exception list and reloaded the page "THAT WAS PERFORMED PROPERLY".
    I quit the browser and returned to the original profile and even removing and replacing this URL in the exception list does not work.
    From the result of this test I believe that there must have been some change in the structure of some file that stores the profile settings from one version of Opera to another and there is a transposition of these values 鈥嬧媋nd functionalities leading to the non-functioning of the exception list of the flash plugin.
    This occurs in all 3 versions, either Linux or Windows.
    The most immediate workaround for those who do not save the settings in the cloud is to somehow even list them in a text file to relate all open pages to manually re-type in the new profile.
    I would not run the risk of exporting data because it may happen that this bug is related to the data that will be exported which means more tests but I think enough for the developers of Opera to check it out, if they give the work of read these topics and all posts (I doubt)
    I did this manually (which gave me a hard time) and despite losing the history, bookmarks and addons installed the exception list NOW WORKS perfectly.

  • @zalex108 said in Opera updated to 49 and now having flash player problems:

    @johngoode said in Opera updated to 49 and now having flash player problems:

    @leocg Opera 49.0 simply does not support Flash. Revert to an older version if possible or use a different browser. It's not a Flash issue but an Opera one, and Opera seems to be unable or unwilling to fix it.

    That's untrue.

    馃斀

    0_1510935909567_2017-11-17_171312a.png

    But there are some problems that has unknown causes.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

    Hmmm...

    I have to fix this comment.

    I've made the screenshot in an existent installation updated to O49 few days ago.

    Note that it's a StandAlone installation.

    --

    Right now I've downloaded the Online O49 full installer and made another StandAlone installation.

    • Flash won't work.
    • WiDevine hasn't been installed either.

    What has fix it:

    • Downgrade to latest O48 - noted that Flash worked again -.
    • Autoupdate to O49 - Flash on O49 still working -.
    • Copy WiDevine folder from a working Opera profile. For those who need it - unzip it-.

    Then,
    @Johngoode seems to be right as the installer seems to have a bug in it.

    My apologizes


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • @msxmaniac it can also be a case of broken profile or extension causing issues since with a clean profile there's no problem with Flash.

  • @zalex108 said in Opera updated to 49 and now having flash player problems:

    @zalex108 said in Opera updated to 49 and now having flash player problems:

    @johngoode said in Opera updated to 49 and now having flash player problems:

    @leocg Opera 49.0 simply does not support Flash. Revert to an older version if possible or use a different browser. It's not a Flash issue but an Opera one, and Opera seems to be unable or unwilling to fix it.

    That's untrue.

    馃斀

    0_1510935909567_2017-11-17_171312a.png

    But there are some problems that has unknown causes.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

    Hmmm...

    I have to fix this comment.

    I've made the screenshot in an existent installation updated to O49 few days ago.

    Note that it's a StandAlone installation.

    --

    Right now I've downloaded the Online O49 full installer and made another StandAlone installation.

    • Flash won't work.
    • WiDevine hasn't been installed either.

    What has fix it:

    • Downgrade to latest O48 - noted that Flash worked again -.
    • Autoupdate to O49 - Flash on O49 still working -.
    • Copy WiDevine folder from a working Opera profile. For those who need it - unzip it-.

    Then,
    @Johngoode seems to be right as the installer seems to have a bug in it.

    My apologizes


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

    It has fixed my regular Opera Stable installation too.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • @leocg I came to think of this possibility but the fact that caught my attention is that I always use 5 addons be in Chromium, Chrome or Opera and are always the same and always the same version since I always update them and the problem only exists in Opera.
    Incidentally Chromium is always a nightly snapshot straight from https://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html and I do not face this kind of problem with Chromium whose engine is used by Opera.
    Google Chrome is the unstable version that is always up-to-date and the exception list works.
    So if everyone uses the same engine. has the same addons installed that comes from the same place why is it that only in Opera causes problems?
    Because there is probably some bug that has gone unnoticed, since older profiles have this problem that the exception list of the flash is ignored or not executed in the latest versions.
    And because it occurs in all 3 versions on the Windows and Linux platforms (I do not have Macintosh to test) is probably something standard which helps to complicate a bit more but that's what makes the debug.
    The turn of the moment is with the developers.

  • @msxmaniac even with the same engines, those browsers may have different APIs and that's why extensions need to be ported to each one of them.
    And even if we discard the extensions, there's still the broken profile issue.

  • @leocg To solve this problem I simple delete the file "Preferences" that are located in different places depending if in Linux or Windows (I don't have a Mac).
    The issue is that for me I need to reinstall the addons, but the bookmark and history are preserved.
    So in my GNU/Linux installed system the file preferences stay in a path like:
    /home/username/.config/opera
    In Windows installed system the path is:
    C:/Users/username/AppData/Roaming/Opera Software/Opera Stable

  • @zalex108

    Auto update from 48 to 49, flash don't work for me (Windows 10 Pro x64)

  • @slackmonkey said in Opera updated to 49 and now having flash player problems:

    @zalex108

    Auto update from 48 to 49, flash don't work for me (Windows 10 Pro x64)

    After downgrade it before!?


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Test profile | Back up LinuxMacWin

  • @msxmaniac said in Opera updated to 49 and now having flash player problems:

    @leocg To solve this problem I simple delete the file "Preferences" that are located in different places depending if in Linux or Windows (I don't have a Mac).
    The issue is that for me I need to reinstall the addons, but the bookmark and history are preserved.
    So in my GNU/Linux installed system the file preferences stay in a path like:
    /home/username/.config/opera
    In Windows installed system the path is:
    C:/Users/username/AppData/Roaming/Opera Software/Opera Stable

    Yes, I tried the same workaround time ago and it worked.
    Additionally, I found also that enabling sync on another pc with the same build (my laptop) was returning the problem.
    Now I'm without Opera on that laptop...

  • @msxmaniac To check the path for the profile folder, where the 'Preferences' file is stored, go to Menu > About Opera or type opera://about in address bar.

Log in to reply