Opera crashes and will not start after upgrade (48)

  • Opera crashes and will not start since upgrade. Version is given as 48.0.2685.32
    Ubuntu (15.10) crash reporter states SIGABRT
    It doesn't allow me to copy and paste the crash details, and it appears that I can't include a screenshot here.
    Also in the crash reporter is "Unreportable reason - This is not an official Ubuntu package".

    Now looking for a way to convert bookmarks to use in Firefox, but Opera won't start to allow me to export them.

  • Similar problem. Upgraded an hour ago. Opera (mini) now doesn't work. uninstalled, reinstalled, New one doesn't start, says Can't connect. All other applications fine.

  • Ubuntu 15.10 is unsupported since July 2016, so probably opera wants a newer version of some library it can not find, so it crashes. So upgrade to 16.04 at least.

  • If you want to see what Opera says, open a terminal and start it from the terminal. Normally you'll see a number of messages anyway, so the output could be pretty long.

    You can do screenshots, but you need to upload them to some external site then embed them in your post. At least, until the forum update.

  • Ubuntu 15.10 is unsupported since July 2016

    Okay, but it showed the update & allowed me to install it.

  • I have installed a previous package version found in /var/cache/apt/archives.
    For anyone else having this problem this is what I did (after cd to the above directory):

    sudo dpkg -i opera-stable_47.0.2631.80_amd64.deb
    

    This will do for now. I have been intending to upgrade to a newer Linux OS but still need to make sure I have backed up some data which I have not finished doing yet.

  • It looks like it is libnss3. From the terminal:

    [1003/135841.876808:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
    #0 0x000001cbb477 <unknown>
    #1 0x000001cd05f1 <unknown>
    #2 0x0000021b7f16 <unknown>
    #3 0x0000020feab5 <unknown>
    #4 0x0000020a0bb8 <unknown>
    #5 0x000001ffd363 <unknown>
    #6 0x00000068bd6a <unknown>
    #7 0x00000068bcd2 <unknown>
    #8 0x000000775e68 <unknown>
    #9 0x000000c2019d <unknown>
    #10 0x000001d16f30 <unknown>
    #11 0x000001d11c43 <unknown>
    #12 0x7f9d5ff9e6aa start_thread
    #13 0x7f9d5f7c713d clone

    Discarded=1
    Aborted (core dumped)

  • It would be more useful to tell us which version of libnss3 is installed in ubuntu 15.10, like so

    apt-cache show libnss3 | grep Version

    because packages.ubuntu.com does not list your version's packages anymore.

  • The output of that command strangely shows two lines:

    Version: 2:3.23-0ubuntu0.15.10.1
    Version: 2:3.19.2-1ubuntu1
    

    In Synaptic it shows the installed version is 2:3.23-0ubuntu0.15.10.1

  • You can find which version comes from where with "apt-cache policy libnss3".
    However, both are too old now, because all the working repos of ubuntu (14.04, 16.04 and to 17.10) have 3.28 (2:3.28-whatever), so yes, an update is mandatory for you now.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.