Default search engine displays all the results in Spanish

  • What is your default search engine? If Google, it's using google.com or it's redirecting to some local Google page?

    What editor are you using to edit 'Local State'? I recommend using Notepad++.

    Also, did you change the site preferences to show results in English for you?

  • That's right, I'm using Google, and already tried to use google.com, it changed EVERY SINGLE time to google.es.

    Yes, I'm using Notepad++ for editing, after changed the file, went back to confirm, and it showed location":{"country":"us","countryfromserver":"US", which I assume the change is accepted, but still when I try to do a search, Spanish google came up and not in US, what else can I do?

    Yes, the preference has been changed too.

  • Here goes one more unhappy Google user, I'm replacing Google with DuckDuckGo, tired of doing things their way, regardless of user feedback, already dropped gmail, now it's Google search, Google will be the next MS!!!!

  • what else can I do?

    Try cleaning cache and cookies. Also disable geolocation for Google.

  • Can you please tell me how to disable Google's geolocation? I've tried cache and cookies to no avail. As far as I know, Google won't let you change it, I've tried also change settings, and also useless, everytime you shut down the pc, it goes back to Spanish, it's like a nightmare that never goes away.

  • Can you please tell me how to disable Google's geolocation?

    Did you ever allowed it? Check in settings > Sites > Local > Manage exceptions.

  • I don't remember allowing it, but you never know, those crappy sites are sneaky, they install/enable it by using small prints or during updates.

    Sorry, I don't have sites under setting, when I click on settings (right side bottom) in google search, I have the following options:
    Search settings
    Advanced search
    History
    Search help
    Send feedback
    but no Sites, if I can attach a screenshot, I can show you what I meant, are you using Windows 10? It shouldn't matter which OS, it's in the browser.

  • Sorry, I don't have sites under setting, when I click on settings (right side bottom) in google search

    We are talking about Opera's settings.

  • Sorry, under Settings > Websites > Location > Ask me when a site tries to track my physical location (recommended) was selected, now I changed it to Do not allow any site to track my physical location.

    Also, under Manage Exceptions there's one entry: https://www.google.es:443, and under Behavior shows block, so I assume it'll block Google ES to track me, right?

  • so I assume it'll block Google ES to track me, right?

    Yep but it may also mean that the redirection is not related to geolocation.

    Can you try adding google.com and see what happens?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.