Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

google search result changed display.

  • For anyone already using Tampermonkey, create a new script with the metadata below

    copy the browser identification from Opera > About Opera

    paste into metadata, remove OPR/ and everything after OPR/

    save and test google

    // ==UserScript==
    // @name       Google Fix
    // @namespace  
    // @version    0.1
    // @description  enter something useful
    // @include    *.google.*
    // @user-agent paste browser identification here
    // ==/UserScript==
  • Could you show me where to click please? I could not find it
    Yes, login and click in this button.

  • Could you show me where to click please? I could not find it
    Yes, login and click in this button.

    Thanks, I will do it!

  • Could you show me where to click please? I could not find it
    Yes, login and click in this button.

    I can not click, look here

  • I can not click
    Hmmm, try to "join" the discussion group first. (http://i.imgur.com/rDDcTIV.jpg)

  • I can not click
    Hmmm, try to "join" the discussion group first. (http://i.imgur.com/rDDcTIV.jpg)

    Thanks, it worked now 🙂

  • But why you don't want to use "Permanent Spoof List" and add only Google to it? 🙂 It seems to work well.

    Herrpietrus, I tried but it did not seem to work. If it worked for you tell me how and what you entered and where in the options. I tried all sort of variations and nothing changed! I gave up and thought to change the code. I also thought why is there not an option to change the default, and did it myself.

    The "User-Agent Switcher" for Chrome also has a right-click on the icon method for switching user agents - so if Facebook is squirrelly you can just switch them. So it's like the For-Opera-Extension "User-Agent Switcher" with the addition of automation.

  • I had to change the Default User-Agent from Opera on Windows to Chrome on Windows, because UA as Opera had more problems on other pages. It works perfectly, but so I seem to be Chrome, not Opera. 😞

  • They have just updated Opera to version 21, but didn't fix this problem! 😞

  • They have just updated Opera to version 21, but didn't fix this problem! 😞

    It is not an Opera problem.

  • Well>> They have just updated Opera to version 21, but didn't fix this problem! 😞

    It is not an Opera problem.

    Well, in User-Agent Switcher, if you select Opera 10, it still works. So my guess is google doesn't recognize Opera as Opera. It identifies it as Internet Explorer 6, or 7, or 8...

  • I can't solve the problem neither with user-agent switcher nor deleting cookies. Now there's also another problem: when I search for a video by using google, when I click on a youtube result it can't load the page.

  • I am having the same problem, and the user agent switcher isn't a good solution for me. When I have the agent switcher enabled, gmail will not load and other sites are slow or display in an outdated format. Is there any way to automatically enable the user agent switcher for google only, and have it disable itself for all other sites? I am not tech-savvy in the least and am having a hard time figuring this out. Thanks... this issue really blows.

  • Select an updated browser in the extension. If "Chrome on Windows" isn't working add a new one in the extension options and use that.
    E.g. Name: Blah
    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.132 Safari/537.36

  • rafaelluik: Thanks for the suggestion! Unfortunately, I still have the same issues after following your instructions... I am thinking about switching search engines altogether until this is fixed 😕

  • Well>> They have just updated Opera to version 21, but didn't fix this problem! 😞

    Google is blocking Opera, if you choose Chrome user agent, you get the new interface of Google.

  • Well>> They have just updated Opera to version 21, but didn't fix this problem! 😞

    Google is blocking Opera, if you choose Chrome user agent, you get the new interface of Google.

    Is this a bug or an intentional/malicious feature? Google displays the current version in Opera 12, and gmail and other google sites work fine for me in Opera 20. If Google was blocking Opera on purpose, wouldn't these be affected too?

  • I have Opera 12 installed too, and it works just fine with it. So Google is not targeting Opera - or is only targeting this version... Is that likely? And if so can't Opera 'fix' it?

  • Well>> They have just updated Opera to version 21, but didn't fix this problem! 😞

    Google is blocking Opera, if you choose Chrome user agent, you get the new interface of Google.

    Is this a bug or an intentional/malicious feature? Google displays the current version in Opera 12, and gmail and other google sites work fine for me in Opera 20. If Google was blocking Opera on purpose, wouldn't these be affected too?

    The user agent of Opera Presto and Blink are different. They are blocking the new one. If Opera fix that, the would use some patch in browser.js maybe.

  • Google appears to be mostly back to normal on Opera 20 now. I still don't see the camera icon on Google image search that allows you to search by an image's URL. Hopefully google is continuing to work out the bugs.

Log in to reply