Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Google Maps not working

  • Mostly on battery power with Opera battery saver on.

    Did you check with it off?

  • maps.google.com bug is unrelated to battery settings. Currently connected to wall power.

    Intel HD Graphics set to maximum performance.

    With hardware acceleration disabled, the issue remains.

    Chrome and Firefox does fine without.

  • I also have a problem with google maps in 46.0.2597.32 (PGO) version.

    Turning off or turning on hardware acceleration doesn't help.

  • With hardware acceleration disabled, the issue remains.

    Why did you disable it? Some things depend on hardware acceleration to work.

  • Are you implying that hardware acceleration enabled should be a requirement for a major site such as maps.google.com to work normally on Opera?

  • Are you implying that hardware acceleration enabled should be a requirement for a major site such as maps.google.com to work normally on Opera?

    Not sure about Google Maps itself.

    Anyway, hardware acceleration is enabled by default so if someone has it disabled should be due to some issue.

  • Thanks leocg, I’m good. πŸ™‚

    On Chrome, Google Maps has normal basic functionality with HWA disabled, as did Opera prior to 46 update – that’s why I thought some users might be confused.

  • The google maps lite works properly

    https://www.google.de/maps/?force=lite

  • same here, with or without hardware acceleration. Version 46.0.2597.26314
    To me this is a bug. before no issues, after last couple of updates, maps is not working. One should not bother to turn HWA on or off. Similar using the "lite" version. Can folks from Opera share their lights?

  • Issue is gone after I turn on h/w acceleration.

  • Cheers!
    I have this same problem and tried turning off the Hardware Acceleration, and it sure solves the issue BUT then I realized the Facebook Messenger stops working πŸ˜•
    Also it seems that the browser works a little slower.
    I find it so weird that there is no bug solution yet, as I guess thousands of people might be having the same issues!
    So I am using Google Maps LITE for now, so I can use Facebook Messenger.

    PS: It's my first time commenting here. So I would take the chance to praise the work of Opera that I use since the version 9 and loving it! πŸ™‚

  • Same problem here. If I enable HW acceleration, google maps works, but then scrolling becomes very slow in Opera (no matter Smooth Scrolling is on or off). That's why I've always disabled HW acc. in the past.

  • When enabling HWA I loose a lot of Youtube functionality, most of the videos turn green. Of course if there's a simple solution to that I could leave HWA permanently on.

  • I have exactly the same. On my HP Spectre PC my Opera browser shows a flickering/blinking round mouse pointer / cursor.
    I tried all kind of settings in Opera, no help. I fully totally uninstalled Opera, downloaded new and installed again. No help.
    And indeed the Lite Mode of google maps works fine.
    Full Mode works fine in other browsers too.

    The problem is that other sites, that embed google maps, have the same problem. They show the blinking cursor and load very slow, or not complete or not at all.

    The only thing I can remember was when I first opened Google Calendar (or was it Google Mail) in Opera, it asked something like "do you want to follow? all links to calendar?" (or something like that). Of course like every user, you glance at the message and click yes immediately. 😞

    So this is a Opera issue I would say.

    Anyone any suggestions?

  • I had similar issues with or without HWA. I disabled my VPN (Surfeasy) and Google Maps worked again.

  • Tried all of the above but nothing worked. Finally Google launched the page in 'Lite' mode and that worked a treat, read more here;

    https://support.google.com/maps/answer/3031966?p=switch_to_lite&hl=en-GB&visit_id=0-636358110248834783-1486033833&rd=1

    Hope this helps someone?

  • It's not only with Google Maps. The issue seems to appear when any map service is active, even if it's embedded in a website. Enabling Hardware Acceleration worked for me.
    Thank you for opening the thread, vegelund!

  • Hello folks,

    I'm a bit late to the party - but I fully concur.

    For me also HWA "on" solves this problem. But then (I've just posted a new thread) all CNN-videos get stuck within seconds and only manually going back ~2 seconds will play them for another ~5 seconds. So this site turns unusable with this setting.

    Could you please check if that same consequence occurs on your systems?

    Until Opera 45 you could then turn HWA "off" - and CNN-videos would play normally BUT "Google maps" (and some other sites) would work well with only minimal delay.

    Unfortunately (as I've explained in the new thread) until Opera 45 videos would not play "full-screen" on a 4K-display - but would rather play in native resolution in the upper left corner instead. This issue seems now resolved in Opera 46 - but at what cost! Without HWA even pretty basic sites seem to load (blinking busy cursor) for 15 seconds and more and sites like "Google maps" will never proceed to the final navigational layers.

    So please could you all check out if with HWA set "on" your CNN-videos get stuck within seconds, too?

    greetings

    Tom

  • Hello folks,

    could someone please give the CNN-videos a try with the HWA setting to "on"? Do they hang or will they play normal? Anybody?

    greetings

    Tom

Log in to reply