Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Every time i open a new tab its just a blank white or black screen

  • Hi @zalex108 - your Clean Profile link goes to the Opera for Windows FAQs.

  • Hi @zalex108 - your Clean Profile link goes to the Opera for Windows FAQs.

    Try with a Clean Profile, just use Apple paths and Finder.

    There's not an Apple link, https://forums.opera.com/category/12/opera-for-mac, because of this I've added
    just use Apple paths and Finder.
    they are the same steps for every desktop OS (if I'm not wrong), so should be easy to do as well.

    About Opera | File Explorer (any of them)

    BTW, you can test with a private window and or cleaning browsing data.

  • @Xgipper | @Nigelthebald

    Could you clarify how to try with a clean profile please? What does "just use Apple paths and Finder" mean? Currently under Paths I have:
    Paths
    Install: /Applications/Opera
    Profile: /Users/my user name/Library/Application Support/com.operasoftware.Opera
    Cache: /Users/my user name/Library/Caches/com.operasoftware.Opera

    Info from the guide:

    ···········································································

    How do I create a clean profile

    Go to Menu > About Opera and take note of the path to the Opera's profile folder

    Using Windows Explorer (or a similar software), locate that folder and rename it to whatever you want

    Open Opera for a new profile folder to be created

    ···········································································

    > Profile: /Users/my user name/Library/Application Support/com.operasoftware.Opera

    Go there and rename com.operasoftware.Opera ==> Eg: "Date".com.operasoftware.Opera - 03.09.2017.com.operasoftware.Opera

    Once Opera starts it will create a new com.operasoftware.Opera folder.

    There are info in the forums to create different profiles in the same installation, keep a clean profile alive with it's shortcut save time if any issue happens.

  • Mention @Xgipper | @Nigelthebald - To inform via eMail.

    PS: The upper post was edited to add the mentions but after create the post not sure if mentions will be detected.

  • @zalex108, the path goes either: Users/(myname)/Applications (and then nothing)

    or (disc name)/Library/Application support/ (and then no entry for com.operasoftware.Opera)

    although "About Opera" says that the profile path should be:

    /Users/(myname)/Library/Application Support/com.operasoftware.Opera

    Any suggestions as to how I can get round this anomaly? (And thank you for your efforts so far. The problem seems to be affecting a number of users.)

  • ditto what xgipper 4:58PM said.
    H091530E Mar 2017
    I'm using Opera v37. Mac OS 10.7.4, 2011 model.
    I've run the Disk Utility to Verify/Fix Permissions, Cleaned my history on opera and restarted the mac and then opera.
    Some websites work, other flicker on, then go right to a white screen with the url displayed in the finder field.
    Went to your Opera help page, using your browser v37. It flicked on, then white screened out. This has just
    started happening yesterday. I am unable to use the free VPN version (not availabale for my OS). Any suggestions
    would be helpful at this time. Thanks in advance. शेर

  • If I remember it's a hidden path, you should unhidde system files, then it will be available.

    Check the link options to find the appropriate for your OS version and check again.

  • Thank you, @zalex108 - I have now been able to rename com.operasoftware.Opera using Gotoes (Funter was not supported on my OS).

    However, this has not sorted out the problem, and means I have now lost all my bookmarks and cannot login to my email in Opera, since the login page is one that loads blank.

  • Thanks for the support. I did this inc displaying the hidden files:

    "Go there and rename com.operasoftware.Opera ==> Eg: "Date".com.operasoftware.Opera - 03.09.2017.com.operasoftware.Opera"

    but, although the first time Opera opened it seemed to think it was a new installation and it then did display Facebook, one of the ones I was previously having trouble with, now it is all white again, as are other sites I commonly use. (BBC.co.uk displays a portion of the content!; Google works; life's too short to test every website 🙂 ).

    Guess I'll try it once more when I have some time, cos it's a bit of a faff!, and then possibly have to see if I can find another browser that will work on my system, alongside Firefox which I also use (but need two!).

    BTW there's an app that makes it simpler to view hidden files on a mac if it helps anyone (I believe free or donate) - http://gotoes.org/sales/ShowHiddenFilesMacOSX/How_To_Show_Hidden_Files.php

  • @xgipper, same problem for me, and I used the gotoes option you've suggested.

    @zalex108, I now have both a dated and an undated version of com.operasoftware.Opera - would it be safe to delete the dated copy to see if that restores what I've lost? (See my last reply.)

  • xgipper are you able to sign in to your Opera account? I'm unable to since this problem has started.
    Also, several site are okay: Google Maps, Calendar, Trip Advisor, Google News, Gmail...

  • Hi Xgipper, ditto for me too. Almost identical problem except my Macbook Air is OS X 10.7.5 64-bit. Everything else you describe is absolutely identical even down to the fixes above not solving the problem.
    As an aside Opera is working fine on my Windows Desktop PC (on which I'm submitting this post)

  • @peciacake I don't think I have an Opera account, other than on this forum. What is it for?

    Yes Google search and analytics work for me using Opera, but nothing else I usually use it for (only a few sites, which as described appear to load, and then promptly disappear, although some partially load). Also with the new preferences file, perhaps obviously, it no longer remembers my passwords or bookmarks, which is an additional annoyance, so as this change hasn't made any difference I may revert to the former one when I have time - unless another solution rears its head.

    Thanks.

  • Oh Well, 2 things:

    1 In the Paths, follow to the Cache and rename it too, maybe there is something there messing the new profile.

    2 I forgot to mention to use Sync to keep a copy of your bookmarks, passwords (if you allow that) and some other stuff, just rename / delete cache, then depending on the result go back to renamed profile, give back the original name, test and Sync to the cloud. After that depending on which profile works, just delete the other or create a shortcut to a testing profile.

    More info about files to keep and back up.
    BackUp Opera files

  • @zalex108 - success! I decided to try deleting the UNDATED folder in application supprt, relaunched Opera, and now at least two of the previously blank pages work perfectly.

    So now I have dated folder in application support and undated in Cache (the "date cache" suggestion was unnecessary).

    It might have been helpful if you had mentioned that one should delete the undated folder in application support, but we got there in the end. I still am bookmarkless, but I will add them as I go along.

    Thank you for your help!

  • More info about files to keep and back up.
    BackUp Opera files

    There is the info about files to back up, in this case, Bookmarks.

    Despite the folder rename, "bookmarks" file should still be there, just needs to be copied to the current profile.

    If your current folder it's the original folder, then the "bookmarks" file maybe it's renamed to "Bookmarks_1" anyway should exist another "copy" called "Bookmarks.Bak", just find which of them it's in the profile, make a bckp of the file, and rename to "Bookmarks".

    Don't forget to use Sync too. 😉

    @zalex108 - success! I decided to try deleting the UNDATED folder in application supprt, relaunched Opera, and now at least two of the previously blank pages work perfectly.

    I will Glad once everything will be Ok again 😉

  • Same problems here. Sites flicker and dissapear.
    If I disable the adblocking some sites that previously dissapeared display, others still dont.
    I did not perform any updates, opera just started this behaviour a couple of days ago, so what changed? Does the adblocker refer to an online database that since recently describes some pieces of code as ads (as someone noted: even opera.com wont load)?

    I will study the instructions here and see if they work for me, but also I would like to understand what causes the problem, clearly more people are affected. Peace!
    Mac OS X 10.8.5 64-bit

  • I been using various Mac computers, for the last 15 years, and never once have I ever suffered from any kind of problem or virus, etc. Version: 37.0.2178.54 - Opera is up to date
    Update stream: Stable
    System: Mac OS X 10.8.5 64-bit

    I started to experience the same problem, yesterday, on my Mac. I get a quick flash of a website, then a blank screen. Strangely enough, OANDA, the currency Converter website, loads up, no problem, and still works. https://www.oanda.com/currency/converter/

    The Ad Blocker keeps popping up, on websites that it never used to. Thankfully, Google and Gmail are not unaffected, but I've had to use Chrome, to come on here, to register the problem.

    I've also started getting a plague of unwanted advertisement websites repeatedly popping up, mainly from those extremely annoying MacKeeper people, who don't seem to understand the meaning of 'Thanks, but NO THANKS!', and think that I should handover control of my computer to their software, carte blanche, for an ongoing monthly fee. I am still getting their Backup programme starting automatically, and invading my computer. I have to use 'Force Quit', in order to stop it dragging down my CPU.

    I like Opera, and really need to get it back working, again. Hopefully, some 'knowing person', will figure out it, and post a solution that doesn't loose all bookmarks. Cheers everyone.

  • I have mine sort of working again after deleting the opera folder in prefs and restarting it, although Facebook is missing the icons along the blue bar at the top. I didn't have time to try to understand the stuff about the cache, but I did spend a bit of time researching alternative browsers. If this really a widespread issue perhaps some kind of fix can be offered via an update, rather than people having to scrabble around hiding and unhiding system files and so on (and risk losing bookmarks gathered over perhaps years) when in a lot of cases users are perhaps not confident to get involved. Just my 2pth.

    PS Interestingly I have also had some issues with 'malwertising' which took over one of the sites I run, from pretty much the same time Opera went wrong, although I don't usually use Opera to view or administer that site, and I suspect the issue is something to do with Adsense code.

  • you can test with a private window and or cleaning browsing data.

Log in to reply