Opera for Android 42

  • Using latest Opera beta for Android there's endless loading loop on opera's forum page, cannot login, cannot use at all see in video https://youtu.be/8lxmYnDCr_k
    Have to write this post using different browser. Fix soon?

  • Using latest Opera beta for Android there's endless loading loop on opera's forum page, cannot login, cannot use at all see in video https://youtu.be/8lxmYnDCr_k
    Have to write this post using different browser. Fix soon?

    Opera Stable 42 does no longer play any H264 or VP9 video anymore.

    I urge the Opera team to blacklist Samsung Galaxy Note 2 N7100 and Samsung Galaxy Note 10.1 N8000 on Google Play and only allow these devices upto Opera 37.0.2 the last version before the overhaul. Reason, the new user interface is to demanding and every website stutters. I always have to revert back to Opera 37.0.2 since later versions behave as described and programmers at Opera perhaps forgot efficient programming. As long as Opera sync is allowed for Opera 37 on my devices I will use Opera. After that unfortunately Google Chrome ironically using 1 version higher as render engine is my only option left. Since Google Chrome doesn't stutter despite the latest shared render engine I regret to inform Opera programmers 'Your code is to demanding and far from optimal as an understatement. You have chosen like Microsoft does for rapid development instead of efficiency which is masked by people not knowing any better.' The law of Microsoft is 'The faster hardware becomes the slower our code is because rapid development is compensated by faster hardware so no one will notice'.

    Please blacklist mentioned devices. It harms Opera if they see your latest release. Especially compared to Google Chrome.

  • Using latest Opera beta for Android there's endless loading loop on opera's forum page, cannot login, cannot use at all see in video https://youtu.be/8lxmYnDCr_k
    Have to write this post using different browser. Fix soon?

    After deleting data, cache, cookies from browser's settings opera's forum worked fine but only one day. Today issue repeats. But if I open private browsing it's working fine there

  • glitch in opera: menu-settings-home page (in news section) there're black spots.
    [](https://postimg.org/image/n2gj81oux/' target='_blank)

  • The string for the setting is too long so it requires 2 rows, the second row doesn't really show except the top: Thats why it looks like spots.
    We should shorten the string or alternatively truncate it.

  • ad blocker still not working

    no answer?

  • Re:adblock

    Our adblocker is based on easylist (same used by ad-block pro) and should block the same as adblock browser or the adblock pro extension.

    However, for the adblocker to work properly in OfA you need to enable data savings and the adblocker feature in Settings.

    There are some cases when you would still get ads.

    • Some ad providers are whitelisted
    • if you have loaded a page without data savings enabled there is a chance that the ad content has been cached and if so, it will display.
    • If the content is stored on secured servers (https) we do not compress or block it due to security reasons since compression and blocking is done serverside (on turbo proxy).
    • Furthermore, publishers (websites who display ads) find new ways to display their ads to the users.
      Since its the only way for them to make money like sending the masked URLs to trick AdBlock List components or create new sites that is not in easy list.
  • The string for the setting is too long so it requires 2 rows, the second row doesn't really show except the top: Thats why it looks like spots.
    We should shorten the string or alternatively truncate it.

    And what about glitch with loading loop of opera's forum pages(posted here earlier)

  • Not related, happens in Windows too and in other browsers. Clear your cookies for opera.com then log in.

  • Re:adblock
    Our adblocker is based on easylist (same used by ad-block pro) and should block the same as adblock browser or the adblock pro extension.
    However, for the adblocker to work properly in OfA you need to enable data savings and the adblocker feature in Settings.
    There are some cases when you would still get ads.

    Some ad providers are whitelisted
    if you have loaded a page without data savings enabled there is a chance that the ad content has been cached and if so, it will display.
    If the content is stored on secured servers (https) we do not compress or block it due to security reasons since compression and blocking is done serverside (on turbo proxy).
    Furthermore, publishers (websites who display ads) find new ways to display their ads to the users.
    Since its the only way for them to make money like sending the masked URLs to trick AdBlock List components or create new sites that is not in easy list.

    ok thanks

  • Not related, happens in Windows too and in other browsers. Clear your cookies for opera.com then log in.

    😄 clear cookies 😄 I have to do that every time I wanna visit opera forum. It's nonsense

  • Also:
    Replicable issue with saved pages:

    • If you mark SOME saved pages then delete them then click to system back button and then on speed-dial page click to restore those deleted saved pages app crashes! (If you mark all saved pages this is not happening. It's also not happening if you perform restoration of SOME/ALL deleted saved pages in saved pages card.) See in video: https://youtu.be/ue9OIiszbd4
  • Do you have planned to add new features in opera for android ?

  • Re:adblock
    There are some cases when you would still get ads.

    Some ad providers are whitelisted
    if you have loaded a page without data savings enabled there is a chance that the ad content has been cached and if so, it will display.
    If the content is stored on secured servers (https) we do not compress or block it due to security reasons since compression and blocking is done serverside (on turbo proxy).
    Furthermore, publishers (websites who display ads) find new ways to display their ads to the users.
    Since its the only way for them to make money like sending the masked URLs to trick AdBlock List components or create new sites that is not in easy list.

    I get ads with Opera for Android which are blocked with Opera mini on the same websites. Data savings / ad blocking is enabled, cache is cleared. Any ideas?

  • To-Mr-Jona- ad blocker is not working it is not working since New Opera introduced with new UI, please fix this you people are telling reasons but we people need no reasons but perfect Browser I am using data saving mod and clear cache enabled ad blocker and I have done everything to get rid of this adds but they are showing up anyway almost In All websites the truth is adblocker is not working fix this. Opera is great Browser please don't make this worst .old Opera is good and works perfect but New Opera is all of bugs and not working perfectly. new UI (everyone hating)..

  • For Opera 42.3.xxxx on an LG LTE:

    When using the cliptray to cut/copy-&-paste, the Opera winndow shortens and the now empty area at the top becomes a black "bar". Getting the window back to use the entire screen takes closing and reopening Opera.

  • please add an option to use reader mode on other sites too instead of feed news sites

  • New loading page is really cool.

  • New loading page is really cool.

    Hmm, hasn't updated yet. Is the data savings switch more accessible now as it's shown in the pictures?

  • New loading page is really cool.

    It's like in Opera Mini.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.