Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Mini 18 final for Android

  • hi, no option to delete message due to duplicates, testing, etc?

  • There is a problem. If I try to write anything in a dialogue box & try to swipe forward my cursor Opera Mini takes the cursor to the start point of that writing post. (Such as: I tried to wrote something in twitter. after I tried to move the cursor it takes me to the start point) Such Annoying..

  • There is a bug since Vers.17. Sometimes when I open an old tab, only a blank site is shown. Then I push any button - nothing happens and after 5 seconds Opera Mini crashes. After re-opening it works fine.

  • When u download opera mini from Google Play Store, it can't be installed, all I get is "can't install opera mini" Can you please help me fix this problem?

  • When u download opera mini from Google Play Store, it can't be installed, all I get is "can't install opera mini" Can you please help me fix this problem?

    Please read this

  • Sir I've been also facing this problem since version 17.

    "There is a bug since Vers.17. Sometimes when I open an old tab, only a blank site is shown. Then I push any button - nothing happens and after 5 seconds Opera Mini crashes. After re-opening it works fine."

  • Sir, Please introduce auto page loader for facebook and twitter like UC have. I will be obliged for this.

  • Please introduce auto page loader for facebook and twitter

    What would be it?

  • opera mini not working.. getting err_ tunnel_connection_failed problem...

  • I missing the Separated Search Bar in the omnibar. Bring it back, would be the best.

  • why when I install a new version of operamini, all web page that I have saved, be lost? any one experience like this?

  • hi, A bug after re-logging in first account in gmail :

    Login first account, then login/changed to another account, then login first account name again - opera mini, then kept flipping between 2 URL addresses without stopping - blank pages still (my guess is, those are URL addresses of the former Gmail account and latter Gmail account respectively). This happens when extreme mode data saving is OFF - in fact even in older version of opera (v16, I think).

    I can access gmail under extreme saving and tried logging out (gmail was under first account) but pages flipping under non-extreme still occurs. Finally, I need to clean all cookies, to be able to login Gmail again (under non-extreme data).

    Another thing is that I can't open yahoo mail under extreme mode (blank page though URL is displayed). However, have no problem accessing yahoo mail under non extreme mode...problem occurs after opera v16, I think.

  • opera,

    I can accessed yahoo mail again under extreme data saving using v18 (latest update) again - don't know how but I encountered blank page under extreme mode this morning...

  • I can't find my saved page in memory card. Please design opera mini to save page in memory card and open it from there using opera mini-the same way as you do in opera mini for java.

    Please do that it will be enormously helpfull.

    If possible design opera mini to save page in .mht extension.

  • Why cannot I watch videos on youtube when I enable extreme mode?

  • didn't realize the developer again take out the file renaming dialogue box popping up in a file saving session!why!are we back to that design of opera mini 7.6.4?
    it is a regression!
    if it is to expedite the saving process, an option could be added to the settings, much as the saving location option. LET USERS CHOOSE IT!

  • for guy facing this
    problem:
    "There is a bug since Vers.17.
    Sometimes when I open an old
    tab, only a blank site is shown.

    --- just push the page downward to have opera refresh the page. it works for me all the while.

  • Say, does somebody know how to change the default search browser?

  • Say, does somebody know how to change the default search browser?

    Go to setting>apl & choose the default browser and then un tick "clear default"
    May help.

  • where did feeds go?

Log in to reply